Update to upstream version 13.0
- Remove RPM bug workaround - Convert patches to pom macros
This commit is contained in:
parent
57d830fa00
commit
24db2d70eb
@ -1,20 +0,0 @@
|
||||
--- guava/pom.xml 2012-02-22 14:59:24.000000000 +0100
|
||||
+++ guava/pom.xml-gil 2012-04-28 13:55:54.793020732 +0200
|
||||
@@ -84,7 +84,7 @@
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
- <plugin>
|
||||
+ <!--plugin>
|
||||
<groupId>org.codehaus.mojo</groupId>
|
||||
<artifactId>animal-sniffer-maven-plugin</artifactId>
|
||||
<version>1.7</version>
|
||||
@@ -104,7 +104,7 @@
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
- </plugin>
|
||||
+ </plugin-->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-javadoc-plugin</artifactId>
|
@ -1,26 +0,0 @@
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index d016fe2..3339700 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -2,11 +2,6 @@
|
||||
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
|
||||
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
- <parent>
|
||||
- <groupId>com.google</groupId>
|
||||
- <artifactId>google</artifactId>
|
||||
- <version>5</version>
|
||||
- </parent>
|
||||
<groupId>com.google.guava</groupId>
|
||||
<artifactId>guava</artifactId>
|
||||
<version>r09</version>
|
||||
@@ -25,6 +20,9 @@
|
||||
per the JSR-305 spec.
|
||||
</description>
|
||||
<url>http://code.google.com/p/guava-libraries</url>
|
||||
+ <properties>
|
||||
+ <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
|
||||
+ </properties>
|
||||
<issueManagement>
|
||||
<system>code.google.com</system>
|
||||
<url>http://code.google.com/p/guava-libraries/issues</url>
|
37
guava.spec
37
guava.spec
@ -1,15 +1,14 @@
|
||||
Name: guava
|
||||
Version: 11.0.2
|
||||
Release: 2%{?dist}
|
||||
Version: 13.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Google Core Libraries for Java
|
||||
|
||||
Group: Development/Libraries
|
||||
License: ASL 2.0
|
||||
URL: http://code.google.com/p/guava-libraries
|
||||
# git clone https://code.google.com/p/guava-libraries/
|
||||
# cd guava-libraries && git archive --format=tar --prefix=guava-11.0.2/ v11.0.2 | xz > guava-11.0.2.tar.xz
|
||||
# (cd ./guava-libraries && git archive --format=tar --prefix=guava-%{version}/ v%{version}) | xz >guava-%{version}.tar.xz
|
||||
Source0: %{name}-%{version}.tar.xz
|
||||
Patch0: guava-11.0.2-remove-animal-sniffer.patch
|
||||
|
||||
BuildRequires: java-devel >= 0:1.7.0
|
||||
BuildRequires: jpackage-utils
|
||||
@ -18,17 +17,12 @@ BuildRequires: sonatype-oss-parent
|
||||
BuildRequires: maven
|
||||
BuildRequires: maven-compiler-plugin
|
||||
BuildRequires: maven-dependency-plugin
|
||||
BuildRequires: maven-enforcer-plugin
|
||||
BuildRequires: maven-install-plugin
|
||||
BuildRequires: maven-jar-plugin
|
||||
BuildRequires: maven-resources-plugin
|
||||
BuildRequires: maven-surefire-provider-junit4
|
||||
#BuildRequires: animal-sniffer
|
||||
#BuildRequires: mojo-signatures
|
||||
|
||||
BuildRequires: jsr-305 >= 0-0.6.20090319svn
|
||||
BuildRequires: ant-nodeps
|
||||
BuildRequires: jdiff
|
||||
|
||||
Requires: jsr-305
|
||||
|
||||
@ -56,14 +50,10 @@ API documentation for %{name}.
|
||||
%setup -q -n %{name}-%{version}
|
||||
find . -name '*.jar' -delete
|
||||
|
||||
# guava/lib/jdiff.jar
|
||||
ln -sf $(build-classpath jdiff) guava/lib/jdiff.jar
|
||||
|
||||
%patch0 -p0
|
||||
|
||||
sed -i "s|<module>guava-gwt</module>|<!--module>guava-gwt</module-->|" pom.xml
|
||||
sed -i "s|<module>guava-testlib</module>|<!--module>guava-testlib</module-->|" pom.xml
|
||||
sed -i "s|<module>guava-tests</module>|<!--module>guava-tests</module-->|" pom.xml
|
||||
%pom_disable_module guava-gwt
|
||||
%pom_disable_module guava-testlib
|
||||
%pom_disable_module guava-tests
|
||||
%pom_remove_plugin :animal-sniffer-maven-plugin guava
|
||||
|
||||
%build
|
||||
|
||||
@ -74,7 +64,6 @@ mvn-rpmbuild install javadoc:aggregate
|
||||
# jars
|
||||
mkdir -p %{buildroot}%{_javadir}
|
||||
install -pm 644 %{name}/target/%{name}-%{version}.jar %{buildroot}%{_javadir}/%{name}.jar
|
||||
install -pm 644 %{name}-bootstrap/target/%{name}-bootstrap-%{version}.jar %{buildroot}%{_javadir}/guava-bootstrap.jar
|
||||
|
||||
# poms
|
||||
mkdir -p %{buildroot}%{_mavenpomdir}
|
||||
@ -82,18 +71,11 @@ install -pm 644 pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}-parent.pom
|
||||
%add_maven_depmap JPP-%{name}-parent.pom
|
||||
install -pm 644 %{name}/pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
|
||||
%add_maven_depmap JPP-%{name}.pom %{name}.jar -a "com.google.collections:google-collections"
|
||||
install -pm 644 %{name}-bootstrap/pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}-bootstrap.pom
|
||||
%add_maven_depmap JPP-%{name}-bootstrap.pom %{name}-bootstrap.jar
|
||||
|
||||
# javadoc
|
||||
install -d -m 0755 %{buildroot}%{_javadocdir}/%{name}
|
||||
cp -rp target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/
|
||||
|
||||
%pre javadoc
|
||||
# workaround for rpm bug 646523 (can be removed in F-18)
|
||||
[ $1 -gt 1 ] && [ -L %{_javadocdir}/%{name} ] && \
|
||||
rm -rf $(readlink -f %{_javadocdir}/%{name}) %{_javadocdir}/%{name} || :
|
||||
|
||||
%files
|
||||
%doc AUTHORS CONTRIBUTORS COPYING README*
|
||||
%{_javadir}/%{name}*.jar
|
||||
@ -105,6 +87,11 @@ rm -rf $(readlink -f %{_javadocdir}/%{name}) %{_javadocdir}/%{name} || :
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Tue Aug 7 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 13.0-1
|
||||
- Update to upstream version 13.0
|
||||
- Remove RPM bug workaround
|
||||
- Convert patches to pom macros
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 11.0.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user