diff --git a/.gitignore b/.gitignore
index 8d49f2f..05d590d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -10,3 +10,4 @@
/v25.0.tar.gz
/v28.0.tar.gz
/v28.1.tar.gz
+/v28.2.tar.gz
diff --git a/guava.spec b/guava.spec
index 86c9665..4cba094 100644
--- a/guava.spec
+++ b/guava.spec
@@ -1,6 +1,6 @@
Name: guava
-Version: 28.1
-Release: 2%{?dist}
+Version: 28.2
+Release: 1%{?dist}
Summary: Google Core Libraries for Java
# Most of the code is under ASL 2.0
# Few classes are under CC0, grep for creativecommons
@@ -42,6 +42,9 @@ find . -name '*.jar' -delete
%pom_disable_module guava-gwt
%pom_disable_module guava-tests
+%pom_xpath_inject pom:modules \
+"futures/failureaccess"
+
%pom_remove_plugin -r :animal-sniffer-maven-plugin
# Downloads JDK source for doc generation
%pom_remove_plugin :maven-dependency-plugin guava
@@ -55,12 +58,14 @@ find . -name '*.jar' -delete
%pom_xpath_inject /pom:project/pom:build/pom:plugins/pom:plugin/pom:configuration/pom:instructions "<_nouses>true" guava/pom.xml
-%pom_remove_dep -r :animal-sniffer-annotations
%pom_remove_dep -r :error_prone_annotations
%pom_remove_dep -r :j2objc-annotations
%pom_remove_dep -r org.checkerframework:
%pom_remove_dep -r :listenablefuture
+# This multiline annotation escapes the following annotation removal
+sed -i -z 's/@DoNotMock([^()]*)\n//' guava/src/com/google/common/util/concurrent/ListeningExecutorService.java
+
annotations=$(
find -name '*.java' \
| xargs fgrep -h \
@@ -79,9 +84,6 @@ find -name '*.java' | xargs sed -ri \
%mvn_package "com.google.guava:failureaccess" guava
-%pom_xpath_inject pom:modules \
-"futures/failureaccess"
-
%mvn_package "com.google.guava:guava-bom" __noinstall
%build
@@ -99,6 +101,9 @@ find -name '*.java' | xargs sed -ri \
%files testlib -f .mfiles-guava-testlib
%changelog
+* Fri Jan 24 2020 Marian Koncek - 28.2-1
+- Update to upstream version 28.2
+
* Tue Nov 05 2019 Mikolaj Izdebski - 28.1-2
- Mass rebuild for javapackages-tools 201902
diff --git a/sources b/sources
index 0735f02..d3d863c 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (v28.1.tar.gz) = de637e90accc67645b12d56e42d1249cf9bf32b3352a4e4114cf3d713a08d6e7933aec9f550bf406d6b96148a83498af6fc0f98ab950d28b14e31ffd56a67a1f
+SHA512 (v28.2.tar.gz) = 8fcb2b2c8045b04d81a3d201826c969ec9e0af1e7afbc0decc439e0e7036c24f1a355505990332ab89e4f0bf7e7dd7eab4d10ee2aef6d4b20726acfb1734c85d