Update to version 18
This commit is contained in:
parent
e1a943b7d2
commit
11a4bde037
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,5 +1,6 @@
|
|||||||
guava-r05.tar.bz2
|
/guava-r05.tar.bz2
|
||||||
/guava-r09.tar.bz2
|
/guava-r09.tar.bz2
|
||||||
/guava-11.0.2.tar.xz
|
/guava-11.0.2.tar.xz
|
||||||
/guava-15.0.tar.xz
|
/guava-15.0.tar.xz
|
||||||
/guava-17.0.tar.xz
|
/guava-17.0.tar.xz
|
||||||
|
/v18.0.tar.xz
|
||||||
|
@ -17,10 +17,10 @@ index 0f05f78..d5bd950 100644
|
|||||||
import java.io.Serializable;
|
import java.io.Serializable;
|
||||||
+import java.lang.annotation.Annotation;
|
+import java.lang.annotation.Annotation;
|
||||||
+import java.lang.reflect.AnnotatedType;
|
+import java.lang.reflect.AnnotatedType;
|
||||||
|
import java.lang.reflect.AnnotatedElement;
|
||||||
import java.lang.reflect.Array;
|
import java.lang.reflect.Array;
|
||||||
import java.lang.reflect.GenericArrayType;
|
import java.lang.reflect.GenericArrayType;
|
||||||
import java.lang.reflect.GenericDeclaration;
|
@@ -371,6 +373,22 @@ final class Types {
|
||||||
@@ -368,6 +370,22 @@ final class Types {
|
|
||||||
return false;
|
return false;
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
@ -43,6 +43,3 @@ index 0f05f78..d5bd950 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
static final class WildcardTypeImpl implements WildcardType, Serializable {
|
static final class WildcardTypeImpl implements WildcardType, Serializable {
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
||||||
|
27
guava.spec
27
guava.spec
@ -1,12 +1,11 @@
|
|||||||
Name: guava
|
Name: guava
|
||||||
Version: 17.0
|
Version: 18.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Google Core Libraries for Java
|
Summary: Google Core Libraries for Java
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: http://code.google.com/p/guava-libraries
|
URL: https://code.google.com/p/guava-libraries
|
||||||
# git clone https://code.google.com/p/guava-libraries/
|
|
||||||
# (cd ./guava-libraries && git archive --format=tar --prefix=guava-%{version}/ v%{version}) | xz >guava-%{version}.tar.xz
|
Source0: https://github.com/google/guava/archive/v%{version}.tar.gz
|
||||||
Source0: %{name}-%{version}.tar.xz
|
|
||||||
Patch0: %{name}-java8.patch
|
Patch0: %{name}-java8.patch
|
||||||
|
|
||||||
BuildRequires: java-devel >= 0:1.7.0
|
BuildRequires: java-devel >= 0:1.7.0
|
||||||
@ -18,6 +17,9 @@ BuildRequires: apache-ivy
|
|||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
|
# Use the same directory of the main package for subpackage licence and docs
|
||||||
|
%global _docdir_fmt %{name}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Guava is a suite of core and expanded libraries that include
|
Guava is a suite of core and expanded libraries that include
|
||||||
utility classes, Google’s collections, io classes, and much
|
utility classes, Google’s collections, io classes, and much
|
||||||
@ -33,7 +35,7 @@ Summary: Javadoc for %{name}
|
|||||||
API documentation for %{name}.
|
API documentation for %{name}.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
find . -name '*.jar' -delete
|
find . -name '*.jar' -delete
|
||||||
|
|
||||||
@ -56,12 +58,17 @@ find . -name '*.jar' -delete
|
|||||||
%mvn_install
|
%mvn_install
|
||||||
|
|
||||||
%files -f .mfiles
|
%files -f .mfiles
|
||||||
%doc AUTHORS CONTRIBUTORS COPYING README*
|
%doc AUTHORS CONTRIBUTORS README*
|
||||||
|
%license COPYING
|
||||||
|
|
||||||
%files javadoc -f .mfiles-javadoc
|
%files javadoc -f .mfiles-javadoc
|
||||||
%doc COPYING
|
%license COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 7 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 18.0-1
|
||||||
|
- Update to v. 18 (#1175401)
|
||||||
|
- Use %license
|
||||||
|
|
||||||
* Wed Oct 8 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 17.0-2
|
* Wed Oct 8 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 17.0-2
|
||||||
- Add alias for com.google.guava:guava-jdk5
|
- Add alias for com.google.guava:guava-jdk5
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user