Update to 4.4.1

Resolves: #2021061

(cherry picked from Fedora commit 14132faf40b55093248d64509574383dc7b4b1b2)
This commit is contained in:
Kalev Lember 2021-11-01 16:45:24 +01:00
parent af452c8a94
commit cbd8526288
4 changed files with 7 additions and 34 deletions

1
.gitignore vendored
View File

@ -23,3 +23,4 @@
/gtk-4.2.0.tar.xz
/gtk-4.2.1.tar.xz
/gtk-4.4.0.tar.xz
/gtk-4.4.1.tar.xz

View File

@ -1,29 +0,0 @@
From 552a4b2c82f41c1dbba410b825673cf67d089b68 Mon Sep 17 00:00:00 2001
From: Kalev Lember <klember@redhat.com>
Date: Mon, 23 Aug 2021 15:38:46 +0200
Subject: [PATCH] build: Fix detection for pre-compiled css files
The default theme changed from Adwaita to Default and this tripped up
the logic to detect if the tarball builds contain pre-built css files or
not. Fix this by looking at pre-compiled css files in themes/Default/
instead of themes/Adwaita/.
---
gtk/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gtk/meson.build b/gtk/meson.build
index fa66764c50..bfb5105fe5 100644
--- a/gtk/meson.build
+++ b/gtk/meson.build
@@ -842,7 +842,7 @@ gtk_gresources_xml = configure_file(output: 'gtk.gresources.xml',
theme_deps = []
# For git checkouts, but not for tarballs...
-if not fs.exists('theme/Adwaita/Adwaita.css')
+if not fs.exists('theme/Default/Default-light.css')
# ... build the theme files
sassc = find_program('sassc', required: false)
if not sassc.found()
--
2.31.1

View File

@ -16,15 +16,13 @@
%global __provides_exclude_from ^%{_libdir}/gtk-4.0
Name: gtk4
Version: 4.4.0
Release: 4%{?dist}
Version: 4.4.1
Release: 1%{?dist}
Summary: GTK graphical user interface library
License: LGPLv2+
URL: https://www.gtk.org
Source0: https://download.gnome.org/sources/gtk/4.4/gtk-%{version}.tar.xz
# Backported from upstream
Patch0: 0001-build-Fix-detection-for-pre-compiled-css-files.patch
BuildRequires: cups-devel
BuildRequires: desktop-file-utils
@ -211,6 +209,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%{_mandir}/man1/gtk4-widget-factory.1*
%changelog
* Mon Nov 01 2021 Kalev Lember <klember@redhat.com> - 4.4.1-1
- Update to 4.4.1
* Mon Sep 27 2021 Kalev Lember <klember@redhat.com> - 4.4.0-4
- Build with tracker support enabled (#1908874)

View File

@ -1 +1 @@
SHA512 (gtk-4.4.0.tar.xz) = de0b6508df3fa4523a7e54cf417ac31292c833346409ff89fd4daf886edad16ffe60b6ed77a85451bd36b96098c8437d56c6fd42daca33c52db8dc57a25753b6
SHA512 (gtk-4.4.1.tar.xz) = 4edf9c5c24a1853713dfabdf9a8853eca4477fdd64b391f55c25d8937bfa7e78fb2e357067dee30aebbc245a099244c637d07965a34a0bff51f090b8f45e3d16