Update to 4.12.1
This commit is contained in:
parent
cf2971f84b
commit
c336367d79
1
.gitignore
vendored
1
.gitignore
vendored
@ -47,3 +47,4 @@
|
||||
/gtk-4.11.3.tar.xz
|
||||
/gtk-4.11.4.tar.xz
|
||||
/gtk-4.12.0.tar.xz
|
||||
/gtk-4.12.1.tar.xz
|
||||
|
69
6250.patch
69
6250.patch
@ -1,69 +0,0 @@
|
||||
From 4d7277f72c8f4915f237e36982ffd7dfba524b15 Mon Sep 17 00:00:00 2001
|
||||
From: Xi Ruoyao <xry111@xry111.site>
|
||||
Date: Mon, 7 Aug 2023 18:00:34 +0800
|
||||
Subject: [PATCH] print: Revert "Start sorting apart includes" change for
|
||||
gtkprinteroptionprivate.h
|
||||
|
||||
The print backends needs the functions in gtkprinteroptionprivate.h to
|
||||
be exported.
|
||||
|
||||
Fixes #6003.
|
||||
---
|
||||
gtk/print/gtkprinteroptionprivate.h | 12 ++++++++++++
|
||||
1 file changed, 12 insertions(+)
|
||||
|
||||
diff --git a/gtk/print/gtkprinteroptionprivate.h b/gtk/print/gtkprinteroptionprivate.h
|
||||
index 82dd8739ba1..a7d8e8ad5b6 100644
|
||||
--- a/gtk/print/gtkprinteroptionprivate.h
|
||||
+++ b/gtk/print/gtkprinteroptionprivate.h
|
||||
@@ -27,6 +27,7 @@
|
||||
#endif
|
||||
|
||||
#include <glib-object.h>
|
||||
+#include <gdk/gdk.h>
|
||||
|
||||
G_BEGIN_DECLS
|
||||
|
||||
@@ -87,28 +88,39 @@ struct _GtkPrinterOptionClass
|
||||
void (*_gtk_reserved4) (void);
|
||||
};
|
||||
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
GType gtk_printer_option_get_type (void) G_GNUC_CONST;
|
||||
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
GtkPrinterOption *gtk_printer_option_new (const char *name,
|
||||
const char *display_text,
|
||||
GtkPrinterOptionType type);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
void gtk_printer_option_set (GtkPrinterOption *option,
|
||||
const char *value);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
void gtk_printer_option_set_has_conflict (GtkPrinterOption *option,
|
||||
gboolean has_conflict);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
void gtk_printer_option_clear_has_conflict (GtkPrinterOption *option);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
void gtk_printer_option_set_boolean (GtkPrinterOption *option,
|
||||
gboolean value);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
void gtk_printer_option_allocate_choices (GtkPrinterOption *option,
|
||||
int num);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
void gtk_printer_option_choices_from_array (GtkPrinterOption *option,
|
||||
int num_choices,
|
||||
const char **choices,
|
||||
const char **choices_display);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
gboolean gtk_printer_option_has_choice (GtkPrinterOption *option,
|
||||
const char *choice);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
void gtk_printer_option_set_activates_default (GtkPrinterOption *option,
|
||||
gboolean activates);
|
||||
+GDK_AVAILABLE_IN_ALL
|
||||
gboolean gtk_printer_option_get_activates_default (GtkPrinterOption *option);
|
||||
|
||||
|
||||
--
|
||||
GitLab
|
||||
|
100
6293.patch
100
6293.patch
@ -1,100 +0,0 @@
|
||||
From 090e01b3832c37bb3fd0af070650e942e287a3fc Mon Sep 17 00:00:00 2001
|
||||
From: Xavier Claessens <xavier.claessens@collabora.com>
|
||||
Date: Tue, 15 Aug 2023 13:35:46 -0400
|
||||
Subject: [PATCH 1/2] meson: Add wayland-client to gtk4-wayland requires
|
||||
|
||||
---
|
||||
gdk/wayland/meson.build | 3 +++
|
||||
meson.build | 17 +++++++----------
|
||||
2 files changed, 10 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/gdk/wayland/meson.build b/gdk/wayland/meson.build
|
||||
index d325b4edea2..c6e6236ca8e 100644
|
||||
--- a/gdk/wayland/meson.build
|
||||
+++ b/gdk/wayland/meson.build
|
||||
@@ -127,3 +127,6 @@ libgdk_wayland = static_library('gdk-wayland',
|
||||
link_with: [ libwayland_cursor, ],
|
||||
dependencies: [ gdk_deps, gdk_wayland_deps ],
|
||||
)
|
||||
+
|
||||
+# Used to generate pkg-config Requires
|
||||
+wayland_public_deps = [wlclientdep]
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 004333141c5..2217b947add 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -826,19 +826,15 @@ gsk_private_packages = [] # all already in gdk_private_packages
|
||||
pangoft2_pkgs = (wayland_enabled or x11_enabled) ? ['pangoft2'] : []
|
||||
gtk_private_packages = pangoft2_pkgs
|
||||
|
||||
-pkgs = []
|
||||
-pkg_targets = []
|
||||
-display_backends = []
|
||||
+enabled_backends = []
|
||||
foreach backend: [ 'broadway', 'macos', 'wayland', 'win32', 'x11', ]
|
||||
if get_variable('@0@_enabled'.format(backend))
|
||||
- pkgs += ['gtk4-@0@'.format(backend)]
|
||||
- pkg_targets += backend
|
||||
- display_backends += [ backend ]
|
||||
+ enabled_backends += backend
|
||||
endif
|
||||
endforeach
|
||||
|
||||
common_pc_variables = [
|
||||
- 'targets=@0@'.format(' '.join(pkg_targets)),
|
||||
+ 'targets=@0@'.format(' '.join(enabled_backends)),
|
||||
'gtk_binary_version=@0@'.format(gtk_binary_version),
|
||||
'gtk_host=@0@-@1@'.format(host_machine.cpu_family(), host_machine.system()), # FIXME
|
||||
]
|
||||
@@ -853,13 +849,14 @@ pkg_config.generate(libgtk,
|
||||
)
|
||||
meson.override_dependency('gtk4', libgtk_dep)
|
||||
|
||||
-foreach pkg: pkgs
|
||||
+foreach backend: enabled_backends
|
||||
+ pkg = 'gtk4-@0@'.format(backend)
|
||||
pkg_config.generate(
|
||||
filebase: pkg,
|
||||
unescaped_variables: common_pc_variables,
|
||||
name: 'GTK',
|
||||
description: 'GTK Graphical UI Library',
|
||||
- requires: 'gtk4',
|
||||
+ requires: ['gtk4', get_variable('@0@_public_deps'.format(backend), [])],
|
||||
)
|
||||
meson.override_dependency(pkg, libgtk_dep)
|
||||
endforeach
|
||||
@@ -904,7 +901,7 @@ endif
|
||||
|
||||
#### Summary ####
|
||||
|
||||
-summary('Display backends', display_backends, section: 'Components')
|
||||
+summary('Display backends', enabled_backends, section: 'Components')
|
||||
summary('Print backends', print_backends, section: 'Components')
|
||||
summary('Media backends', media_backends, section: 'Components')
|
||||
|
||||
--
|
||||
GitLab
|
||||
|
||||
|
||||
From d6a07cd61763d2e0fa4e111dad34f0762738ce6f Mon Sep 17 00:00:00 2001
|
||||
From: Xavier Claessens <xavier.claessens@collabora.com>
|
||||
Date: Tue, 15 Aug 2023 21:17:23 -0400
|
||||
Subject: [PATCH 2/2] meson: Add x11_dep to gtk4-x11 requires
|
||||
|
||||
---
|
||||
gdk/x11/meson.build | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/gdk/x11/meson.build b/gdk/x11/meson.build
|
||||
index 58d12bb8a1c..013d8b1d00c 100644
|
||||
--- a/gdk/x11/meson.build
|
||||
+++ b/gdk/x11/meson.build
|
||||
@@ -86,3 +86,5 @@ libgdk_x11 = static_library('gdk-x11',
|
||||
] + common_cflags,
|
||||
dependencies: [ gdk_deps, gdk_x11_deps, ],
|
||||
)
|
||||
+
|
||||
+x11_public_deps = [x11_dep]
|
||||
--
|
||||
GitLab
|
||||
|
@ -16,19 +16,13 @@
|
||||
%global __provides_exclude_from ^%{_libdir}/gtk-4.0
|
||||
|
||||
Name: gtk4
|
||||
Version: 4.12.0
|
||||
Version: 4.12.1
|
||||
Release: %autorelease
|
||||
Summary: GTK graphical user interface library
|
||||
|
||||
License: LGPL-2.0-or-later
|
||||
URL: https://www.gtk.org
|
||||
Source0: https://download.gnome.org/sources/gtk/4.12/gtk-%{version}.tar.xz
|
||||
# Backported upstream MR
|
||||
# https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/6293
|
||||
Patch0: 6293.patch
|
||||
# Backported upstream MR
|
||||
# https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/6250
|
||||
Patch1: 6250.patch
|
||||
|
||||
BuildRequires: cups-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gtk-4.12.0.tar.xz) = a69f82e1f021b1eb68e8723bc9003bfca0b5939fd3cc7cda87d7dde0b3e37bb39d9594cb93a73f54bd1cff1b63a1c459d1217e8df794c67fda50bf0b9b732826
|
||||
SHA512 (gtk-4.12.1.tar.xz) = 5a893d3d855b5f1cf5b2e3c1c5178cc25e4165288f1ecc257d8af5ac1f94fc70fce7be34cf4b0292acd6652e544dd989c0065c1287623b6d4a115a9974a441c9
|
||||
|
Loading…
Reference in New Issue
Block a user