Update to 4.1.1
This commit is contained in:
parent
f1d012984f
commit
b44aca8456
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
||||
/gtk-4.0.1.tar.xz
|
||||
/gtk-4.0.2.tar.xz
|
||||
/gtk-4.1.0.tar.xz
|
||||
/gtk-4.1.1.tar.xz
|
||||
|
@ -1,50 +0,0 @@
|
||||
From 1fbdfe340ec5108a8c5a1dd1db3442aad3d2e55e Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Garnacho <carlosg@gnome.org>
|
||||
Date: Thu, 18 Feb 2021 16:12:53 +0100
|
||||
Subject: [PATCH] gdk/wayland: Look for font settings recursively
|
||||
|
||||
Use the infrastructure already available to look up keys, instead.
|
||||
This does the right thing and looks up the setting across all
|
||||
sources.
|
||||
|
||||
Fixes: https://gitlab.gnome.org/GNOME/gtk/-/issues/3680
|
||||
---
|
||||
gdk/wayland/gdkdisplay-wayland.c | 13 +++----------
|
||||
1 file changed, 3 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/gdk/wayland/gdkdisplay-wayland.c b/gdk/wayland/gdkdisplay-wayland.c
|
||||
index 41e8b5f5a7..88fab19d55 100644
|
||||
--- a/gdk/wayland/gdkdisplay-wayland.c
|
||||
+++ b/gdk/wayland/gdkdisplay-wayland.c
|
||||
@@ -1590,15 +1590,11 @@ update_xft_settings (GdkDisplay *display)
|
||||
}
|
||||
else
|
||||
{
|
||||
- GSettingsSchemaSource *source;
|
||||
- GSettingsSchema *schema;
|
||||
+ TranslationEntry *entry;
|
||||
|
||||
- source = g_settings_schema_source_get_default ();
|
||||
- schema = g_settings_schema_source_lookup (source,
|
||||
- "org.gnome.desktop.interface",
|
||||
- FALSE);
|
||||
+ entry = find_translation_entry_by_schema ("org.gnome.desktop.interface", "font-antialiasing");
|
||||
|
||||
- if (schema && g_settings_schema_has_key (schema, "font-antialiasing"))
|
||||
+ if (entry && entry->valid)
|
||||
{
|
||||
settings = g_hash_table_lookup (display_wayland->settings,
|
||||
"org.gnome.desktop.interface");
|
||||
@@ -1622,9 +1618,6 @@ update_xft_settings (GdkDisplay *display)
|
||||
order = GSD_FONT_RGBA_ORDER_RGB;
|
||||
}
|
||||
|
||||
- if (schema)
|
||||
- g_settings_schema_unref (schema);
|
||||
-
|
||||
dpi = get_dpi_from_gsettings (display_wayland) * 1024;
|
||||
}
|
||||
|
||||
--
|
||||
2.29.2
|
||||
|
10
gtk4.spec
10
gtk4.spec
@ -16,17 +16,14 @@
|
||||
%global __provides_exclude_from ^%{_libdir}/gtk-4.0
|
||||
|
||||
Name: gtk4
|
||||
Version: 4.1.0
|
||||
Release: 3%{?dist}
|
||||
Version: 4.1.1
|
||||
Release: 1%{?dist}
|
||||
Summary: GTK graphical user interface library
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://www.gtk.org
|
||||
Source0: https://download.gnome.org/sources/gtk/4.1/gtk-%{version}.tar.xz
|
||||
|
||||
# Backported from upstream
|
||||
Patch0: 0001-gdk-wayland-Look-for-font-settings-recursively.patch
|
||||
|
||||
BuildRequires: cups-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: docbook-style-xsl
|
||||
@ -235,6 +232,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/gtk-doc
|
||||
|
||||
%changelog
|
||||
* Wed Feb 24 2021 Kalev Lember <klember@redhat.com> - 4.1.1-1
|
||||
- Update to 4.1.1
|
||||
|
||||
* Fri Feb 19 2021 Kalev Lember <klember@redhat.com> - 4.1.0-3
|
||||
- Backport upstream patch to fix a settings schema loading issue on Wayland
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gtk-4.1.0.tar.xz) = c86acb103528ff7e7a92d0656a4fcb9bb5c2b5f5aece34ad544a62e3d0f3b1f86af43e97bda79d210fb927e639c0fab32f2ded7411118d8091f28889f7e6aa94
|
||||
SHA512 (gtk-4.1.1.tar.xz) = dc2b33598ecfbb1e830d0e63e5658a3947ea5326063f91a75d4f57dd2fb1b345da71bfd6048c967110eaf100d4c0f6b05fac36a52f503fd06e968be40a5d8b1e
|
||||
|
Loading…
Reference in New Issue
Block a user