Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/gtk4.git#b2909fb1bf80f21cce2d2666692322514a1d04aa
This commit is contained in:
parent
070a18cb32
commit
9d31facd40
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
||||
/gtk-3.99.4.tar.xz
|
||||
/gtk-3.99.5.tar.xz
|
||||
/gtk-4.0.0.tar.xz
|
||||
/gtk-4.0.1.tar.xz
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 7d5826ccf7a8d5ad39f370a3f214e4811ca1075b Mon Sep 17 00:00:00 2001
|
||||
From: Jan Tojnar <jtojnar@gmail.com>
|
||||
Date: Sun, 27 Dec 2020 06:42:29 +0100
|
||||
Subject: [PATCH] build: Fix vulkan reference in pc file
|
||||
|
||||
A mistake in string concatenation caused the vulcan dependency to be omitted.
|
||||
|
||||
Fixes: https://gitlab.gnome.org/GNOME/gtk/-/issues/3517
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index bb58717f6a..60e7729a8e 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -723,7 +723,7 @@ if cairogobj_pkg_found
|
||||
endif
|
||||
|
||||
if vulkan_pkg_found
|
||||
- gdk_packages += 'vulkan'
|
||||
+ gdk_packages += ' vulkan'
|
||||
endif
|
||||
|
||||
pkgconf.set('GDK_PACKAGES', gdk_packages)
|
||||
--
|
||||
2.29.2
|
||||
|
@ -1,16 +1,3 @@
|
||||
diff --git a/gtk/css/gtkcssenumtypes.c.template b/gtk/css/gtkcssenumtypes.c.template
|
||||
index 063b8d0..cb4c9ac 100644
|
||||
--- a/gtk/css/gtkcssenumtypes.c.template
|
||||
+++ b/gtk/css/gtkcssenumtypes.c.template
|
||||
@@ -13,7 +13,7 @@
|
||||
GType
|
||||
@enum_name@_get_type (void)
|
||||
{
|
||||
- static volatile gsize g_define_type_id__volatile = 0;
|
||||
+ static gsize g_define_type_id__volatile = 0;
|
||||
|
||||
if (g_once_init_enter (&g_define_type_id__volatile))
|
||||
{
|
||||
diff --git a/gtk/gtktextchild.c b/gtk/gtktextchild.c
|
||||
index 4d5e30e..915b991 100644
|
||||
--- a/gtk/gtktextchild.c
|
||||
|
10
gtk4.spec
10
gtk4.spec
@ -16,15 +16,14 @@
|
||||
%global __provides_exclude_from ^%{_libdir}/gtk-4.0
|
||||
|
||||
Name: gtk4
|
||||
Version: 4.0.0
|
||||
Release: 3%{?dist}
|
||||
Version: 4.0.1
|
||||
Release: 1%{?dist}
|
||||
Summary: GTK graphical user interface library
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://www.gtk.org
|
||||
Source0: https://download.gnome.org/sources/gtk/4.0/gtk-%{version}.tar.xz
|
||||
Patch0: %{name}-gcc11.patch
|
||||
Patch1: 0001-build-Fix-vulkan-reference-in-pc-file.patch
|
||||
Patch0: gtk4-gcc11.patch
|
||||
|
||||
BuildRequires: cups-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -234,6 +233,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/gtk-doc
|
||||
|
||||
%changelog
|
||||
* Sat Jan 09 2021 Kalev Lember <klember@redhat.com> - 4.0.1-1
|
||||
- Update to 4.0.1
|
||||
|
||||
* Sat Jan 09 2021 Kalev Lember <klember@redhat.com> - 4.0.0-3
|
||||
- Fix vulkan reference in pc file
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gtk-4.0.0.tar.xz) = 5fe807bcdb59f0df2ad1cc5a28b654dbf90f5fa29bf9a4c69c9278543ab9a3e4f8b1712547fb2fd1f35711c438f78ee8a5cd1a509cf64f815274bb8c82023922
|
||||
SHA512 (gtk-4.0.1.tar.xz) = cab50b5bcf1a6bfdd5245c908e813330b9173531c49fdd63f9b5618f5329ddf2560f0a3548f61bba55dea6d816e57681d4e59941cfc50cf430544d3ebcd90aad
|
||||
|
Loading…
Reference in New Issue
Block a user