Update to 4.4.0
This commit is contained in:
parent
9a87968de8
commit
8bffe659b7
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
||||
/gtk-4.1.2.tar.xz
|
||||
/gtk-4.2.0.tar.xz
|
||||
/gtk-4.2.1.tar.xz
|
||||
/gtk-4.4.0.tar.xz
|
||||
|
29
0001-build-Fix-detection-for-pre-compiled-css-files.patch
Normal file
29
0001-build-Fix-detection-for-pre-compiled-css-files.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From c4266327ce7a76558f238692e0e8a4e5788fa646 Mon Sep 17 00:00:00 2001
|
||||
From: Kalev Lember <klember@redhat.com>
|
||||
Date: Mon, 23 Aug 2021 15:38:46 +0200
|
||||
Subject: [PATCH] build: Fix detection for pre-compiled css files
|
||||
|
||||
The default theme changed from Adwaita to Default and this tripped up
|
||||
the logic to detect if the tarball builds contain pre-built css files or
|
||||
not. Fix this by looking at pre-compiled css files in themes/Default/
|
||||
instead of themes/Adwaita/.
|
||||
---
|
||||
gtk/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gtk/meson.build b/gtk/meson.build
|
||||
index fa66764c50..4ba89f2298 100644
|
||||
--- a/gtk/meson.build
|
||||
+++ b/gtk/meson.build
|
||||
@@ -842,7 +842,7 @@ gtk_gresources_xml = configure_file(output: 'gtk.gresources.xml',
|
||||
|
||||
theme_deps = []
|
||||
# For git checkouts, but not for tarballs...
|
||||
-if not fs.exists('theme/Adwaita/Adwaita.css')
|
||||
+if not fs.exists('theme/Default/gtk-light.css')
|
||||
# ... build the theme files
|
||||
sassc = find_program('sassc', required: false)
|
||||
if not sassc.found()
|
||||
--
|
||||
2.31.1
|
||||
|
16
gtk4.spec
16
gtk4.spec
@ -6,8 +6,8 @@
|
||||
%global pango_version 1.47.0
|
||||
%global cairo_version 1.14.0
|
||||
%global gdk_pixbuf_version 2.30.0
|
||||
%global wayland_protocols_version 1.20
|
||||
%global wayland_version 1.14.91
|
||||
%global wayland_protocols_version 1.21
|
||||
%global wayland_version 1.16.91
|
||||
%global epoxy_version 1.4
|
||||
|
||||
%global bin_version 4.0.0
|
||||
@ -16,13 +16,15 @@
|
||||
%global __provides_exclude_from ^%{_libdir}/gtk-4.0
|
||||
|
||||
Name: gtk4
|
||||
Version: 4.2.1
|
||||
Release: 2%{?dist}
|
||||
Version: 4.4.0
|
||||
Release: 1%{?dist}
|
||||
Summary: GTK graphical user interface library
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://www.gtk.org
|
||||
Source0: https://download.gnome.org/sources/gtk/4.2/gtk-%{version}.tar.xz
|
||||
Source0: https://download.gnome.org/sources/gtk/4.4/gtk-%{version}.tar.xz
|
||||
# Backported from upstream
|
||||
Patch0: 0001-build-Fix-detection-for-pre-compiled-css-files.patch
|
||||
|
||||
BuildRequires: cups-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -132,7 +134,6 @@ export CFLAGS='-fno-strict-aliasing -DG_DISABLE_CAST_CHECKS -DG_DISABLE_ASSERT %
|
||||
-Dcloudproviders=enabled \
|
||||
-Dsysprof=enabled \
|
||||
-Dcolord=enabled \
|
||||
-Dsassc=disabled \
|
||||
-Dgtk_doc=true \
|
||||
-Dman-pages=true \
|
||||
-Dinstall-tests=false
|
||||
@ -229,6 +230,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/doc/gtk4/
|
||||
|
||||
%changelog
|
||||
* Mon Aug 23 2021 Kalev Lember <klember@redhat.com> - 4.4.0-1
|
||||
- Update to 4.4.0
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gtk-4.2.1.tar.xz) = a2721d6b9a72be481460081aedfbd713842cb5abdb24d810ec48e346342d0d91271f4ace321a9697214477ad4829d0b0ca67754ea316e719784f01c43f0fe732
|
||||
SHA512 (gtk-4.4.0.tar.xz) = de0b6508df3fa4523a7e54cf417ac31292c833346409ff89fd4daf886edad16ffe60b6ed77a85451bd36b96098c8437d56c6fd42daca33c52db8dc57a25753b6
|
||||
|
Loading…
Reference in New Issue
Block a user