Avoid rebuilding stylesheets with sassc during the build
This avoids sassc/libsassc build deps that we don't want to ship in RHEL, and also makes sure that we use upstream-shipped stylesheets.
This commit is contained in:
parent
5376622a32
commit
4523289c01
@ -0,0 +1,26 @@
|
|||||||
|
From 1a30ec6da6a38bd283dc48b0bc13a96237fd187c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kalev Lember <klember@redhat.com>
|
||||||
|
Date: Tue, 19 Jan 2021 10:46:13 +0100
|
||||||
|
Subject: [PATCH] dist: Fix css theme disting after HighContrast-dark changes
|
||||||
|
|
||||||
|
Commit f60d245e327a760a188e8b5a40844f5fe092df43 renamed it from
|
||||||
|
HighContrast-inverse.css to HighContrast-dark.css.
|
||||||
|
---
|
||||||
|
build-aux/meson/dist-theme.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/build-aux/meson/dist-theme.py b/build-aux/meson/dist-theme.py
|
||||||
|
index 1582057113..b1d5291a2c 100644
|
||||||
|
--- a/build-aux/meson/dist-theme.py
|
||||||
|
+++ b/build-aux/meson/dist-theme.py
|
||||||
|
@@ -7,7 +7,7 @@ import subprocess
|
||||||
|
stylesheets = [ 'gtk/theme/Adwaita/Adwaita.css',
|
||||||
|
'gtk/theme/Adwaita/Adwaita-dark.css',
|
||||||
|
'gtk/theme/HighContrast/HighContrast.css',
|
||||||
|
- 'gtk/theme/HighContrast/HighContrast-inverse.css' ]
|
||||||
|
+ 'gtk/theme/HighContrast/HighContrast-dark.css' ]
|
||||||
|
|
||||||
|
sourceroot = os.environ.get('MESON_SOURCE_ROOT')
|
||||||
|
distroot = os.environ.get('MESON_DIST_ROOT')
|
||||||
|
--
|
||||||
|
2.29.2
|
16
gtk4.spec
16
gtk4.spec
@ -17,13 +17,19 @@
|
|||||||
|
|
||||||
Name: gtk4
|
Name: gtk4
|
||||||
Version: 4.0.2
|
Version: 4.0.2
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: GTK graphical user interface library
|
Summary: GTK graphical user interface library
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://www.gtk.org
|
URL: https://www.gtk.org
|
||||||
Source0: https://download.gnome.org/sources/gtk/4.0/gtk-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/gtk/4.0/gtk-%{version}.tar.xz
|
||||||
|
|
||||||
|
# Generated with patch0
|
||||||
|
Source1: HighContrast-dark.css
|
||||||
|
|
||||||
|
# https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/3095
|
||||||
|
Patch0: 0001-dist-Fix-css-theme-disting-after-HighContrast-dark-c.patch
|
||||||
|
|
||||||
BuildRequires: cups-devel
|
BuildRequires: cups-devel
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: docbook-style-xsl
|
BuildRequires: docbook-style-xsl
|
||||||
@ -62,7 +68,6 @@ BuildRequires: pkgconfig(xkbcommon)
|
|||||||
BuildRequires: pkgconfig(xrandr)
|
BuildRequires: pkgconfig(xrandr)
|
||||||
BuildRequires: pkgconfig(xrender)
|
BuildRequires: pkgconfig(xrender)
|
||||||
BuildRequires: pkgconfig(xrender)
|
BuildRequires: pkgconfig(xrender)
|
||||||
BuildRequires: sassc
|
|
||||||
BuildRequires: /usr/bin/xsltproc
|
BuildRequires: /usr/bin/xsltproc
|
||||||
|
|
||||||
# standard icons
|
# standard icons
|
||||||
@ -128,6 +133,9 @@ widget toolkit.
|
|||||||
%prep
|
%prep
|
||||||
%autosetup -p1 -n gtk-%{version}
|
%autosetup -p1 -n gtk-%{version}
|
||||||
|
|
||||||
|
# Generated with patch0
|
||||||
|
cp -a %{SOURCE1} gtk/theme/HighContrast/HighContrast-dark.css
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS='-fno-strict-aliasing %optflags'
|
export CFLAGS='-fno-strict-aliasing %optflags'
|
||||||
%meson \
|
%meson \
|
||||||
@ -140,6 +148,7 @@ export CFLAGS='-fno-strict-aliasing %optflags'
|
|||||||
-Dmedia-gstreamer=enabled \
|
-Dmedia-gstreamer=enabled \
|
||||||
-Dxinerama=enabled \
|
-Dxinerama=enabled \
|
||||||
-Dcolord=enabled \
|
-Dcolord=enabled \
|
||||||
|
-Dsassc=disabled \
|
||||||
-Dgtk_doc=true \
|
-Dgtk_doc=true \
|
||||||
-Dman-pages=true \
|
-Dman-pages=true \
|
||||||
-Dinstall-tests=false
|
-Dinstall-tests=false
|
||||||
@ -232,6 +241,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
|||||||
%{_datadir}/gtk-doc
|
%{_datadir}/gtk-doc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 19 2021 Kalev Lember <klember@redhat.com> - 4.0.2-2
|
||||||
|
- Avoid rebuilding stylesheets with sassc during the build
|
||||||
|
|
||||||
* Tue Jan 19 2021 Kalev Lember <klember@redhat.com> - 4.0.2-1
|
* Tue Jan 19 2021 Kalev Lember <klember@redhat.com> - 4.0.2-1
|
||||||
- Update to 4.0.2
|
- Update to 4.0.2
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
|||||||
SHA512 (gtk-4.0.2.tar.xz) = ae4d57c857bc07b775f7d906b4106804aa5d78240b0348c886f189a3c32d0fee494ebd1f0fd3301d53a523d6bb7c620150ee6306f44cc7d4f3f4f32fc42f8e49
|
SHA512 (gtk-4.0.2.tar.xz) = ae4d57c857bc07b775f7d906b4106804aa5d78240b0348c886f189a3c32d0fee494ebd1f0fd3301d53a523d6bb7c620150ee6306f44cc7d4f3f4f32fc42f8e49
|
||||||
|
SHA512 (HighContrast-dark.css) = 4a90efc556d10f44f68650c901344f9fedec4fa6be6ddfdc252e10c5c23fb142b1c6bac77e1ad36da0a23a9e4b2588313c1f69610f3535930e8501bea3347a1e
|
||||||
|
Loading…
Reference in New Issue
Block a user