Update to 4.6.2
This commit is contained in:
parent
b17d1e7a0e
commit
26e9ae85dc
1
.gitignore
vendored
1
.gitignore
vendored
@ -28,3 +28,4 @@
|
||||
/gtk-4.5.1.tar.xz
|
||||
/gtk-4.6.0.tar.xz
|
||||
/gtk-4.6.1.tar.xz
|
||||
/gtk-4.6.2.tar.xz
|
||||
|
@ -1,40 +0,0 @@
|
||||
From 4d741bac98f906796d61eebfb4f74f5b1cecb2b6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Guido=20G=C3=BCnther?= <agx@sigxcpu.org>
|
||||
Date: Tue, 11 Jan 2022 20:21:55 +0100
|
||||
Subject: [PATCH] wayland: xdg-activation: Don't assume there's a focus surface
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Tools like gtk4-launch can't set surface on the activation token so
|
||||
don't require it. If the compositor requires it we can't do anything
|
||||
about it anyway. This avoids a critical:
|
||||
|
||||
(gtk4-launch:23497): Gdk-CRITICAL **: 17:07:24.704: gdk_wayland_surface_get_wl_surface: assertion 'GDK_IS_WAYLAND_SURFACE (surface)' failed
|
||||
|
||||
Fixes: be4216e051 ("gdk/wayland: Support the xdg-activation wayland protocol")
|
||||
|
||||
Signed-off-by: Guido Günther <agx@sigxcpu.org>
|
||||
---
|
||||
gdk/wayland/gdkapplaunchcontext-wayland.c | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gdk/wayland/gdkapplaunchcontext-wayland.c b/gdk/wayland/gdkapplaunchcontext-wayland.c
|
||||
index c9498e507c..c8bf5afd25 100644
|
||||
--- a/gdk/wayland/gdkapplaunchcontext-wayland.c
|
||||
+++ b/gdk/wayland/gdkapplaunchcontext-wayland.c
|
||||
@@ -73,8 +73,9 @@ gdk_wayland_app_launch_context_get_startup_notify_id (GAppLaunchContext *context
|
||||
xdg_activation_token_v1_set_serial (token,
|
||||
_gdk_wayland_seat_get_last_implicit_grab_serial (seat, NULL),
|
||||
gdk_wayland_seat_get_wl_seat (GDK_SEAT (seat)));
|
||||
- xdg_activation_token_v1_set_surface (token,
|
||||
- gdk_wayland_surface_get_wl_surface (focus_surface));
|
||||
+ if (focus_surface)
|
||||
+ xdg_activation_token_v1_set_surface (token,
|
||||
+ gdk_wayland_surface_get_wl_surface (focus_surface));
|
||||
xdg_activation_token_v1_commit (token);
|
||||
|
||||
while (app_launch_data.token == NULL)
|
||||
--
|
||||
2.35.1
|
||||
|
12
gtk4.spec
12
gtk4.spec
@ -16,19 +16,14 @@
|
||||
%global __provides_exclude_from ^%{_libdir}/gtk-4.0
|
||||
|
||||
Name: gtk4
|
||||
Version: 4.6.1
|
||||
Release: 2%{?dist}
|
||||
Version: 4.6.2
|
||||
Release: 1%{?dist}
|
||||
Summary: GTK graphical user interface library
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://www.gtk.org
|
||||
Source0: https://download.gnome.org/sources/gtk/4.6/gtk-%{version}.tar.xz
|
||||
|
||||
# Fix control-center pane launching from overview:
|
||||
# https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1675
|
||||
# https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/4366
|
||||
Patch0: 0001-wayland-xdg-activation-Don-t-assume-there-s-a-focus-.patch
|
||||
|
||||
BuildRequires: cups-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: docbook-style-xsl
|
||||
@ -232,6 +227,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
||||
%{_mandir}/man1/gtk4-widget-factory.1*
|
||||
|
||||
%changelog
|
||||
* Sat Mar 19 2022 David King <amigadave@amigadave.com> - 4.6.2-1
|
||||
- Update to 4.6.2
|
||||
|
||||
* Wed Mar 02 2022 Adam Williamson <awilliam@redhat.com> - 4.6.1-2
|
||||
- Backport MR#4366 to fix launching control-center panes from overview
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gtk-4.6.1.tar.xz) = 7184c3a541172bcc712c00c0093426c5ff5cc54ad2de8529cfec17f8185966718b18b46cfb6c3d8067535909eb0275cd57e8887d2be7a2af459d14f5efb4d03b
|
||||
SHA512 (gtk-4.6.2.tar.xz) = 220959085b43c5a0bc496cb3d67213b73e1c597d6c799e5d788d0b75b664adc573b21c449850c7c0fbb7cbfafd77528c910f0e5eaa75a8fa59bff47e04c77f33
|
||||
|
Loading…
Reference in New Issue
Block a user