Update to 4.9.2
This commit is contained in:
parent
746f87a4f0
commit
1a268def4b
1
.gitignore
vendored
1
.gitignore
vendored
@ -37,3 +37,4 @@
|
||||
/gtk-4.8.1.tar.xz
|
||||
/gtk-4.8.2.tar.xz
|
||||
/gtk-4.9.1.tar.xz
|
||||
/gtk-4.9.2.tar.xz
|
||||
|
@ -1,34 +0,0 @@
|
||||
From e07f8ef50657dab0d5184d4c6927acc0683bc07d Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Tue, 1 Nov 2022 17:26:29 -0700
|
||||
Subject: [PATCH] focus: fall back to old behaviour if we didn't focus anything
|
||||
|
||||
8455b9ac74 seems to have introduced a problem where we can wind
|
||||
up focusing no widget at all if the `while (parent)` loop doesn't
|
||||
find a widget it can successfully move the focus to. This 'fixes'
|
||||
that by falling back to doing the previous thing if we make it
|
||||
all the way through that loop without moving the focus. Thanks to
|
||||
@coreyberla for a hint to improve the implementation.
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
gtk/gtkwindow.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/gtk/gtkwindow.c b/gtk/gtkwindow.c
|
||||
index a7cbde18bc..21dfb49880 100644
|
||||
--- a/gtk/gtkwindow.c
|
||||
+++ b/gtk/gtkwindow.c
|
||||
@@ -4703,6 +4703,9 @@ maybe_unset_focus_and_default (GtkWindow *window)
|
||||
parent = _gtk_widget_get_parent (parent);
|
||||
}
|
||||
|
||||
+ if (!parent)
|
||||
+ gtk_widget_child_focus (GTK_WIDGET (window), GTK_DIR_TAB_FORWARD);
|
||||
+
|
||||
priv->move_focus = FALSE;
|
||||
g_clear_object (&priv->move_focus_widget);
|
||||
}
|
||||
--
|
||||
2.38.1
|
||||
|
15
gtk4.spec
15
gtk4.spec
@ -16,8 +16,8 @@
|
||||
%global __provides_exclude_from ^%{_libdir}/gtk-4.0
|
||||
|
||||
Name: gtk4
|
||||
Version: 4.9.1
|
||||
Release: 2%{?dist}
|
||||
Version: 4.9.2
|
||||
Release: 1%{?dist}
|
||||
Summary: GTK graphical user interface library
|
||||
|
||||
License: LGPLv2+
|
||||
@ -28,11 +28,6 @@ Source1: settings.ini
|
||||
# private requires that are needed for rpm automatic dep extraction.
|
||||
# https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/4756
|
||||
Patch0: 0001-Revert-Meson-Simplify-pkgconfig-file-generator.patch
|
||||
# https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/5189
|
||||
# https://gitlab.gnome.org/GNOME/nautilus/-/issues/2574
|
||||
# Fix a problem which could lead to no element being focused
|
||||
# (so keyboard shortcuts don't work) in some cases
|
||||
Patch1: 0001-focus-fall-back-to-old-behaviour-if-we-didn-t-focus-.patch
|
||||
|
||||
BuildRequires: cups-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -144,8 +139,7 @@ export CFLAGS='-fno-strict-aliasing -DG_DISABLE_CAST_CHECKS -DG_DISABLE_ASSERT %
|
||||
-Dtracker=enabled \
|
||||
-Dcolord=enabled \
|
||||
-Dgtk_doc=true \
|
||||
-Dman-pages=true \
|
||||
-Dinstall-tests=false
|
||||
-Dman-pages=true
|
||||
|
||||
%meson_build
|
||||
|
||||
@ -244,6 +238,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
||||
%{_mandir}/man1/gtk4-widget-factory.1*
|
||||
|
||||
%changelog
|
||||
* Fri Dec 30 2022 David King <amigadave@amigadave.com> - 4.9.2-1
|
||||
- Update to 4.9.2
|
||||
|
||||
* Tue Nov 29 2022 Adam Williamson <awilliam@redhat.com> - 4.9.1-2
|
||||
- Bring back focus fix (MR #5189), it wasn't in 4.9.1
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gtk-4.9.1.tar.xz) = 1647fe84ce722de3dd3d75fe9ad0eace7557c0dd6e7a42c1ebd911fb6f872a8cdaa7f5bb431046fc1bcc12f19dd8e8a721378c26d7e985c135dc7a7c17918499
|
||||
SHA512 (gtk-4.9.2.tar.xz) = 1a01cc9b24c32bd92677b1ae0d4c5c5e05739bde442e18d0b31df08ebb683d0f255bf7b2cc51c8794f79bfe1f1cddb3e5ea7513dbc3ae127b187c654198385bc
|
||||
|
Loading…
Reference in New Issue
Block a user