Update to 3.17.9
This commit is contained in:
parent
67cfa0a716
commit
b0f2ab0d76
1
.gitignore
vendored
1
.gitignore
vendored
@ -117,3 +117,4 @@ gtk+-2.90.5.tar.bz2
|
||||
/gtk+-3.17.6.tar.xz
|
||||
/gtk+-3.17.7.tar.xz
|
||||
/gtk+-3.17.8.tar.xz
|
||||
/gtk+-3.17.9.tar.xz
|
||||
|
@ -1,39 +0,0 @@
|
||||
From dbf85cc4dba2d659c65f18caadad256304a1f5d1 Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Garnacho <carlosg@gnome.org>
|
||||
Date: Wed, 9 Sep 2015 16:05:15 +0200
|
||||
Subject: [PATCH] x11: Declare variable for the inner loop
|
||||
|
||||
Otherwise the outer loop control variable is messed up, and we end
|
||||
up with uninitialized axes if there were any more valuators after
|
||||
the XIKeyClass one.
|
||||
|
||||
This bug was sneakily introduced by fdb9a8e14, many thanks to
|
||||
Carlos Soriano for helping spot the source of this bug.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=753431
|
||||
---
|
||||
gdk/x11/gdkdevicemanager-xi2.c | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gdk/x11/gdkdevicemanager-xi2.c b/gdk/x11/gdkdevicemanager-xi2.c
|
||||
index e63c35b..2401ff1 100644
|
||||
--- a/gdk/x11/gdkdevicemanager-xi2.c
|
||||
+++ b/gdk/x11/gdkdevicemanager-xi2.c
|
||||
@@ -214,11 +214,12 @@ translate_device_classes (GdkDisplay *display,
|
||||
case XIKeyClass:
|
||||
{
|
||||
XIKeyClassInfo *key_info = (XIKeyClassInfo *) class_info;
|
||||
+ gint j;
|
||||
|
||||
_gdk_device_set_keys (device, key_info->num_keycodes);
|
||||
|
||||
- for (i = 0; i < key_info->num_keycodes; i++)
|
||||
- gdk_device_set_key (device, i, key_info->keycodes[i], 0);
|
||||
+ for (j = 0; j < key_info->num_keycodes; j++)
|
||||
+ gdk_device_set_key (device, j, key_info->keycodes[j], 0);
|
||||
}
|
||||
break;
|
||||
case XIValuatorClass:
|
||||
--
|
||||
2.4.3
|
||||
|
13
gtk3.spec
13
gtk3.spec
@ -3,7 +3,7 @@
|
||||
%global with_broadway 1
|
||||
%endif
|
||||
|
||||
%global glib2_version 2.43.4
|
||||
%global glib2_version 2.45.8
|
||||
%global pango_version 1.37.3
|
||||
%global gdk_pixbuf_version 2.30.0
|
||||
%global atk_version 2.15.1
|
||||
@ -17,8 +17,8 @@
|
||||
|
||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||
Name: gtk3
|
||||
Version: 3.17.8
|
||||
Release: 2%{?dist}
|
||||
Version: 3.17.9
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
@ -26,9 +26,6 @@ URL: http://www.gtk.org
|
||||
|
||||
Source: http://download.gnome.org/sources/gtk+/3.17/gtk+-%{version}.tar.xz
|
||||
|
||||
# Backported upstream patch to fix mouse scroll wheel events
|
||||
Patch0: 0001-x11-Declare-variable-for-the-inner-loop.patch
|
||||
|
||||
BuildRequires: gnome-common autoconf automake intltool gettext
|
||||
BuildRequires: pkgconfig(atk) >= %{atk_version}
|
||||
BuildRequires: pkgconfig(atk-bridge-2.0)
|
||||
@ -170,7 +167,6 @@ the functionality of the installed %{name} package.
|
||||
|
||||
%prep
|
||||
%setup -q -n gtk+-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -341,6 +337,9 @@ gtk-query-immodules-3.0-%{__isa_bits} --update-cache
|
||||
%{_datadir}/installed-tests
|
||||
|
||||
%changelog
|
||||
* Tue Sep 15 2015 Kalev Lember <klember@redhat.com> - 3.17.9-1
|
||||
- Update to 3.17.9
|
||||
|
||||
* Sun Sep 13 2015 Kalev Lember <klember@redhat.com> - 3.17.8-2
|
||||
- Backport a patch to fix mouse scroll wheel events (#1258236)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user