Update to 3.5.14
This commit is contained in:
parent
8611a747dd
commit
6a37ad492a
1
.gitignore
vendored
1
.gitignore
vendored
@ -43,3 +43,4 @@ gtk+-2.90.5.tar.bz2
|
|||||||
/gtk+-3.5.8.tar.xz
|
/gtk+-3.5.8.tar.xz
|
||||||
/gtk+-3.5.10.tar.xz
|
/gtk+-3.5.10.tar.xz
|
||||||
/gtk+-3.5.12.tar.xz
|
/gtk+-3.5.12.tar.xz
|
||||||
|
/gtk+-3.5.14.tar.xz
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
commit 81e76746ffc1a9ad77ab7c3c7b9f43e344401e3c
|
|
||||||
Author: Ryan Lortie <desrt@desrt.ca>
|
|
||||||
Date: Wed Aug 22 00:54:57 2012 -0400
|
|
||||||
|
|
||||||
GtkActionHelper: two small fixups in _set_target_value()
|
|
||||||
|
|
||||||
First, ensure we always consume floating values, as documented.
|
|
||||||
|
|
||||||
Second (and more serious), don't try to query the action if the
|
|
||||||
action name is not set yet. This will cause crashes...
|
|
||||||
|
|
||||||
diff --git a/gtk/gtkactionhelper.c b/gtk/gtkactionhelper.c
|
|
||||||
index 6047a43..a3a0c46 100644
|
|
||||||
--- a/gtk/gtkactionhelper.c
|
|
||||||
+++ b/gtk/gtkactionhelper.c
|
|
||||||
@@ -523,7 +523,10 @@ gtk_action_helper_set_action_target_value (GtkActionHelper *helper,
|
|
||||||
return;
|
|
||||||
|
|
||||||
if (target_value && helper->target && g_variant_equal (target_value, helper->target))
|
|
||||||
- return;
|
|
||||||
+ {
|
|
||||||
+ g_variant_unref (g_variant_ref_sink (target_value));
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
if (helper->target)
|
|
||||||
{
|
|
||||||
@@ -534,6 +537,10 @@ gtk_action_helper_set_action_target_value (GtkActionHelper *helper,
|
|
||||||
if (target_value)
|
|
||||||
helper->target = g_variant_ref_sink (target_value);
|
|
||||||
|
|
||||||
+ /* The action_name has not yet been set. Don't do anything yet. */
|
|
||||||
+ if (helper->action_name == NULL)
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
was_enabled = helper->enabled;
|
|
||||||
was_active = helper->active;
|
|
||||||
|
|
11
gtk3.spec
11
gtk3.spec
@ -9,8 +9,8 @@
|
|||||||
|
|
||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
Name: gtk3
|
Name: gtk3
|
||||||
Version: 3.5.12
|
Version: 3.5.14
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.gtk.org
|
URL: http://www.gtk.org
|
||||||
@ -18,8 +18,6 @@ URL: http://www.gtk.org
|
|||||||
Source: http://download.gnome.org/sources/gtk+/3.5/gtk+-%{version}.tar.xz
|
Source: http://download.gnome.org/sources/gtk+/3.5/gtk+-%{version}.tar.xz
|
||||||
Source1: im-cedilla.conf
|
Source1: im-cedilla.conf
|
||||||
|
|
||||||
Patch0: actionhelper-crashfix.patch
|
|
||||||
|
|
||||||
BuildRequires: gnome-common autoconf automake intltool gettext
|
BuildRequires: gnome-common autoconf automake intltool gettext
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: at-spi2-atk-devel
|
BuildRequires: at-spi2-atk-devel
|
||||||
@ -114,8 +112,6 @@ widget toolkit.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n gtk+-%{version}
|
%setup -q -n gtk+-%{version}
|
||||||
|
|
||||||
%patch0 -p1 -b .actionhelper-crashfix
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||||
@ -249,6 +245,9 @@ gtk-query-immodules-3.0-%{__isa_bits} --update-cache
|
|||||||
%{_datadir}/gtk-doc
|
%{_datadir}/gtk-doc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 04 2012 Richard Hughes <hughsient@gmail.com> - 3.5.14-1
|
||||||
|
- Update to 3.5.14
|
||||||
|
|
||||||
* Wed Aug 22 2012 Cosimo Cecchi <cosimoc@redhat.com> - 3.5.12-2
|
* Wed Aug 22 2012 Cosimo Cecchi <cosimoc@redhat.com> - 3.5.12-2
|
||||||
- Backport a patch from upstream fixing crashers with app menus
|
- Backport a patch from upstream fixing crashers with app menus
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user