Update to 3.24.40
Make some files globs more explicit.
This commit is contained in:
parent
010f8569b2
commit
3f8b4630a0
1
.gitignore
vendored
1
.gitignore
vendored
@ -208,3 +208,4 @@ gtk+-2.90.5.tar.bz2
|
||||
/gtk+-3.24.37.tar.xz
|
||||
/gtk+-3.24.38.tar.xz
|
||||
/gtk+-3.24.39.tar.xz
|
||||
/gtk+-3.24.40.tar.xz
|
||||
|
82
gtk-3.24.40-cast-fixes.patch
Normal file
82
gtk-3.24.40-cast-fixes.patch
Normal file
@ -0,0 +1,82 @@
|
||||
From e0d9dd8ba96bfc86d71bf3cd2d56521f4be561a3 Mon Sep 17 00:00:00 2001
|
||||
From: David King <amigadave@amigadave.com>
|
||||
Date: Fri, 19 Jan 2024 10:41:33 +0000
|
||||
Subject: [PATCH 1/2] tests: Fix GdkEventButton casts in testinput
|
||||
|
||||
---
|
||||
tests/testinput.c | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/tests/testinput.c b/tests/testinput.c
|
||||
index b68552a428..3d4d7f6f87 100644
|
||||
--- a/tests/testinput.c
|
||||
+++ b/tests/testinput.c
|
||||
@@ -194,7 +194,7 @@ button_press_event (GtkWidget *widget, GdkEventButton *event)
|
||||
|
||||
print_axes (event->device, event->axes);
|
||||
gdk_event_get_axis ((GdkEvent *)event, GDK_AXIS_PRESSURE, &pressure);
|
||||
- draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device (event)),
|
||||
+ draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device ((GdkEvent *)event)),
|
||||
event->x, event->y, pressure);
|
||||
|
||||
motion_time = event->time;
|
||||
@@ -239,10 +239,10 @@ motion_notify_event (GtkWidget *widget, GdkEventMotion *event)
|
||||
gdk_device_get_axis (event->device, events[i]->axes, GDK_AXIS_X, &x);
|
||||
gdk_device_get_axis (event->device, events[i]->axes, GDK_AXIS_Y, &y);
|
||||
gdk_device_get_axis (event->device, events[i]->axes, GDK_AXIS_PRESSURE, &pressure);
|
||||
- draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device (event)),
|
||||
+ draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device ((GdkEvent *)event)),
|
||||
x, y, pressure);
|
||||
|
||||
- print_axes (gdk_event_get_source_device (event), events[i]->axes);
|
||||
+ print_axes (gdk_event_get_source_device ((GdkEvent *)event), events[i]->axes);
|
||||
}
|
||||
gdk_device_free_history (events, n_events);
|
||||
}
|
||||
@@ -252,7 +252,7 @@ motion_notify_event (GtkWidget *widget, GdkEventMotion *event)
|
||||
|
||||
gdk_event_get_axis ((GdkEvent *)event, GDK_AXIS_PRESSURE, &pressure);
|
||||
|
||||
- draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device (event)),
|
||||
+ draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device ((GdkEvent *)event)),
|
||||
event->x, event->y, pressure);
|
||||
}
|
||||
motion_time = event->time;
|
||||
--
|
||||
2.43.0
|
||||
|
||||
|
||||
From 9a979bf5f040d44fbbdcac1195d660ef2b8a04fd Mon Sep 17 00:00:00 2001
|
||||
From: David King <amigadave@amigadave.com>
|
||||
Date: Fri, 19 Jan 2024 11:04:37 +0000
|
||||
Subject: [PATCH 2/2] testsuite: Fix casts in reftests
|
||||
|
||||
---
|
||||
testsuite/reftests/gtk-reftest.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/testsuite/reftests/gtk-reftest.c b/testsuite/reftests/gtk-reftest.c
|
||||
index 1a51a9756b..b6a144ff0d 100644
|
||||
--- a/testsuite/reftests/gtk-reftest.c
|
||||
+++ b/testsuite/reftests/gtk-reftest.c
|
||||
@@ -381,7 +381,7 @@ enforce_default_settings (void)
|
||||
|
||||
klass = g_type_class_ref (G_OBJECT_TYPE (settings));
|
||||
|
||||
- pspecs = g_object_class_list_properties (klass, &n_pspecs);
|
||||
+ pspecs = g_object_class_list_properties ((GObjectClass *)klass, &n_pspecs);
|
||||
for (i = 0; i < n_pspecs; i++)
|
||||
{
|
||||
GParamSpec *pspec = pspecs[i];
|
||||
@@ -394,7 +394,7 @@ enforce_default_settings (void)
|
||||
continue;
|
||||
|
||||
value = g_param_spec_get_default_value (pspec);
|
||||
- g_object_set_property (settings, pspec->name, value);
|
||||
+ g_object_set_property ((GObject *)settings, pspec->name, value);
|
||||
}
|
||||
|
||||
g_free (pspecs);
|
||||
--
|
||||
2.43.0
|
||||
|
18
gtk3.spec
18
gtk3.spec
@ -19,13 +19,15 @@
|
||||
%global __provides_exclude_from ^%{_libdir}/gtk-3.0
|
||||
|
||||
Name: gtk3
|
||||
Version: 3.24.39
|
||||
Version: 3.24.40
|
||||
Release: 1%{?dist}
|
||||
Summary: GTK+ graphical user interface library
|
||||
|
||||
License: LGPL-2.0-or-later
|
||||
URL: https://gtk.org
|
||||
Source0: https://download.gnome.org/sources/gtk+/3.24/gtk+-%{version}.tar.xz
|
||||
# https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/6782
|
||||
Patch: gtk-3.24.40-cast-fixes.patch
|
||||
|
||||
BuildRequires: pkgconfig(atk) >= %{atk_version}
|
||||
BuildRequires: pkgconfig(atk-bridge-2.0)
|
||||
@ -263,10 +265,13 @@ gtk-query-immodules-3.0-%{__isa_bits} --update-cache &>/dev/null || :
|
||||
%{_libdir}/gtk-3.0/%{bin_version}/immodules/im-xim.so
|
||||
|
||||
%files devel -f gtk30-properties.lang
|
||||
%{_libdir}/lib*.so
|
||||
%{_includedir}/*
|
||||
%{_datadir}/aclocal/*
|
||||
%{_libdir}/pkgconfig/*
|
||||
%{_libdir}/libgdk-3.so
|
||||
%{_libdir}/libgtk-3.so
|
||||
%{_libdir}/libgailutil-3.so
|
||||
%{_includedir}/gail-3.0/
|
||||
%{_includedir}/gtk-3.0/
|
||||
%{_datadir}/aclocal/gtk-3.0.m4
|
||||
%{_libdir}/pkgconfig/g*-3.0.pc
|
||||
%{_bindir}/gtk3-demo
|
||||
%{_bindir}/gtk3-icon-browser
|
||||
%{_bindir}/gtk-builder-tool
|
||||
@ -302,6 +307,9 @@ gtk-query-immodules-3.0-%{__isa_bits} --update-cache &>/dev/null || :
|
||||
%{_datadir}/installed-tests/
|
||||
|
||||
%changelog
|
||||
* Fri Jan 19 2024 David King <amigadave@amigadave.com> - 3.24.40-1
|
||||
- Update to 3.24.40
|
||||
|
||||
* Tue Dec 19 2023 Kalev Lember <klember@redhat.com> - 3.24.39-1
|
||||
- Update to 3.24.39
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gtk+-3.24.39.tar.xz) = 8ec3db3544805b51fffaa415029b126761ba0a11b68c67cea80fe001e77878abf4d4719d5d002109f8546409c0caf892ea6d7aa792f8d5d97dc4139668f0451f
|
||||
SHA512 (gtk+-3.24.40.tar.xz) = 21fac23b6375c2e545128e60d4e39f7ee9516a824e4a1834a318af5f2a9f125a8a8572a83bf94b4c179a16c66b6a913e74574ccf2e810301f1a593006a1980c7
|
||||
|
Loading…
Reference in New Issue
Block a user