Backport a patch to fix spurious key repeat in gnome-terminal
https://bugzilla.redhat.com/show_bug.cgi?id=1428280
This commit is contained in:
parent
aca2c0a877
commit
3831044d4b
37
0001-wayland-make-sure-to-clear-up-the-number-of-keys.patch
Normal file
37
0001-wayland-make-sure-to-clear-up-the-number-of-keys.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
From aebe3a74ec9c2da5fe6eb0826274d4b971068b8f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Olivier Fourdan <ofourdan@redhat.com>
|
||||||
|
Date: Tue, 28 Feb 2017 18:17:39 +0100
|
||||||
|
Subject: [PATCH] wayland: make sure to clear up the number of keys
|
||||||
|
|
||||||
|
Make sure to clear up the number of keys being pressed on enter/leave so
|
||||||
|
that we don't end up with leftovers if a new window is mapped by a
|
||||||
|
keyboard shortcut.
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=779374
|
||||||
|
---
|
||||||
|
gdk/wayland/gdkdevice-wayland.c | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/gdk/wayland/gdkdevice-wayland.c b/gdk/wayland/gdkdevice-wayland.c
|
||||||
|
index 815fa9a..947ef44 100644
|
||||||
|
--- a/gdk/wayland/gdkdevice-wayland.c
|
||||||
|
+++ b/gdk/wayland/gdkdevice-wayland.c
|
||||||
|
@@ -1869,6 +1869,7 @@ keyboard_handle_enter (void *data,
|
||||||
|
|
||||||
|
seat->keyboard_focus = wl_surface_get_user_data (surface);
|
||||||
|
g_object_ref (seat->keyboard_focus);
|
||||||
|
+ seat->nkeys = 0;
|
||||||
|
|
||||||
|
event = gdk_event_new (GDK_FOCUS_CHANGE);
|
||||||
|
event->focus_change.window = g_object_ref (seat->keyboard_focus);
|
||||||
|
@@ -1925,6 +1926,7 @@ keyboard_handle_leave (void *data,
|
||||||
|
|
||||||
|
g_object_unref (seat->keyboard_focus);
|
||||||
|
seat->keyboard_focus = NULL;
|
||||||
|
+ seat->nkeys = 0;
|
||||||
|
|
||||||
|
GDK_NOTE (EVENTS,
|
||||||
|
g_message ("focus out, seat %p surface %p",
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
10
gtk3.spec
10
gtk3.spec
@ -19,13 +19,17 @@
|
|||||||
|
|
||||||
Name: gtk3
|
Name: gtk3
|
||||||
Version: 3.22.9
|
Version: 3.22.9
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://www.gtk.org
|
URL: http://www.gtk.org
|
||||||
Source0: http://download.gnome.org/sources/gtk+/3.22/gtk+-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/gtk+/3.22/gtk+-%{version}.tar.xz
|
||||||
|
|
||||||
|
# Backported from upstream
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1428280
|
||||||
|
Patch0: 0001-wayland-make-sure-to-clear-up-the-number-of-keys.patch
|
||||||
|
|
||||||
BuildRequires: pkgconfig(atk) >= %{atk_version}
|
BuildRequires: pkgconfig(atk) >= %{atk_version}
|
||||||
BuildRequires: pkgconfig(atk-bridge-2.0)
|
BuildRequires: pkgconfig(atk-bridge-2.0)
|
||||||
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
||||||
@ -163,6 +167,7 @@ the functionality of the installed %{name} package.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n gtk+-%{version}
|
%setup -q -n gtk+-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS='-fno-strict-aliasing %optflags'
|
export CFLAGS='-fno-strict-aliasing %optflags'
|
||||||
@ -336,6 +341,9 @@ gtk-query-immodules-3.0-%{__isa_bits} --update-cache
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 02 2017 Kalev Lember <klember@redhat.com> - 3.22.9-2
|
||||||
|
- Backport a patch to fix spurious key repeat in gnome-terminal (#1428280)
|
||||||
|
|
||||||
* Tue Feb 28 2017 Kalev Lember <klember@redhat.com> - 3.22.9-1
|
* Tue Feb 28 2017 Kalev Lember <klember@redhat.com> - 3.22.9-1
|
||||||
- Update to 3.22.9
|
- Update to 3.22.9
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user