Update to 3.22.16
This commit is contained in:
parent
7cac6f273d
commit
1b851f49b4
1
.gitignore
vendored
1
.gitignore
vendored
@ -158,3 +158,4 @@ gtk+-2.90.5.tar.bz2
|
||||
/gtk+-3.22.13.tar.xz
|
||||
/gtk+-3.22.14.tar.xz
|
||||
/gtk+-3.22.15.tar.xz
|
||||
/gtk+-3.22.16.tar.xz
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 425e4df1006cf15e91813797932cef462805e50c Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Wed, 24 May 2017 16:08:07 +0200
|
||||
Subject: [PATCH] wayland: Don't abort when preparing the source if connection
|
||||
is lost
|
||||
|
||||
Aborting the application makes it look like an application bug, when
|
||||
it is the expected thing to do when the Wayland display server goes
|
||||
way. eg., when the user logs out. The log level is also demoted to
|
||||
avoid a storm of warnings in the log from all applications whenever
|
||||
this happens.
|
||||
|
||||
This is also what the X11 backend does (see gdk_x_io_error).
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=783047
|
||||
---
|
||||
gdk/wayland/gdkeventsource.c | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gdk/wayland/gdkeventsource.c b/gdk/wayland/gdkeventsource.c
|
||||
index 142091733b92..bdb4c80e1eee 100644
|
||||
--- a/gdk/wayland/gdkeventsource.c
|
||||
+++ b/gdk/wayland/gdkeventsource.c
|
||||
@@ -63,7 +63,10 @@ gdk_event_source_prepare (GSource *base,
|
||||
source->reading = TRUE;
|
||||
|
||||
if (wl_display_flush (display->wl_display) < 0)
|
||||
- g_error ("Error flushing display: %s", g_strerror (errno));
|
||||
+ {
|
||||
+ g_message ("Error flushing display: %s", g_strerror (errno));
|
||||
+ _exit (1);
|
||||
+ }
|
||||
|
||||
return FALSE;
|
||||
}
|
||||
--
|
||||
2.9.4
|
||||
|
11
gtk3.spec
11
gtk3.spec
@ -18,17 +18,14 @@
|
||||
%global _changelog_trimtime %(date +%s -d "1 year ago")
|
||||
|
||||
Name: gtk3
|
||||
Version: 3.22.15
|
||||
Release: 2%{?dist}
|
||||
Version: 3.22.16
|
||||
Release: 1%{?dist}
|
||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||
|
||||
License: LGPLv2+
|
||||
URL: http://www.gtk.org
|
||||
Source0: http://download.gnome.org/sources/gtk+/3.22/gtk+-%{version}.tar.xz
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1258818
|
||||
Patch0: gtk3-wayland-Don-t-abort-when-preparing-the-source-if-con.patch
|
||||
|
||||
BuildRequires: pkgconfig(atk) >= %{atk_version}
|
||||
BuildRequires: pkgconfig(atk-bridge-2.0)
|
||||
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
||||
@ -166,7 +163,6 @@ the functionality of the installed %{name} package.
|
||||
|
||||
%prep
|
||||
%setup -q -n gtk+-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
export CFLAGS='-fno-strict-aliasing %optflags'
|
||||
@ -339,6 +335,9 @@ gtk-query-immodules-3.0-%{__isa_bits} --update-cache &>/dev/null || :
|
||||
%{_datadir}/installed-tests
|
||||
|
||||
%changelog
|
||||
* Wed Jun 21 2017 Kalev Lember <klember@redhat.com> - 3.22.16-1
|
||||
- Update to 3.22.16
|
||||
|
||||
* Thu May 25 2017 Debarshi Ray <rishi@fedoraproject.org> - 3.22.15-2
|
||||
- Backport fix to not abort when the Wayland connection is lost (RH #1258818)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gtk+-3.22.15.tar.xz) = c99c4a52bc447a21be20546bdc7808081abde076af9603424c1de20af031ac3f9bd121709d4c18705db8ba2f66ace0aae9b32741347788a8d81afa358d67e758
|
||||
SHA512 (gtk+-3.22.16.tar.xz) = a981ba3c420db649645787916d603a22f1da9d839aba39f3786bab47f9a247867d94d342ce4c3aa47de4876072ed9cf3615304a73de7e613063cef08b8c0d612
|
||||
|
Loading…
Reference in New Issue
Block a user