2.11.6
This commit is contained in:
parent
3305e95815
commit
fc983e5fba
@ -1 +1 @@
|
|||||||
gtk+-2.11.5.tar.bz2
|
gtk+-2.11.6.tar.bz2
|
||||||
|
35
cups-authstring.patch
Normal file
35
cups-authstring.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
Index: configure.in
|
||||||
|
===================================================================
|
||||||
|
--- configure.in (revision 18526)
|
||||||
|
+++ configure.in (working copy)
|
||||||
|
@@ -1572,6 +1572,15 @@
|
||||||
|
fi
|
||||||
|
AM_CONDITIONAL(HAVE_CUPS, test "x$CUPS_CONFIG" != "xno")
|
||||||
|
|
||||||
|
+gtk_save_cflags="$CFLAGS"
|
||||||
|
+CFLAGS="$CUPS_CFLAGS"
|
||||||
|
+AC_TRY_COMPILE([#include <cups/http.h>],
|
||||||
|
+ [http_t http; char *s = http.authstring;],
|
||||||
|
+ [AC_DEFINE(HAVE_HTTP_AUTHSTRING,[],[Define if cups http_t authstring field is accessible])],)
|
||||||
|
+CFLAGS="$gtk_save_cflags"
|
||||||
|
+
|
||||||
|
+AC_SUBST(HAVE_HTTP_AUTHSTRING)
|
||||||
|
+
|
||||||
|
gtk_save_cppflags="$CPPFLAGS"
|
||||||
|
CPPFLAGS="$CPPFLAGS $GTK_DEP_CFLAGS"
|
||||||
|
|
||||||
|
Index: modules/printbackends/cups/gtkcupsutils.c
|
||||||
|
===================================================================
|
||||||
|
--- modules/printbackends/cups/gtkcupsutils.c (revision 18526)
|
||||||
|
+++ modules/printbackends/cups/gtkcupsutils.c (working copy)
|
||||||
|
@@ -30,10 +30,6 @@
|
||||||
|
#include <stdlib.h>
|
||||||
|
#include <time.h>
|
||||||
|
|
||||||
|
-#if CUPS_VERSION_MAJOR > 1 || (CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR > 1) || (CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR == 1 && CUPS_VERSION_PATCH >= 20)
|
||||||
|
-#define HAVE_HTTP_AUTHSTRING 1
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
typedef void (*GtkCupsRequestStateFunc) (GtkCupsRequest *request);
|
||||||
|
|
||||||
|
static void _connect (GtkCupsRequest *request);
|
16
gtk2.spec
16
gtk2.spec
@ -1,6 +1,6 @@
|
|||||||
# Note that this is NOT a relocatable package
|
# Note that this is NOT a relocatable package
|
||||||
|
|
||||||
%define glib2_base_version 2.13.3
|
%define glib2_base_version 2.13.7
|
||||||
%define glib2_version %{glib2_base_version}-1
|
%define glib2_version %{glib2_base_version}-1
|
||||||
%define pango_base_version 1.15.3
|
%define pango_base_version 1.15.3
|
||||||
%define pango_version %{pango_base_version}-1
|
%define pango_version %{pango_base_version}-1
|
||||||
@ -10,13 +10,13 @@
|
|||||||
%define cairo_version %{cairo_base_version}-1
|
%define cairo_version %{cairo_base_version}-1
|
||||||
%define libpng_version 2:1.2.2-16
|
%define libpng_version 2:1.2.2-16
|
||||||
|
|
||||||
%define base_version 2.11.5
|
%define base_version 2.11.6
|
||||||
%define bin_version 2.10.0
|
%define bin_version 2.10.0
|
||||||
|
|
||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
Name: gtk2
|
Name: gtk2
|
||||||
Version: %{base_version}
|
Version: %{base_version}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPL
|
License: LGPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.gnome.org/sources/gtk+/2.11/gtk+-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/gtk+/2.11/gtk+-%{version}.tar.bz2
|
||||||
@ -29,6 +29,8 @@ Patch0: gtk+-2.4.1-lib64.patch
|
|||||||
Patch1: gtk+-2.11.1-set-invisible-char-to-bullet.patch
|
Patch1: gtk+-2.11.1-set-invisible-char-to-bullet.patch
|
||||||
# use fam for recent-files
|
# use fam for recent-files
|
||||||
#Patch2: gtk+-2.10.3-fam.patch
|
#Patch2: gtk+-2.10.3-fam.patch
|
||||||
|
# fixed in upstream svn
|
||||||
|
Patch3: cups-authstring.patch
|
||||||
|
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: pango-devel >= %{pango_version}
|
BuildRequires: pango-devel >= %{pango_version}
|
||||||
@ -115,6 +117,7 @@ docs for the GTK+ widget toolkit.
|
|||||||
%patch0 -p1 -b .lib64
|
%patch0 -p1 -b .lib64
|
||||||
%patch1 -p1 -b .set-invisible-char-to-bullet
|
%patch1 -p1 -b .set-invisible-char-to-bullet
|
||||||
#%patch2 -p1 -b .fam
|
#%patch2 -p1 -b .fam
|
||||||
|
%patch3 -p0 -b .authstring
|
||||||
|
|
||||||
for i in config.guess config.sub ; do
|
for i in config.guess config.sub ; do
|
||||||
test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
|
test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
|
||||||
@ -285,6 +288,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc tmpdocs/examples
|
%doc tmpdocs/examples
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 23 2007 Matthias Clasen <mclasen@redhat.com> - 2.11.6-1
|
||||||
|
- Update to 2.11.6
|
||||||
|
- Make it build against recent cups
|
||||||
|
|
||||||
|
* Thu Jul 19 2007 Matthias Clasen <mclasen@redhat.com> - 2.11.5-4
|
||||||
|
- Up the glib requirement
|
||||||
|
|
||||||
* Sun Jul 8 2007 Matthias Clasen <mclasen@redhat.com> - 2.11.5-3
|
* Sun Jul 8 2007 Matthias Clasen <mclasen@redhat.com> - 2.11.5-3
|
||||||
- Own /usr/lib/gtk-2.0/modules
|
- Own /usr/lib/gtk-2.0/modules
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user