fix an entrycompletion crash
This commit is contained in:
parent
6d56719626
commit
ee7b009202
39
dont-use-deprecated-api.patch
Normal file
39
dont-use-deprecated-api.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
diff --git a/gtk/gtkcombobox.c b/gtk/gtkcombobox.c
|
||||||
|
index 555418a..30545f6 100644
|
||||||
|
--- a/gtk/gtkcombobox.c
|
||||||
|
+++ b/gtk/gtkcombobox.c
|
||||||
|
@@ -1695,7 +1695,7 @@ cell_view_is_sensitive (GtkCellView *cell_view)
|
||||||
|
GList *cells, *list;
|
||||||
|
gboolean sensitive;
|
||||||
|
|
||||||
|
- cells = gtk_cell_view_get_cell_renderers (cell_view);
|
||||||
|
+ cells = gtk_cell_layout_get_cells (GTK_CELL_LAYOUT (cell_view));
|
||||||
|
|
||||||
|
sensitive = FALSE;
|
||||||
|
for (list = cells; list; list = list->next)
|
||||||
|
diff --git a/gtk/gtkentrycompletion.c b/gtk/gtkentrycompletion.c
|
||||||
|
index e2e0142..cb02c5a 100644
|
||||||
|
--- a/gtk/gtkentrycompletion.c
|
||||||
|
+++ b/gtk/gtkentrycompletion.c
|
||||||
|
@@ -758,7 +758,7 @@ gtk_entry_completion_get_cells (GtkCellLayout *cell_layout)
|
||||||
|
|
||||||
|
priv = GTK_ENTRY_COMPLETION_GET_PRIVATE (cell_layout);
|
||||||
|
|
||||||
|
- return gtk_tree_view_column_get_cell_renderers (priv->column);
|
||||||
|
+ return gtk_cell_layout_get_cells (GTK_CELL_LAYOUT (priv->column));
|
||||||
|
}
|
||||||
|
|
||||||
|
/* all those callbacks */
|
||||||
|
diff --git a/gtk/gtkfilechooserdefault.c b/gtk/gtkfilechooserdefault.c
|
||||||
|
index 22836c1..7dc9867 100644
|
||||||
|
--- a/gtk/gtkfilechooserdefault.c
|
||||||
|
+++ b/gtk/gtkfilechooserdefault.c
|
||||||
|
@@ -3707,7 +3707,7 @@ rename_selected_bookmark (GtkFileChooserDefault *impl)
|
||||||
|
{
|
||||||
|
path = gtk_tree_model_get_path (GTK_TREE_MODEL (impl->shortcuts_model), &iter);
|
||||||
|
column = gtk_tree_view_get_column (GTK_TREE_VIEW (impl->browse_shortcuts_tree_view), 0);
|
||||||
|
- renderers = gtk_tree_view_column_get_cell_renderers (column);
|
||||||
|
+ renderers = gtk_cell_layout_get_cells (GTK_CELL_LAYOUT (column));
|
||||||
|
cell = g_list_nth_data (renderers, 1);
|
||||||
|
g_list_free (renderers);
|
||||||
|
g_object_set (cell, "editable", TRUE, NULL);
|
12
gtk2.spec
12
gtk2.spec
@ -17,7 +17,7 @@
|
|||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
Name: gtk2
|
Name: gtk2
|
||||||
Version: %{base_version}
|
Version: %{base_version}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.gnome.org/sources/gtk+/2.17/gtk+-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/gtk+/2.17/gtk+-%{version}.tar.bz2
|
||||||
@ -27,7 +27,9 @@ Source2: update-gtk-immodules
|
|||||||
# Biarch changes
|
# Biarch changes
|
||||||
Patch0: gtk+-2.13.5-lib64.patch
|
Patch0: gtk+-2.13.5-lib64.patch
|
||||||
# http://bugzilla.redhat.com/show_bug.cgi?id=478400
|
# http://bugzilla.redhat.com/show_bug.cgi?id=478400
|
||||||
Patch3: default_printer.patch
|
Patch1: default_printer.patch
|
||||||
|
# upstream
|
||||||
|
Patch2: dont-use-deprecated-api.patch
|
||||||
|
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: pango-devel >= %{pango_version}
|
BuildRequires: pango-devel >= %{pango_version}
|
||||||
@ -137,7 +139,8 @@ This package contains developer documentation for the GTK+ widget toolkit.
|
|||||||
%setup -q -n gtk+-%{version}
|
%setup -q -n gtk+-%{version}
|
||||||
|
|
||||||
%patch0 -p1 -b .lib64
|
%patch0 -p1 -b .lib64
|
||||||
%patch3 -p0 -b .default-printer
|
%patch1 -p0 -b .default-printer
|
||||||
|
%patch2 -p1 -b .deprecated-api
|
||||||
|
|
||||||
# make sure that gtkmarshalers.{c, h} get regenerated during the build
|
# make sure that gtkmarshalers.{c, h} get regenerated during the build
|
||||||
# - caused by print_authentication.patch
|
# - caused by print_authentication.patch
|
||||||
@ -370,6 +373,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 16 2009 Matthias Clasen <mclasen@redhat.com> - 2.27.2-2
|
||||||
|
- Fix an entry completion crash
|
||||||
|
|
||||||
* Mon Jun 15 2009 Matthias Clasen <mclasen@redhat.com> - 2.17.2-1
|
* Mon Jun 15 2009 Matthias Clasen <mclasen@redhat.com> - 2.17.2-1
|
||||||
- Update to 2.17.2
|
- Update to 2.17.2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user