2.10.10
This commit is contained in:
parent
8fc72a4878
commit
a1c39e7c69
23
gtk+-2.10.10-tab-detach.patch
Normal file
23
gtk+-2.10.10-tab-detach.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
--- gtk+-2.10.10/gtk/gtknotebook.c.detach 2007-03-12 23:36:03.000000000 -0400
|
||||||
|
+++ gtk+-2.10.10/gtk/gtknotebook.c 2007-03-12 23:42:11.000000000 -0400
|
||||||
|
@@ -3926,9 +3926,6 @@
|
||||||
|
else
|
||||||
|
g_object_ref_sink (page->menu_label);
|
||||||
|
|
||||||
|
- /* child visible will be turned on by switch_page below */
|
||||||
|
- gtk_widget_set_child_visible (child, FALSE);
|
||||||
|
-
|
||||||
|
if (notebook->menu)
|
||||||
|
gtk_notebook_menu_item_create (notebook,
|
||||||
|
g_list_find (notebook->children, page));
|
||||||
|
@@ -3942,6 +3939,10 @@
|
||||||
|
if (!notebook->first_tab)
|
||||||
|
notebook->first_tab = notebook->children;
|
||||||
|
|
||||||
|
+ /* child visible will be turned on by switch_page below */
|
||||||
|
+ if (notebook->cur_page != page)
|
||||||
|
+ gtk_widget_set_child_visible (child, FALSE);
|
||||||
|
+
|
||||||
|
if (tab_label)
|
||||||
|
{
|
||||||
|
if (notebook->show_tabs && GTK_WIDGET_VISIBLE (child))
|
13
gtk2.spec
13
gtk2.spec
@ -10,13 +10,13 @@
|
|||||||
%define cairo_version %{cairo_base_version}-1
|
%define cairo_version %{cairo_base_version}-1
|
||||||
%define libpng_version 2:1.2.2-16
|
%define libpng_version 2:1.2.2-16
|
||||||
|
|
||||||
%define base_version 2.10.9
|
%define base_version 2.10.10
|
||||||
%define bin_version 2.10.0
|
%define bin_version 2.10.0
|
||||||
|
|
||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
Name: gtk2
|
Name: gtk2
|
||||||
Version: %{base_version}
|
Version: %{base_version}
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPL
|
License: LGPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://ftp.gnome.org/pub/gnome/sources/gtk+/2.10/gtk+-%{version}.tar.bz2
|
Source: http://ftp.gnome.org/pub/gnome/sources/gtk+/2.10/gtk+-%{version}.tar.bz2
|
||||||
@ -38,6 +38,9 @@ Patch7: gtk+-2.10.7-cursor-blink.patch
|
|||||||
# fixed in upstream cvs
|
# fixed in upstream cvs
|
||||||
Patch10: gtk+-2.10.4-im-reset.patch
|
Patch10: gtk+-2.10.4-im-reset.patch
|
||||||
|
|
||||||
|
# fixed in upstream svn
|
||||||
|
Patch11: gtk+-2.10.10-tab-detach.patch
|
||||||
|
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: pango-devel >= %{pango_version}
|
BuildRequires: pango-devel >= %{pango_version}
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
@ -122,6 +125,7 @@ docs for the GTK+ widget toolkit.
|
|||||||
|
|
||||||
%patch7 -p1 -b .cursor-blink
|
%patch7 -p1 -b .cursor-blink
|
||||||
%patch10 -p1 -b .im-reset
|
%patch10 -p1 -b .im-reset
|
||||||
|
%patch11 -p1 -b .tab-detach
|
||||||
|
|
||||||
for i in config.guess config.sub ; do
|
for i in config.guess config.sub ; do
|
||||||
test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
|
test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
|
||||||
@ -288,8 +292,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc tmpdocs/examples
|
%doc tmpdocs/examples
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.10.10-1
|
||||||
|
- Update to 2.10.10
|
||||||
|
|
||||||
* Fri Feb 9 2007 Stepan Kasal <skasal@redhat.com> - 2.10.9-4
|
* Fri Feb 9 2007 Stepan Kasal <skasal@redhat.com> - 2.10.9-4
|
||||||
- Clean up the autotools calles in %%prep.
|
- Clean up the autotools calls in %%prep.
|
||||||
|
|
||||||
* Fri Feb 2 2007 Matthias Clasen <mclasen@redhat.com> - 2.10.9-3
|
* Fri Feb 2 2007 Matthias Clasen <mclasen@redhat.com> - 2.10.9-3
|
||||||
- Fix update-gtk-immodules and update-gdk-pixbuf-loaders
|
- Fix update-gtk-immodules and update-gdk-pixbuf-loaders
|
||||||
|
Loading…
Reference in New Issue
Block a user