Lower gobject-introspection reqs
This commit is contained in:
parent
942f8679ed
commit
96caf6ab5b
@ -1,37 +0,0 @@
|
|||||||
From 6af981739294d3e30835e5eceee47b969de5f20f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Matthias Clasen <mclasen@redhat.com>
|
|
||||||
Date: Mon, 28 Jun 2010 12:38:38 -0400
|
|
||||||
Subject: [PATCH] Fix dynamic module check
|
|
||||||
|
|
||||||
Also, prevent a stray 'yes' in configure output by putting the
|
|
||||||
corresponding AC_MSG_CHECKING call back
|
|
||||||
|
|
||||||
Bug 623016
|
|
||||||
---
|
|
||||||
configure.in | 3 ++-
|
|
||||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.in b/configure.in
|
|
||||||
index 5a65632..dbd04f0 100644
|
|
||||||
--- a/configure.in
|
|
||||||
+++ b/configure.in
|
|
||||||
@@ -751,6 +751,7 @@ AC_MSG_RESULT($gtk_uxtheme_h)
|
|
||||||
AC_CHECK_HEADERS(crt_externs.h)
|
|
||||||
AC_CHECK_FUNCS(_NSGetEnviron)
|
|
||||||
|
|
||||||
+AC_MSG_CHECKING(whether to build dynamic modules)
|
|
||||||
|
|
||||||
AC_ARG_ENABLE(modules,
|
|
||||||
[AC_HELP_STRING([--disable-modules],
|
|
||||||
@@ -773,7 +774,7 @@ else
|
|
||||||
dnl (in a rather ugly way even)
|
|
||||||
if $dynworks; then
|
|
||||||
module_libtool_config="${CONFIG_SHELL-/bin/sh} ./libtool --config"
|
|
||||||
- module_deplibs_check=`$pixbuf_libtool_config | \
|
|
||||||
+ module_deplibs_check=`$module_libtool_config | \
|
|
||||||
grep '^[[a-z_]]*check[[a-z_]]*_method=[['\''"]]' | \
|
|
||||||
sed 's/.*[['\''"]]\(.*\)[['\''"]]$/\1/'`
|
|
||||||
if test "x$module_deplibs_check" = "xnone" || \
|
|
||||||
--
|
|
||||||
1.7.1
|
|
||||||
|
|
@ -33,6 +33,8 @@ Patch0: gtk-lib64.patch
|
|||||||
Patch1: system-python.patch
|
Patch1: system-python.patch
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=583273
|
# https://bugzilla.gnome.org/show_bug.cgi?id=583273
|
||||||
Patch2: icon-padding.patch
|
Patch2: icon-padding.patch
|
||||||
|
# http://git.gnome.org/browse/gtk+/commit/?h=gtk-2-22&id=62c2b4f529334b57323287c8bd04022eaf963ce6
|
||||||
|
Patch3: lower-gi-deps.patch
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=599617
|
# https://bugzilla.gnome.org/show_bug.cgi?id=599617
|
||||||
Patch4: fresh-tooltips.patch
|
Patch4: fresh-tooltips.patch
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=599618
|
# https://bugzilla.gnome.org/show_bug.cgi?id=599618
|
||||||
@ -153,12 +155,16 @@ This package contains developer documentation for the GTK+ widget toolkit.
|
|||||||
%patch0 -p1 -b .lib64
|
%patch0 -p1 -b .lib64
|
||||||
%patch1 -p1 -b .system-python
|
%patch1 -p1 -b .system-python
|
||||||
%patch2 -p1 -b .icon-padding
|
%patch2 -p1 -b .icon-padding
|
||||||
|
%patch3 -p1 -b .lower-gi-deps
|
||||||
%patch4 -p1 -b .fresh-tooltips
|
%patch4 -p1 -b .fresh-tooltips
|
||||||
%patch8 -p1 -b .tooltip-positioning
|
%patch8 -p1 -b .tooltip-positioning
|
||||||
#%patch14 -p1 -b .landscape-pdf-print
|
#%patch14 -p1 -b .landscape-pdf-print
|
||||||
%patch15 -p1 -b .window-dragging
|
%patch15 -p1 -b .window-dragging
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
# For the gobject-introspection patch
|
||||||
|
rm -f configure
|
||||||
|
|
||||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||||
%configure $CONFIGFLAGS \
|
%configure $CONFIGFLAGS \
|
||||||
--with-xinput=xfree \
|
--with-xinput=xfree \
|
||||||
|
34
lower-gi-deps.patch
Normal file
34
lower-gi-deps.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From 62c2b4f529334b57323287c8bd04022eaf963ce6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Colin Walters <walters@verbum.org>
|
||||||
|
Date: Wed, 15 Sep 2010 19:13:05 +0000
|
||||||
|
Subject: introspection: Only use 0.9.3 API
|
||||||
|
|
||||||
|
---
|
||||||
|
diff --git a/configure.in b/configure.in
|
||||||
|
index 63331c4..bf109d9 100644
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -1565,7 +1565,7 @@ fi
|
||||||
|
# GObject introspection
|
||||||
|
##################################################
|
||||||
|
|
||||||
|
-GOBJECT_INTROSPECTION_CHECK([0.9.5])
|
||||||
|
+GOBJECT_INTROSPECTION_CHECK([0.9.3])
|
||||||
|
|
||||||
|
##################################################
|
||||||
|
# Checks for gtk-doc and docbook-tools
|
||||||
|
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
|
||||||
|
index c8b2102..06de1a4 100644
|
||||||
|
--- a/gdk/Makefile.am
|
||||||
|
+++ b/gdk/Makefile.am
|
||||||
|
@@ -238,7 +238,7 @@ x11_introspection_files = \
|
||||||
|
x11/gdkx.h
|
||||||
|
|
||||||
|
GdkX11-2.0.gir: $(gdktargetlib) Gdk-2.0.gir Makefile
|
||||||
|
-GdkX11_2_0_gir_SCANNERFLAGS = --warn-all --identifier-prefix=Gdk --symbol-prefix=gdk
|
||||||
|
+GdkX11_2_0_gir_SCANNERFLAGS = --warn-all --strip-prefix=Gdk
|
||||||
|
GdkX11_2_0_gir_INCLUDES = Gio-2.0 Gdk-2.0 GdkPixbuf-2.0 Pango-1.0 xlib-2.0
|
||||||
|
GdkX11_2_0_gir_LIBS = $(gdktargetlib)
|
||||||
|
GdkX11_2_0_gir_FILES = $(x11_introspection_files)
|
||||||
|
--
|
||||||
|
cgit v0.8.3.1
|
Loading…
Reference in New Issue
Block a user