2.15.2
This commit is contained in:
parent
9047fab0f0
commit
4612e4de14
@ -1 +1 @@
|
|||||||
gtk+-2.15.1.tar.bz2
|
gtk+-2.15.2.tar.bz2
|
||||||
|
@ -1,43 +0,0 @@
|
|||||||
Index: gtk/gtktoolbutton.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtktoolbutton.c (revision 22204)
|
|
||||||
+++ gtk/gtktoolbutton.c (working copy)
|
|
||||||
@@ -772,6 +772,7 @@ gtk_tool_button_activatable_update (GtkA
|
|
||||||
gtk_tool_button_set_label (button, NULL);
|
|
||||||
gtk_tool_button_set_icon_name (button, NULL);
|
|
||||||
}
|
|
||||||
+ gtk_tool_button_set_icon_widget (button, NULL);
|
|
||||||
gtk_tool_button_set_stock_id (button, gtk_action_get_stock_id (action));
|
|
||||||
}
|
|
||||||
else if (strcmp (property_name, "gicon") == 0)
|
|
||||||
@@ -812,6 +813,7 @@ gtk_tool_button_activatable_reset (GtkAc
|
|
||||||
{
|
|
||||||
GtkToolButton *button;
|
|
||||||
GIcon *icon;
|
|
||||||
+ const gchar *stock_id;
|
|
||||||
|
|
||||||
parent_activatable_iface->reset (activatable, action);
|
|
||||||
|
|
||||||
@@ -822,14 +824,15 @@ gtk_tool_button_activatable_reset (GtkAc
|
|
||||||
return;
|
|
||||||
|
|
||||||
button = GTK_TOOL_BUTTON (activatable);
|
|
||||||
-
|
|
||||||
- gtk_tool_button_set_label (button, NULL);
|
|
||||||
- gtk_tool_button_set_stock_id (button, NULL);
|
|
||||||
- gtk_tool_button_set_icon_name (button, NULL);
|
|
||||||
+ stock_id = gtk_action_get_stock_id (action);
|
|
||||||
+
|
|
||||||
+ gtk_tool_button_set_label (button, gtk_action_get_short_label (action));
|
|
||||||
gtk_tool_button_set_use_underline (button, TRUE);
|
|
||||||
-
|
|
||||||
- if (gtk_action_get_stock_id (action))
|
|
||||||
- gtk_tool_button_set_stock_id (button, gtk_action_get_stock_id (action));
|
|
||||||
+ gtk_tool_button_set_stock_id (button, stock_id);
|
|
||||||
+ gtk_tool_button_set_icon_name (button, gtk_action_get_icon_name (action));
|
|
||||||
+
|
|
||||||
+ if (stock_id && gtk_icon_factory_lookup_default (stock_id))
|
|
||||||
+ gtk_tool_button_set_icon_widget (button, NULL);
|
|
||||||
else if ((icon = gtk_action_get_gicon (action)) != NULL)
|
|
||||||
{
|
|
||||||
GtkIconSize icon_size = gtk_tool_item_get_icon_size (GTK_TOOL_ITEM (button));
|
|
@ -1,29 +0,0 @@
|
|||||||
--- gtk+-2.11.1/gtk/gtkentry.c.set-invisible-char-to-bullet 2007-06-04 11:33:19.000000000 -0400
|
|
||||||
+++ gtk+-2.11.1/gtk/gtkentry.c 2007-06-04 13:52:40.000000000 -0400
|
|
||||||
@@ -537,7 +537,7 @@ gtk_entry_class_init (GtkEntryClass *cla
|
|
||||||
g_param_spec_unichar ("invisible-char",
|
|
||||||
P_("Invisible character"),
|
|
||||||
P_("The character to use when masking entry contents (in \"password mode\")"),
|
|
||||||
- '*',
|
|
||||||
+ (gunichar) 0x2022,
|
|
||||||
GTK_PARAM_READWRITE));
|
|
||||||
|
|
||||||
g_object_class_install_property (gobject_class,
|
|
||||||
@@ -1101,7 +1101,7 @@ gtk_entry_init (GtkEntry *entry)
|
|
||||||
|
|
||||||
entry->editable = TRUE;
|
|
||||||
entry->visible = TRUE;
|
|
||||||
- entry->invisible_char = '*';
|
|
||||||
+ entry->invisible_char = (gunichar) 0x2022;
|
|
||||||
entry->dnd_position = -1;
|
|
||||||
entry->width_chars = -1;
|
|
||||||
entry->is_cell_renderer = FALSE;
|
|
||||||
@@ -4495,7 +4495,7 @@ gtk_entry_get_visibility (GtkEntry *entr
|
|
||||||
* gtk_entry_set_visibility() has been called to set text visibility
|
|
||||||
* to %FALSE. i.e. this is the character used in "password mode" to
|
|
||||||
* show the user how many characters have been typed. The default
|
|
||||||
- * invisible char is an asterisk ('*'). If you set the invisible char
|
|
||||||
+ * invisible char is a small bullet (Unicode character 2022). If you set the invisible char
|
|
||||||
* to 0, then the user will get no feedback at all; there will be
|
|
||||||
* no text on the screen as they type.
|
|
||||||
**/
|
|
20
gtk2.spec
20
gtk2.spec
@ -10,13 +10,13 @@
|
|||||||
%define cairo_version %{cairo_base_version}-1
|
%define cairo_version %{cairo_base_version}-1
|
||||||
%define libpng_version 2:1.2.2-16
|
%define libpng_version 2:1.2.2-16
|
||||||
|
|
||||||
%define base_version 2.15.1
|
%define base_version 2.15.2
|
||||||
%define bin_version 2.10.0
|
%define bin_version 2.10.0
|
||||||
|
|
||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
Name: gtk2
|
Name: gtk2
|
||||||
Version: %{base_version}
|
Version: %{base_version}
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.gnome.org/sources/gtk+/2.15/gtk+-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/gtk+/2.15/gtk+-%{version}.tar.bz2
|
||||||
@ -30,14 +30,6 @@ Patch0: gtk+-2.13.5-lib64.patch
|
|||||||
Patch2: workaround.patch
|
Patch2: workaround.patch
|
||||||
# http://bugzilla.redhat.com/show_bug.cgi?id=478400
|
# http://bugzilla.redhat.com/show_bug.cgi?id=478400
|
||||||
Patch3: default_printer.patch
|
Patch3: default_printer.patch
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=569240
|
|
||||||
Patch8: gtk-2.15.1-scale-marks-crasher.patch
|
|
||||||
|
|
||||||
# fixed upstream
|
|
||||||
Patch4: activatable-toolitem.patch
|
|
||||||
Patch5: imcontext-reset.patch
|
|
||||||
Patch6: radio-proxy.patch
|
|
||||||
Patch7: tool-proxy.patch
|
|
||||||
|
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: pango-devel >= %{pango_version}
|
BuildRequires: pango-devel >= %{pango_version}
|
||||||
@ -125,11 +117,6 @@ GTK+ widget toolkit.
|
|||||||
%patch0 -p1 -b .lib64
|
%patch0 -p1 -b .lib64
|
||||||
%patch2 -p1 -b .workaround
|
%patch2 -p1 -b .workaround
|
||||||
%patch3 -p0 -b .default-printer
|
%patch3 -p0 -b .default-printer
|
||||||
%patch4 -p0 -b .activatable-toolitem
|
|
||||||
%patch5 -p0 -b .imcontext-reset
|
|
||||||
%patch6 -p1 -b .radio-proxy
|
|
||||||
%patch7 -p0 -b .tool-proxy
|
|
||||||
%patch8 -p0 -b .scale-marks
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
libtoolize --force --copy
|
libtoolize --force --copy
|
||||||
@ -307,6 +294,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/gtk-2.0
|
%{_datadir}/gtk-2.0
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 27 2009 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
|
||||||
|
- Update to 2.15.2
|
||||||
|
|
||||||
* Mon Jan 26 2009 - Bastien Nocera <bnocera@redhat.com> - 2.15.1-5
|
* Mon Jan 26 2009 - Bastien Nocera <bnocera@redhat.com> - 2.15.1-5
|
||||||
- Add patch to avoid crashes when destroying a GtkScale with marks
|
- Add patch to avoid crashes when destroying a GtkScale with marks
|
||||||
|
|
||||||
|
@ -1,70 +0,0 @@
|
|||||||
Index: gtk/gtktextview.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtktextview.c (revision 22213)
|
|
||||||
+++ gtk/gtktextview.c (working copy)
|
|
||||||
@@ -2076,8 +2076,7 @@
|
|
||||||
*/
|
|
||||||
area.width = 0;
|
|
||||||
|
|
||||||
- if (GTK_WIDGET_REALIZED (text_view))
|
|
||||||
- gtk_im_context_set_cursor_location (text_view->im_context, &area);
|
|
||||||
+ gtk_im_context_set_cursor_location (text_view->im_context, &area);
|
|
||||||
}
|
|
||||||
|
|
||||||
static gboolean
|
|
||||||
@@ -3840,7 +3839,7 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Ensure updating the spot location. */
|
|
||||||
- gtk_text_view_update_im_spot_location(text_view);
|
|
||||||
+ gtk_text_view_update_im_spot_location (text_view);
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
||||||
Index: gtk/gtkimmulticontext.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtkimmulticontext.c (revision 22213)
|
|
||||||
+++ gtk/gtkimmulticontext.c (working copy)
|
|
||||||
@@ -226,7 +226,7 @@
|
|
||||||
if (!multicontext->slave)
|
|
||||||
{
|
|
||||||
GtkIMContext *slave;
|
|
||||||
-
|
|
||||||
+
|
|
||||||
g_free (multicontext->context_id);
|
|
||||||
|
|
||||||
if (multicontext->priv->context_id)
|
|
||||||
@@ -258,18 +258,14 @@
|
|
||||||
GdkWindow *window)
|
|
||||||
{
|
|
||||||
GtkIMMulticontext *multicontext = GTK_IM_MULTICONTEXT (context);
|
|
||||||
- GtkIMContext *slave;
|
|
||||||
GdkScreen *screen;
|
|
||||||
GtkSettings *settings;
|
|
||||||
gboolean connected;
|
|
||||||
|
|
||||||
multicontext->priv->client_window = window;
|
|
||||||
|
|
||||||
- slave = gtk_im_multicontext_get_slave (multicontext);
|
|
||||||
+ gtk_im_multicontext_set_slave (multicontext, NULL, FALSE);
|
|
||||||
|
|
||||||
- if (slave)
|
|
||||||
- gtk_im_context_set_client_window (slave, window);
|
|
||||||
-
|
|
||||||
if (window == NULL)
|
|
||||||
return;
|
|
||||||
|
|
||||||
Index: gtk/gtkimmodule.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtkimmodule.c (revision 22213)
|
|
||||||
+++ gtk/gtkimmodule.c (working copy)
|
|
||||||
@@ -671,9 +671,6 @@
|
|
||||||
GdkScreen *screen;
|
|
||||||
GtkSettings *settings;
|
|
||||||
|
|
||||||
- /* assertion to make sure all of the unexpected invocation is really gone. */
|
|
||||||
- g_return_val_if_fail (client_window != NULL, SIMPLE_ID);
|
|
||||||
-
|
|
||||||
if (!contexts_hash)
|
|
||||||
gtk_im_module_initialize ();
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up gtk+-2.15.1/gtk/gtkradioaction.c.radio-proxy gtk+-2.15.1/gtk/gtkradioaction.c
|
|
||||||
--- gtk+-2.15.1/gtk/gtkradioaction.c.radio-proxy 2009-01-25 19:00:44.000000000 -0500
|
|
||||||
+++ gtk+-2.15.1/gtk/gtkradioaction.c 2009-01-25 19:01:09.000000000 -0500
|
|
||||||
@@ -176,6 +176,8 @@ gtk_radio_action_init (GtkRadioAction *a
|
|
||||||
action->private_data = GTK_RADIO_ACTION_GET_PRIVATE (action);
|
|
||||||
action->private_data->group = g_slist_prepend (NULL, action);
|
|
||||||
action->private_data->value = 0;
|
|
||||||
+
|
|
||||||
+ gtk_toggle_action_set_draw_as_radio (GTK_TOGGLE_ACTION (action), TRUE);
|
|
||||||
}
|
|
||||||
|
|
||||||
/**
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
08bd30294bec395078a2554d642d3b2d gtk+-2.15.1.tar.bz2
|
1c230eeb1bf24b69b480d0a35da34794 gtk+-2.15.2.tar.bz2
|
||||||
|
120
tool-proxy.patch
120
tool-proxy.patch
@ -1,120 +0,0 @@
|
|||||||
Index: gtk/gtktoggletoolbutton.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtktoggletoolbutton.c (revision 22216)
|
|
||||||
+++ gtk/gtktoggletoolbutton.c (working copy)
|
|
||||||
@@ -201,11 +201,17 @@
|
|
||||||
GtkStockItem stock_item;
|
|
||||||
gboolean use_mnemonic = TRUE;
|
|
||||||
const char *label;
|
|
||||||
+ GtkWidget *label_widget;
|
|
||||||
+ const gchar *label_text;
|
|
||||||
+ const gchar *stock_id;
|
|
||||||
|
|
||||||
- GtkWidget *label_widget = gtk_tool_button_get_label_widget (tool_button);
|
|
||||||
- const gchar *label_text = gtk_tool_button_get_label (tool_button);
|
|
||||||
- const gchar *stock_id = gtk_tool_button_get_stock_id (tool_button);
|
|
||||||
+ if (_gtk_tool_item_create_menu_proxy (item))
|
|
||||||
+ return TRUE;
|
|
||||||
|
|
||||||
+ label_widget = gtk_tool_button_get_label_widget (tool_button);
|
|
||||||
+ label_text = gtk_tool_button_get_label (tool_button);
|
|
||||||
+ stock_id = gtk_tool_button_get_stock_id (tool_button);
|
|
||||||
+
|
|
||||||
if (GTK_IS_LABEL (label_widget))
|
|
||||||
{
|
|
||||||
label = gtk_label_get_label (GTK_LABEL (label_widget));
|
|
||||||
Index: gtk/gtktoolbutton.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtktoolbutton.c (revision 22216)
|
|
||||||
+++ gtk/gtktoolbutton.c (working copy)
|
|
||||||
@@ -642,6 +642,9 @@
|
|
||||||
gboolean use_mnemonic = TRUE;
|
|
||||||
const char *label;
|
|
||||||
|
|
||||||
+ if (_gtk_tool_item_create_menu_proxy (item))
|
|
||||||
+ return TRUE;
|
|
||||||
+
|
|
||||||
if (GTK_IS_LABEL (button->priv->label_widget))
|
|
||||||
{
|
|
||||||
label = gtk_label_get_label (GTK_LABEL (button->priv->label_widget));
|
|
||||||
Index: gtk/gtkrecentchoosermenu.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtkrecentchoosermenu.c (revision 22216)
|
|
||||||
+++ gtk/gtkrecentchoosermenu.c (working copy)
|
|
||||||
@@ -970,6 +970,8 @@
|
|
||||||
|
|
||||||
return FALSE;
|
|
||||||
}
|
|
||||||
+ else
|
|
||||||
+ gtk_widget_hide (pdata->placeholder);
|
|
||||||
|
|
||||||
pdata->n_items = g_list_length (pdata->items);
|
|
||||||
pdata->loaded_items = 0;
|
|
||||||
@@ -1056,9 +1058,8 @@
|
|
||||||
|
|
||||||
priv->icon_size = get_icon_size_for_widget (GTK_WIDGET (menu));
|
|
||||||
|
|
||||||
- /* remove our menu items first and hide the placeholder */
|
|
||||||
+ /* remove our menu items first */
|
|
||||||
gtk_recent_chooser_menu_dispose_items (menu);
|
|
||||||
- gtk_widget_hide (priv->placeholder);
|
|
||||||
|
|
||||||
priv->populate_id = gdk_threads_add_idle_full (G_PRIORITY_HIGH_IDLE + 30,
|
|
||||||
idle_populate_func,
|
|
||||||
Index: gtk/gtktoolitem.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtktoolitem.c (revision 22216)
|
|
||||||
+++ gtk/gtktoolitem.c (working copy)
|
|
||||||
@@ -127,8 +127,6 @@
|
|
||||||
const gchar *tip_text,
|
|
||||||
const gchar *tip_private);
|
|
||||||
|
|
||||||
-static gboolean gtk_tool_item_create_menu_proxy (GtkToolItem *item);
|
|
||||||
-
|
|
||||||
static void gtk_tool_item_activatable_interface_init (GtkActivatableIface *iface);
|
|
||||||
static void gtk_tool_item_activatable_update (GtkActivatable *activatable,
|
|
||||||
GtkAction *action,
|
|
||||||
@@ -169,7 +167,7 @@
|
|
||||||
widget_class->size_allocate = gtk_tool_item_size_allocate;
|
|
||||||
widget_class->parent_set = gtk_tool_item_parent_set;
|
|
||||||
|
|
||||||
- klass->create_menu_proxy = gtk_tool_item_create_menu_proxy;
|
|
||||||
+ klass->create_menu_proxy = _gtk_tool_item_create_menu_proxy;
|
|
||||||
klass->set_tooltip = gtk_tool_item_real_set_tooltip;
|
|
||||||
|
|
||||||
g_object_class_install_property (object_class,
|
|
||||||
@@ -554,8 +552,8 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
-static gboolean
|
|
||||||
-gtk_tool_item_create_menu_proxy (GtkToolItem *item)
|
|
||||||
+gboolean
|
|
||||||
+_gtk_tool_item_create_menu_proxy (GtkToolItem *item)
|
|
||||||
{
|
|
||||||
GtkWidget *menu_item;
|
|
||||||
gboolean visible_overflown;
|
|
||||||
@@ -574,6 +572,8 @@
|
|
||||||
}
|
|
||||||
else
|
|
||||||
gtk_tool_item_set_proxy_menu_item (item, "gtk-action-menu-item", NULL);
|
|
||||||
+
|
|
||||||
+ return TRUE;
|
|
||||||
}
|
|
||||||
|
|
||||||
return FALSE;
|
|
||||||
Index: gtk/gtktoolitem.h
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtktoolitem.h (revision 22216)
|
|
||||||
+++ gtk/gtktoolitem.h (working copy)
|
|
||||||
@@ -128,6 +128,10 @@
|
|
||||||
|
|
||||||
void gtk_tool_item_toolbar_reconfigured (GtkToolItem *tool_item);
|
|
||||||
|
|
||||||
+/* private */
|
|
||||||
+
|
|
||||||
+gboolean _gtk_tool_item_create_menu_proxy (GtkToolItem *tool_item);
|
|
||||||
+
|
|
||||||
G_END_DECLS
|
|
||||||
|
|
||||||
#endif /* __GTK_TOOL_ITEM_H__ */
|
|
Loading…
Reference in New Issue
Block a user