Fix turkish totem
This commit is contained in:
parent
9ba48433a6
commit
4116e550e6
30
builder-turkish.patch
Normal file
30
builder-turkish.patch
Normal file
@ -0,0 +1,30 @@
|
||||
--- trunk/gtk/gtkbuilder.c 2007/09/14 00:56:57 18820
|
||||
+++ trunk/gtk/gtkbuilder.c 2007/10/22 09:15:50 18939
|
||||
@@ -21,7 +21,6 @@
|
||||
*/
|
||||
|
||||
#include <config.h>
|
||||
-#include <ctype.h> /* tolower, toupper */
|
||||
#include <errno.h> /* errno */
|
||||
#include <stdlib.h> /* strtol, strtoul */
|
||||
#include <string.h> /* strlen */
|
||||
@@ -210,13 +209,13 @@
|
||||
{
|
||||
c = name[i];
|
||||
/* skip if uppercase, first or previous is uppercase */
|
||||
- if ((c == toupper (c) &&
|
||||
- i > 0 && name[i-1] != toupper (name[i-1])) ||
|
||||
- (i > 2 && name[i] == toupper (name[i]) &&
|
||||
- name[i-1] == toupper (name[i-1]) &&
|
||||
- name[i-2] == toupper (name[i-2])))
|
||||
+ if ((c == g_ascii_toupper (c) &&
|
||||
+ i > 0 && name[i-1] != g_ascii_toupper (name[i-1])) ||
|
||||
+ (i > 2 && name[i] == g_ascii_toupper (name[i]) &&
|
||||
+ name[i-1] == g_ascii_toupper (name[i-1]) &&
|
||||
+ name[i-2] == g_ascii_toupper (name[i-2])))
|
||||
g_string_append_c (symbol_name, '_');
|
||||
- g_string_append_c (symbol_name, tolower (c));
|
||||
+ g_string_append_c (symbol_name, g_ascii_tolower (c));
|
||||
}
|
||||
g_string_append (symbol_name, "_get_type");
|
||||
|
10
gtk2.spec
10
gtk2.spec
@ -16,7 +16,7 @@
|
||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||
Name: gtk2
|
||||
Version: %{base_version}
|
||||
Release: 3%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
Source: http://download.gnome.org/sources/gtk+/2.12/gtk+-%{version}.tar.bz2
|
||||
@ -37,6 +37,9 @@ Patch3: firefox-print-preview.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=488119
|
||||
Patch4: system-log-crash.patch
|
||||
|
||||
# fixed in upstream svn
|
||||
Patch5: builder-turkish.patch
|
||||
|
||||
BuildRequires: atk-devel >= %{atk_version}
|
||||
BuildRequires: pango-devel >= %{pango_version}
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
@ -115,6 +118,7 @@ docs for the GTK+ widget toolkit.
|
||||
%patch2 -p1 -b .workaround
|
||||
%patch3 -p1 -b .firefox-print-preview
|
||||
%patch4 -p1 -b .system-log-crash
|
||||
%patch5 -p1 -b .builder-turkish
|
||||
|
||||
for i in config.guess config.sub ; do
|
||||
test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
|
||||
@ -297,6 +301,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/gtk-2.0
|
||||
|
||||
%changelog
|
||||
* Thu Oct 25 2007 Matthias Clasen <mclasen@redhat.com> - 2.12.1-5
|
||||
- Fix a bug that prevents GtkBuilder-using apps (like totem)
|
||||
to run in some locales (like Turkish) (#348631)
|
||||
|
||||
* Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 2.12.1-4
|
||||
- Fix a crash in gnome-system-log (#321701)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user