Fix build
This commit is contained in:
parent
40666df40b
commit
3fdd01d87b
24
gtk2-fix-install.patch
Normal file
24
gtk2-fix-install.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up gtk+-2.17.11/po/Makefile.in.in.fix-install gtk+-2.17.11/po/Makefile.in.in
|
||||||
|
--- gtk+-2.17.11/po/Makefile.in.in.fix-install 2009-09-05 01:19:45.303824009 -0400
|
||||||
|
+++ gtk+-2.17.11/po/Makefile.in.in 2009-09-05 01:19:14.632573806 -0400
|
||||||
|
@@ -126,7 +126,7 @@ install-data: install-data-@USE_NLS@
|
||||||
|
install-data-no: all
|
||||||
|
install-data-yes: all
|
||||||
|
$(mkdir_p) $(DESTDIR)$(datadir); \
|
||||||
|
- @catalogs='$(CATALOGS)'; \
|
||||||
|
+ catalogs='$(CATALOGS)'; \
|
||||||
|
for cat in $$catalogs; do \
|
||||||
|
cat=`basename $$cat`; \
|
||||||
|
case "$$cat" in \
|
||||||
|
diff -up gtk+-2.17.11/po-properties/Makefile.in.in.fix-install gtk+-2.17.11/po-properties/Makefile.in.in
|
||||||
|
--- gtk+-2.17.11/po-properties/Makefile.in.in.fix-install 2009-09-05 01:19:54.543583934 -0400
|
||||||
|
+++ gtk+-2.17.11/po-properties/Makefile.in.in 2009-09-05 01:20:16.427830666 -0400
|
||||||
|
@@ -107,7 +107,7 @@ install-data: install-data-@USE_NLS@
|
||||||
|
install-data-no: all
|
||||||
|
install-data-yes: all
|
||||||
|
$(mkdir_p) $(DESTDIR)$(datadir); \
|
||||||
|
- @catalogs='$(CATALOGS)'; \
|
||||||
|
+ catalogs='$(CATALOGS)'; \
|
||||||
|
for cat in $$catalogs; do \
|
||||||
|
cat=`basename $$cat`; \
|
||||||
|
case "$$cat" in \
|
@ -28,6 +28,8 @@ Source3: im-cedilla.conf
|
|||||||
# Biarch changes
|
# Biarch changes
|
||||||
Patch0: gtk+-2.13.5-lib64.patch
|
Patch0: gtk+-2.13.5-lib64.patch
|
||||||
|
|
||||||
|
Patch1: gtk2-fix-install.patch
|
||||||
|
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: pango-devel >= %{pango_version}
|
BuildRequires: pango-devel >= %{pango_version}
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
@ -138,6 +140,7 @@ This package contains developer documentation for the GTK+ widget toolkit.
|
|||||||
%setup -q -n gtk+-%{version}
|
%setup -q -n gtk+-%{version}
|
||||||
|
|
||||||
%patch0 -p1 -b .lib64
|
%patch0 -p1 -b .lib64
|
||||||
|
%patch1 -p1 -b .fix-install
|
||||||
|
|
||||||
# make sure that gtkmarshalers.{c, h} get regenerated during the build
|
# make sure that gtkmarshalers.{c, h} get regenerated during the build
|
||||||
# - caused by print_authentication.patch
|
# - caused by print_authentication.patch
|
||||||
@ -215,17 +218,17 @@ make install DESTDIR=$RPM_BUILD_ROOT \
|
|||||||
%find_lang gtk20
|
%find_lang gtk20
|
||||||
%find_lang gtk20-properties
|
%find_lang gtk20-properties
|
||||||
|
|
||||||
./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0
|
||||||
#
|
#
|
||||||
# Make cleaned-up versions of tutorials, examples, and faq for installation
|
# Make cleaned-up versions of tutorials, examples, and faq for installation
|
||||||
#
|
#
|
||||||
./mkinstalldirs tmpdocs
|
mkdir -p tmpdocs
|
||||||
cp -aR docs/tutorial/html tmpdocs/tutorial
|
cp -aR docs/tutorial/html tmpdocs/tutorial
|
||||||
cp -aR docs/faq/html tmpdocs/faq
|
cp -aR docs/faq/html tmpdocs/faq
|
||||||
|
|
||||||
for dir in examples/* ; do
|
for dir in examples/* ; do
|
||||||
if [ -d $dir ] ; then
|
if [ -d $dir ] ; then
|
||||||
./mkinstalldirs tmpdocs/$dir
|
mkdir -p tmpdocs/$dir
|
||||||
for file in $dir/* ; do
|
for file in $dir/* ; do
|
||||||
install -m 0644 $file tmpdocs/$dir
|
install -m 0644 $file tmpdocs/$dir
|
||||||
done
|
done
|
||||||
|
Loading…
Reference in New Issue
Block a user