assorted gio fixes
This commit is contained in:
parent
e025cfad8d
commit
1ea2edf9c6
12
filechooser-auth.patch
Normal file
12
filechooser-auth.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up gtk+-2.12.9/gtk/gtkfilechooserdefault.c.filechooser-auth gtk+-2.12.9/gtk/gtkfilechooserdefault.c
|
||||||
|
--- gtk+-2.12.9/gtk/gtkfilechooserdefault.c.filechooser-auth 2008-04-09 13:39:03.000000000 -0400
|
||||||
|
+++ gtk+-2.12.9/gtk/gtkfilechooserdefault.c 2008-04-09 13:39:06.000000000 -0400
|
||||||
|
@@ -10377,7 +10377,7 @@ shortcuts_activate_get_info_cb (GtkFileS
|
||||||
|
|
||||||
|
data->impl->shortcuts_activate_iter_handle = NULL;
|
||||||
|
|
||||||
|
- if (cancelled)
|
||||||
|
+ if (cancelled || g_error_matches (error, G_FILE_ERROR, G_FILE_ERROR_INTR))
|
||||||
|
goto out;
|
||||||
|
|
||||||
|
if (!error && gtk_file_info_get_is_folder (info))
|
21
filechooser-iconsize.patch
Normal file
21
filechooser-iconsize.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up gtk+-2.12.9/gtk/gtkfilesystem.c.iconsize gtk+-2.12.9/gtk/gtkfilesystem.c
|
||||||
|
--- gtk+-2.12.9/gtk/gtkfilesystem.c.iconsize 2008-04-09 12:32:53.000000000 -0400
|
||||||
|
+++ gtk+-2.12.9/gtk/gtkfilesystem.c 2008-04-09 12:34:15.000000000 -0400
|
||||||
|
@@ -306,7 +306,7 @@ gtk_file_info_render_icon (const GtkFile
|
||||||
|
pixbuf = gtk_widget_render_icon (widget,
|
||||||
|
gtk_file_info_get_is_folder (info)
|
||||||
|
? GTK_STOCK_DIRECTORY : GTK_STOCK_FILE,
|
||||||
|
- GTK_ICON_SIZE_SMALL_TOOLBAR,
|
||||||
|
+ GTK_ICON_SIZE_MENU,
|
||||||
|
NULL);
|
||||||
|
if (!pixbuf && error)
|
||||||
|
g_set_error (error,
|
||||||
|
@@ -670,7 +670,7 @@ gtk_file_system_volume_render_icon (GtkF
|
||||||
|
if (!pixbuf)
|
||||||
|
pixbuf = gtk_widget_render_icon (widget,
|
||||||
|
GTK_STOCK_HARDDISK,
|
||||||
|
- GTK_ICON_SIZE_SMALL_TOOLBAR,
|
||||||
|
+ GTK_ICON_SIZE_MENU,
|
||||||
|
NULL);
|
||||||
|
|
||||||
|
return pixbuf;
|
14
gtk2.spec
14
gtk2.spec
@ -16,7 +16,7 @@
|
|||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
Name: gtk2
|
Name: gtk2
|
||||||
Version: %{base_version}
|
Version: %{base_version}
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.gnome.org/sources/gtk+/2.12/gtk+-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/gtk+/2.12/gtk+-%{version}.tar.bz2
|
||||||
@ -43,6 +43,11 @@ Patch5: foreign-cmap.patch
|
|||||||
# fixed upstream
|
# fixed upstream
|
||||||
Patch6: implicit-g_fopen.patch
|
Patch6: implicit-g_fopen.patch
|
||||||
|
|
||||||
|
# fixed upstream
|
||||||
|
Patch7: filechooser-iconsize.patch
|
||||||
|
# http://bugzilla.gnome.org/show_bug.cgi?id=521032
|
||||||
|
Patch8: filechooser-auth.patch
|
||||||
|
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: pango-devel >= %{pango_version}
|
BuildRequires: pango-devel >= %{pango_version}
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
@ -124,6 +129,8 @@ docs for the GTK+ widget toolkit.
|
|||||||
%patch4 -p1 -b .im-setting
|
%patch4 -p1 -b .im-setting
|
||||||
%patch5 -p1 -b .foreign-cmap
|
%patch5 -p1 -b .foreign-cmap
|
||||||
%patch6 -p1 -b .implicit-g_fopen
|
%patch6 -p1 -b .implicit-g_fopen
|
||||||
|
%patch7 -p1 -b .filechooser-iconsize
|
||||||
|
%patch8 -p1 -b .filechooser-auth
|
||||||
|
|
||||||
for i in config.guess config.sub ; do
|
for i in config.guess config.sub ; do
|
||||||
test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
|
test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
|
||||||
@ -306,6 +313,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/gtk-2.0
|
%{_datadir}/gtk-2.0
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.12.9-4
|
||||||
|
- Make sure we use the right icon size for all icons in the
|
||||||
|
file chooser (Fix by Tomas Bzatek)
|
||||||
|
- Improve the handling of auth dialogs in the file chooser (Tomas Bzatek)
|
||||||
|
|
||||||
* Mon Apr 7 2008 Marek Kasik <mkasik@redhat.com> - 2.12.9-3
|
* Mon Apr 7 2008 Marek Kasik <mkasik@redhat.com> - 2.12.9-3
|
||||||
- Correction of "implicit declaration of function 'g_fopen'"
|
- Correction of "implicit declaration of function 'g_fopen'"
|
||||||
warning
|
warning
|
||||||
|
Loading…
Reference in New Issue
Block a user