2.19.1
This commit is contained in:
parent
e39823b92a
commit
0e97796564
@ -1 +1 @@
|
|||||||
gtk+-2.18.0.tar.bz2
|
gtk+-2.19.1.tar.bz2
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up gtk+-2.18.3/gtk/gtktooltip.c.fresh-tooltips gtk+-2.18.3/gtk/gtktooltip.c
|
diff -up gtk+-2.19.1/gtk/gtktooltip.c.fresh-tooltips gtk+-2.19.1/gtk/gtktooltip.c
|
||||||
--- gtk+-2.18.3/gtk/gtktooltip.c.fresh-tooltips 2009-10-16 10:35:45.000000000 -0400
|
--- gtk+-2.19.1/gtk/gtktooltip.c.fresh-tooltips 2009-11-26 23:54:55.000000000 -0500
|
||||||
+++ gtk+-2.18.3/gtk/gtktooltip.c 2009-10-31 14:53:37.120183113 -0400
|
+++ gtk+-2.19.1/gtk/gtktooltip.c 2009-11-30 20:06:37.539580221 -0500
|
||||||
@@ -29,6 +29,10 @@
|
@@ -29,6 +29,10 @@
|
||||||
#include "gtkhbox.h"
|
#include "gtkhbox.h"
|
||||||
#include "gtkalignment.h"
|
#include "gtkalignment.h"
|
||||||
@ -100,33 +100,7 @@ diff -up gtk+-2.18.3/gtk/gtktooltip.c.fresh-tooltips gtk+-2.18.3/gtk/gtktooltip.
|
|||||||
tooltip->custom_widget = NULL;
|
tooltip->custom_widget = NULL;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -318,9 +369,9 @@ gtk_tooltip_set_icon_from_stock (GtkTool
|
@@ -508,19 +559,208 @@ gtk_tooltip_window_style_set (GtkTooltip
|
||||||
* Since: 2.14
|
|
||||||
*/
|
|
||||||
void
|
|
||||||
-gtk_tooltip_set_icon_from_icon_name(GtkTooltip *tooltip,
|
|
||||||
- const gchar *icon_name,
|
|
||||||
- GtkIconSize size)
|
|
||||||
+gtk_tooltip_set_icon_from_icon_name (GtkTooltip *tooltip,
|
|
||||||
+ const gchar *icon_name,
|
|
||||||
+ GtkIconSize size)
|
|
||||||
{
|
|
||||||
g_return_if_fail (GTK_IS_TOOLTIP (tooltip));
|
|
||||||
|
|
||||||
@@ -471,27 +522,217 @@ static void
|
|
||||||
gtk_tooltip_window_style_set (GtkTooltip *tooltip)
|
|
||||||
{
|
|
||||||
gtk_alignment_set_padding (GTK_ALIGNMENT (tooltip->alignment),
|
|
||||||
- tooltip->window->style->ythickness,
|
|
||||||
- tooltip->window->style->ythickness,
|
|
||||||
- tooltip->window->style->xthickness,
|
|
||||||
+ tooltip->window->style->ythickness,
|
|
||||||
+ tooltip->window->style->ythickness,
|
|
||||||
+ tooltip->window->style->xthickness,
|
|
||||||
tooltip->window->style->xthickness);
|
|
||||||
-
|
|
||||||
+ gtk_box_set_spacing (GTK_BOX (tooltip->box),
|
|
||||||
+ tooltip->window->style->xthickness);
|
|
||||||
gtk_widget_queue_draw (tooltip->window);
|
gtk_widget_queue_draw (tooltip->window);
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -259,7 +233,7 @@ diff -up gtk+-2.18.3/gtk/gtktooltip.c.fresh-tooltips gtk+-2.18.3/gtk/gtktooltip.
|
|||||||
+ wm = gdk_x11_screen_get_window_manager_name (screen);
|
+ wm = gdk_x11_screen_get_window_manager_name (screen);
|
||||||
+ if (g_strcmp0 (wm, "Metacity") == 0)
|
+ if (g_strcmp0 (wm, "Metacity") == 0)
|
||||||
+ gtk_window_set_type_hint (GTK_WINDOW (tooltip->window),
|
+ gtk_window_set_type_hint (GTK_WINDOW (tooltip->window),
|
||||||
+ GDK_WINDOW_TYPE_HINT_DND);
|
+ GDK_WINDOW_TYPE_HINT_DND);
|
||||||
+ }
|
+ }
|
||||||
+#endif
|
+#endif
|
||||||
+ return;
|
+ return;
|
||||||
@ -345,7 +319,7 @@ diff -up gtk+-2.18.3/gtk/gtktooltip.c.fresh-tooltips gtk+-2.18.3/gtk/gtktooltip.
|
|||||||
|
|
||||||
return FALSE;
|
return FALSE;
|
||||||
}
|
}
|
||||||
@@ -631,7 +872,7 @@ find_widget_under_pointer (GdkWindow *wi
|
@@ -660,7 +900,7 @@ find_widget_under_pointer (GdkWindow *wi
|
||||||
|
|
||||||
#ifdef DEBUG_TOOLTIP
|
#ifdef DEBUG_TOOLTIP
|
||||||
g_print ("event window %p (belonging to %p (%s)) (%d, %d)\n",
|
g_print ("event window %p (belonging to %p (%s)) (%d, %d)\n",
|
||||||
@ -354,10 +328,10 @@ diff -up gtk+-2.18.3/gtk/gtktooltip.c.fresh-tooltips gtk+-2.18.3/gtk/gtktooltip.
|
|||||||
*x, *y);
|
*x, *y);
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
diff -up gtk+-2.18.3/gtk/gtkwidget.c.fresh-tooltips gtk+-2.18.3/gtk/gtkwidget.c
|
diff -up gtk+-2.19.1/gtk/gtkwidget.c.fresh-tooltips gtk+-2.19.1/gtk/gtkwidget.c
|
||||||
--- gtk+-2.18.3/gtk/gtkwidget.c.fresh-tooltips 2009-10-09 01:00:44.000000000 -0400
|
--- gtk+-2.19.1/gtk/gtkwidget.c.fresh-tooltips 2009-11-27 20:59:42.000000000 -0500
|
||||||
+++ gtk+-2.18.3/gtk/gtkwidget.c 2009-10-31 14:27:50.333957199 -0400
|
+++ gtk+-2.19.1/gtk/gtkwidget.c 2009-11-30 20:00:23.425825787 -0500
|
||||||
@@ -2386,6 +2386,14 @@ gtk_widget_class_init (GtkWidgetClass *k
|
@@ -2557,6 +2557,14 @@ gtk_widget_class_init (GtkWidgetClass *k
|
||||||
P_("The length of vertical scroll arrows"),
|
P_("The length of vertical scroll arrows"),
|
||||||
1, G_MAXINT, 16,
|
1, G_MAXINT, 16,
|
||||||
GTK_PARAM_READABLE));
|
GTK_PARAM_READABLE));
|
||||||
|
29
gtk2.spec
29
gtk2.spec
@ -11,13 +11,13 @@
|
|||||||
%define libpng_version 2:1.2.2-16
|
%define libpng_version 2:1.2.2-16
|
||||||
%define xrandr_version 1.2.99.4-2
|
%define xrandr_version 1.2.99.4-2
|
||||||
|
|
||||||
%define base_version 2.18.3
|
%define base_version 2.19.1
|
||||||
%define bin_version 2.10.0
|
%define bin_version 2.10.0
|
||||||
|
|
||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
Name: gtk2
|
Name: gtk2
|
||||||
Version: %{base_version}
|
Version: %{base_version}
|
||||||
Release: 22%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.gnome.org/sources/gtk+/2.18/gtk+-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/gtk+/2.18/gtk+-%{version}.tar.bz2
|
||||||
@ -30,32 +30,16 @@ Patch0: gtk+-2.13.5-lib64.patch
|
|||||||
Patch1: system-python.patch
|
Patch1: system-python.patch
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=583273
|
# https://bugzilla.gnome.org/show_bug.cgi?id=583273
|
||||||
Patch2: icon-padding.patch
|
Patch2: icon-padding.patch
|
||||||
# from upstream
|
|
||||||
Patch3: image-size-alloc.patch
|
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=599617
|
# https://bugzilla.gnome.org/show_bug.cgi?id=599617
|
||||||
Patch4: fresh-tooltips.patch
|
Patch4: fresh-tooltips.patch
|
||||||
# from upstream
|
|
||||||
Patch5: allow-set-hint.patch
|
|
||||||
# from upstream
|
|
||||||
Patch6: compose-sequences.patch
|
|
||||||
# from upstream
|
|
||||||
Patch7: symbolic-color-parsing.patch
|
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=599618
|
# https://bugzilla.gnome.org/show_bug.cgi?id=599618
|
||||||
Patch8: tooltip-positioning.patch
|
Patch8: tooltip-positioning.patch
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=581150
|
|
||||||
Patch9: iconview-hang.patch
|
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=599446
|
|
||||||
Patch10: toolbutton-assert.patch
|
|
||||||
# http://bugzilla.redhat.com/show_bug.cgi?id=529364
|
# http://bugzilla.redhat.com/show_bug.cgi?id=529364
|
||||||
Patch11: gtk2-remove-connecting-reason.patch
|
Patch11: gtk2-remove-connecting-reason.patch
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=592582
|
# https://bugzilla.gnome.org/show_bug.cgi?id=592582
|
||||||
Patch12: gtk2-preview.patch
|
|
||||||
Patch13: gtk2-rotate-layout.patch
|
|
||||||
Patch14: gtk2-landscape-pdf-print.patch
|
Patch14: gtk2-landscape-pdf-print.patch
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=600992
|
# https://bugzilla.gnome.org/show_bug.cgi?id=600992
|
||||||
Patch15: filesystemref.patch
|
Patch15: filesystemref.patch
|
||||||
# fixed upstream
|
|
||||||
Patch16: 0001-Make-level3-keys-work-again.patch
|
|
||||||
|
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: pango-devel >= %{pango_version}
|
BuildRequires: pango-devel >= %{pango_version}
|
||||||
@ -169,20 +153,11 @@ This package contains developer documentation for the GTK+ widget toolkit.
|
|||||||
%patch0 -p1 -b .lib64
|
%patch0 -p1 -b .lib64
|
||||||
%patch1 -p1 -b .system-python
|
%patch1 -p1 -b .system-python
|
||||||
%patch2 -p1 -b .icon-padding
|
%patch2 -p1 -b .icon-padding
|
||||||
%patch3 -p1 -b .image-size-alloc
|
|
||||||
%patch4 -p1 -b .fresh-tooltips
|
%patch4 -p1 -b .fresh-tooltips
|
||||||
%patch5 -p1 -b .allow-set-hint
|
|
||||||
%patch6 -p1 -b .compose-sequences
|
|
||||||
%patch7 -p1 -b .symbolic-color-parsing
|
|
||||||
%patch8 -p1 -b .tooltip-positioning
|
%patch8 -p1 -b .tooltip-positioning
|
||||||
%patch9 -p1 -b .iconview-hang
|
|
||||||
%patch10 -p1 -b .toolbutton-assert
|
|
||||||
%patch11 -p1 -b .remove-connecting-reason
|
%patch11 -p1 -b .remove-connecting-reason
|
||||||
%patch12 -p1 -b .preview
|
|
||||||
%patch13 -p1 -b .rotate-layout
|
|
||||||
%patch14 -p1 -b .landscape-pdf-print
|
%patch14 -p1 -b .landscape-pdf-print
|
||||||
%patch15 -p1 -b .filesystemref
|
%patch15 -p1 -b .filesystemref
|
||||||
%patch16 -p1 -b .level3
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
libtoolize --force --copy
|
libtoolize --force --copy
|
||||||
|
Loading…
Reference in New Issue
Block a user