import gtk2-2.24.32-4.el8
This commit is contained in:
commit
0bf00e175f
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/gtk+-2.24.32.tar.xz
|
1
.gtk2.metadata
Normal file
1
.gtk2.metadata
Normal file
@ -0,0 +1 @@
|
||||
c885ade62b06854590822c8eb906daf7dd15d90a SOURCES/gtk+-2.24.32.tar.xz
|
258
SOURCES/icon-padding.patch
Normal file
258
SOURCES/icon-padding.patch
Normal file
@ -0,0 +1,258 @@
|
||||
diff -up gtk+-2.19.7/gtk/gtkstatusicon.c.icon-padding gtk+-2.19.7/gtk/gtkstatusicon.c
|
||||
--- gtk+-2.19.7/gtk/gtkstatusicon.c.icon-padding 2010-03-08 08:42:22.000000000 -0500
|
||||
+++ gtk+-2.19.7/gtk/gtkstatusicon.c 2010-03-10 00:40:11.165527903 -0500
|
||||
@@ -170,6 +170,7 @@ static void gtk_status_icon_screen_c
|
||||
GdkScreen *old_screen);
|
||||
static void gtk_status_icon_embedded_changed (GtkStatusIcon *status_icon);
|
||||
static void gtk_status_icon_orientation_changed (GtkStatusIcon *status_icon);
|
||||
+static void gtk_status_icon_padding_changed (GtkStatusIcon *status_icon);
|
||||
static gboolean gtk_status_icon_scroll (GtkStatusIcon *status_icon,
|
||||
GdkEventScroll *event);
|
||||
static gboolean gtk_status_icon_query_tooltip (GtkStatusIcon *status_icon,
|
||||
@@ -850,6 +851,8 @@ gtk_status_icon_init (GtkStatusIcon *sta
|
||||
G_CALLBACK (gtk_status_icon_embedded_changed), status_icon);
|
||||
g_signal_connect_swapped (priv->tray_icon, "notify::orientation",
|
||||
G_CALLBACK (gtk_status_icon_orientation_changed), status_icon);
|
||||
+ g_signal_connect_swapped (priv->tray_icon, "notify::padding",
|
||||
+ G_CALLBACK (gtk_status_icon_padding_changed), status_icon);
|
||||
g_signal_connect_swapped (priv->tray_icon, "button-press-event",
|
||||
G_CALLBACK (gtk_status_icon_button_press), status_icon);
|
||||
g_signal_connect_swapped (priv->tray_icon, "button-release-event",
|
||||
@@ -975,6 +978,8 @@ gtk_status_icon_finalize (GObject *objec
|
||||
g_signal_handlers_disconnect_by_func (priv->tray_icon,
|
||||
gtk_status_icon_orientation_changed, status_icon);
|
||||
g_signal_handlers_disconnect_by_func (priv->tray_icon,
|
||||
+ gtk_status_icon_padding_changed, status_icon);
|
||||
+ g_signal_handlers_disconnect_by_func (priv->tray_icon,
|
||||
gtk_status_icon_button_press, status_icon);
|
||||
g_signal_handlers_disconnect_by_func (priv->tray_icon,
|
||||
gtk_status_icon_button_release, status_icon);
|
||||
@@ -1679,14 +1684,32 @@ gtk_status_icon_screen_changed (GtkStatu
|
||||
#ifdef GDK_WINDOWING_X11
|
||||
|
||||
static void
|
||||
+gtk_status_icon_padding_changed (GtkStatusIcon *status_icon)
|
||||
+{
|
||||
+ GtkStatusIconPrivate *priv = status_icon->priv;
|
||||
+ GtkOrientation orientation;
|
||||
+ gint padding;
|
||||
+
|
||||
+ orientation = _gtk_tray_icon_get_orientation (GTK_TRAY_ICON (priv->tray_icon));
|
||||
+ padding = _gtk_tray_icon_get_padding (GTK_TRAY_ICON (priv->tray_icon));
|
||||
+
|
||||
+ if (orientation == GTK_ORIENTATION_HORIZONTAL)
|
||||
+ gtk_misc_set_padding (GTK_MISC (priv->image), padding, 0);
|
||||
+ else
|
||||
+ gtk_misc_set_padding (GTK_MISC (priv->image), 0, padding);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
gtk_status_icon_embedded_changed (GtkStatusIcon *status_icon)
|
||||
{
|
||||
+ gtk_status_icon_padding_changed (status_icon);
|
||||
g_object_notify (G_OBJECT (status_icon), "embedded");
|
||||
}
|
||||
|
||||
static void
|
||||
gtk_status_icon_orientation_changed (GtkStatusIcon *status_icon)
|
||||
{
|
||||
+ gtk_status_icon_padding_changed (status_icon);
|
||||
g_object_notify (G_OBJECT (status_icon), "orientation");
|
||||
}
|
||||
|
||||
@@ -1804,7 +1827,7 @@ gtk_status_icon_reset_image_data (GtkSta
|
||||
|
||||
g_object_notify (G_OBJECT (status_icon), "stock");
|
||||
break;
|
||||
-
|
||||
+
|
||||
case GTK_IMAGE_ICON_NAME:
|
||||
g_free (priv->image_data.icon_name);
|
||||
priv->image_data.icon_name = NULL;
|
||||
diff -up gtk+-2.19.7/gtk/gtktrayicon.h.icon-padding gtk+-2.19.7/gtk/gtktrayicon.h
|
||||
--- gtk+-2.19.7/gtk/gtktrayicon.h.icon-padding 2009-10-18 01:35:45.000000000 -0400
|
||||
+++ gtk+-2.19.7/gtk/gtktrayicon.h 2010-03-10 00:40:11.169528392 -0500
|
||||
@@ -69,7 +69,8 @@ void _gtk_tray_icon_cancel_mes
|
||||
guint id);
|
||||
|
||||
GtkOrientation _gtk_tray_icon_get_orientation (GtkTrayIcon *icon);
|
||||
-
|
||||
+gint _gtk_tray_icon_get_padding (GtkTrayIcon *icon);
|
||||
+
|
||||
G_END_DECLS
|
||||
|
||||
#endif /* __GTK_TRAY_ICON_H__ */
|
||||
diff -up gtk+-2.19.7/gtk/gtktrayicon-x11.c.icon-padding gtk+-2.19.7/gtk/gtktrayicon-x11.c
|
||||
--- gtk+-2.19.7/gtk/gtktrayicon-x11.c.icon-padding 2010-03-08 21:01:28.000000000 -0500
|
||||
+++ gtk+-2.19.7/gtk/gtktrayicon-x11.c 2010-03-10 00:49:48.229509604 -0500
|
||||
@@ -43,23 +43,26 @@
|
||||
|
||||
enum {
|
||||
PROP_0,
|
||||
- PROP_ORIENTATION
|
||||
+ PROP_ORIENTATION,
|
||||
+ PROP_PADDING
|
||||
};
|
||||
|
||||
struct _GtkTrayIconPrivate
|
||||
{
|
||||
guint stamp;
|
||||
-
|
||||
+
|
||||
Atom selection_atom;
|
||||
Atom manager_atom;
|
||||
Atom system_tray_opcode_atom;
|
||||
Atom orientation_atom;
|
||||
Atom visual_atom;
|
||||
+ Atom padding_atom;
|
||||
Window manager_window;
|
||||
GdkVisual *manager_visual;
|
||||
gboolean manager_visual_rgba;
|
||||
|
||||
GtkOrientation orientation;
|
||||
+ gint padding;
|
||||
};
|
||||
|
||||
static void gtk_tray_icon_constructed (GObject *object);
|
||||
@@ -113,6 +116,16 @@ gtk_tray_icon_class_init (GtkTrayIconCla
|
||||
GTK_ORIENTATION_HORIZONTAL,
|
||||
GTK_PARAM_READABLE));
|
||||
|
||||
+ g_object_class_install_property (gobject_class,
|
||||
+ PROP_PADDING,
|
||||
+ g_param_spec_int ("padding",
|
||||
+ P_("Padding"),
|
||||
+ P_("Padding that should be put around icons in the tray"),
|
||||
+ 0,
|
||||
+ G_MAXINT,
|
||||
+ 0,
|
||||
+ GTK_PARAM_READABLE));
|
||||
+
|
||||
g_type_class_add_private (class, sizeof (GtkTrayIconPrivate));
|
||||
}
|
||||
|
||||
@@ -124,6 +137,7 @@ gtk_tray_icon_init (GtkTrayIcon *icon)
|
||||
|
||||
icon->priv->stamp = 1;
|
||||
icon->priv->orientation = GTK_ORIENTATION_HORIZONTAL;
|
||||
+ icon->priv->padding = 0;
|
||||
|
||||
gtk_widget_set_app_paintable (GTK_WIDGET (icon), TRUE);
|
||||
gtk_widget_add_events (GTK_WIDGET (icon), GDK_PROPERTY_CHANGE_MASK);
|
||||
@@ -161,6 +175,10 @@ gtk_tray_icon_constructed (GObject *obje
|
||||
"_NET_SYSTEM_TRAY_VISUAL",
|
||||
False);
|
||||
|
||||
+ icon->priv->padding_atom = XInternAtom (xdisplay,
|
||||
+ "_NET_SYSTEM_TRAY_PADDING",
|
||||
+ False);
|
||||
+
|
||||
/* Add a root window filter so that we get changes on MANAGER */
|
||||
gdk_window_add_filter (root_window,
|
||||
gtk_tray_icon_manager_filter, icon);
|
||||
@@ -212,6 +230,9 @@ gtk_tray_icon_get_property (GObject *
|
||||
case PROP_ORIENTATION:
|
||||
g_value_set_enum (value, icon->priv->orientation);
|
||||
break;
|
||||
+ case PROP_PADDING:
|
||||
+ g_value_set_int (value, icon->priv->padding);
|
||||
+ break;
|
||||
default:
|
||||
G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
|
||||
break;
|
||||
@@ -372,9 +393,58 @@ gtk_tray_icon_get_visual_property (GtkTr
|
||||
XFree (prop.prop);
|
||||
}
|
||||
|
||||
+static void
|
||||
+gtk_tray_icon_get_padding_property (GtkTrayIcon *icon)
|
||||
+{
|
||||
+ GdkScreen *screen = gtk_widget_get_screen (GTK_WIDGET (icon));
|
||||
+ GdkDisplay *display = gdk_screen_get_display (screen);
|
||||
+ Display *xdisplay = GDK_DISPLAY_XDISPLAY (display);
|
||||
+
|
||||
+ Atom type;
|
||||
+ int format;
|
||||
+ union {
|
||||
+ gulong *prop;
|
||||
+ guchar *prop_ch;
|
||||
+ } prop = { NULL };
|
||||
+ gulong nitems;
|
||||
+ gulong bytes_after;
|
||||
+ int error, result;
|
||||
+
|
||||
+ g_assert (icon->priv->manager_window != None);
|
||||
+
|
||||
+ gdk_error_trap_push ();
|
||||
+ type = None;
|
||||
+ result = XGetWindowProperty (xdisplay,
|
||||
+ icon->priv->manager_window,
|
||||
+ icon->priv->padding_atom,
|
||||
+ 0, G_MAXLONG, FALSE,
|
||||
+ XA_CARDINAL,
|
||||
+ &type, &format, &nitems,
|
||||
+ &bytes_after, &(prop.prop_ch));
|
||||
+ error = gdk_error_trap_pop ();
|
||||
+
|
||||
+ if (!error && result == Success &&
|
||||
+ type == XA_CARDINAL && nitems == 1 && format == 32)
|
||||
+ {
|
||||
+ gint padding;
|
||||
+
|
||||
+ padding = prop.prop[0];
|
||||
+
|
||||
+ if (icon->priv->padding != padding)
|
||||
+ {
|
||||
+ icon->priv->padding = padding;
|
||||
+
|
||||
+ g_object_notify (G_OBJECT (icon), "padding");
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ if (type != None)
|
||||
+ XFree (prop.prop);
|
||||
+}
|
||||
+
|
||||
static GdkFilterReturn
|
||||
-gtk_tray_icon_manager_filter (GdkXEvent *xevent,
|
||||
- GdkEvent *event,
|
||||
+gtk_tray_icon_manager_filter (GdkXEvent *xevent,
|
||||
+ GdkEvent *event,
|
||||
gpointer user_data)
|
||||
{
|
||||
GtkTrayIcon *icon = user_data;
|
||||
@@ -399,6 +469,11 @@ gtk_tray_icon_manager_filter (GdkXEvent
|
||||
|
||||
gtk_tray_icon_get_orientation_property (icon);
|
||||
}
|
||||
+ else if (xev->xany.type == PropertyNotify &&
|
||||
+ xev->xproperty.atom == icon->priv->padding_atom)
|
||||
+ {
|
||||
+ gtk_tray_icon_get_padding_property (icon);
|
||||
+ }
|
||||
else if (xev->xany.type == DestroyNotify)
|
||||
{
|
||||
GTK_NOTE (PLUGSOCKET,
|
||||
@@ -504,6 +579,7 @@ gtk_tray_icon_update_manager_window (Gtk
|
||||
|
||||
gtk_tray_icon_get_orientation_property (icon);
|
||||
gtk_tray_icon_get_visual_property (icon);
|
||||
+ gtk_tray_icon_get_padding_property (icon);
|
||||
|
||||
if (gtk_widget_get_realized (GTK_WIDGET (icon)))
|
||||
{
|
||||
@@ -740,6 +816,14 @@ _gtk_tray_icon_get_orientation (GtkTrayI
|
||||
return icon->priv->orientation;
|
||||
}
|
||||
|
||||
+gint
|
||||
+_gtk_tray_icon_get_padding (GtkTrayIcon *icon)
|
||||
+{
|
||||
+ g_return_val_if_fail (GTK_IS_TRAY_ICON (icon), 0);
|
||||
+
|
||||
+ return icon->priv->padding;
|
||||
+}
|
||||
+
|
||||
|
||||
#define __GTK_TRAY_ICON_X11_C__
|
||||
#include "gtkaliasdef.c"
|
6
SOURCES/im-cedilla.conf
Normal file
6
SOURCES/im-cedilla.conf
Normal file
@ -0,0 +1,6 @@
|
||||
XIM=none
|
||||
XIM_PROGRAM=/bin/true
|
||||
XIM_ARGS=
|
||||
SHORT_DESC=im-cedilla
|
||||
GTK_IM_MODULE=cedilla
|
||||
QT_IM_MODULE=xim
|
122
SOURCES/python3-compat.patch
Normal file
122
SOURCES/python3-compat.patch
Normal file
@ -0,0 +1,122 @@
|
||||
Add compatibility with Python 3 (keeping compatibility with Python 2.7)
|
||||
|
||||
--- gtk+-2.24.32/gtk/gtk-builder-convert (original)
|
||||
+++ gtk+-2.24.32/gtk/gtk-builder-convert (refactored)
|
||||
@@ -36,10 +36,11 @@
|
||||
|
||||
Report bugs to http://bugzilla.gnome.org/."""
|
||||
|
||||
+from __future__ import print_function
|
||||
import getopt
|
||||
import os
|
||||
import sys
|
||||
-
|
||||
+import subprocess
|
||||
from xml.dom import minidom, Node
|
||||
|
||||
DIALOGS = ['GtkDialog',
|
||||
@@ -47,13 +48,6 @@
|
||||
'GtkMessageDialog']
|
||||
WINDOWS = ['GtkWindow'] + DIALOGS
|
||||
|
||||
-# The subprocess is only available in Python 2.4+
|
||||
-try:
|
||||
- import subprocess
|
||||
- subprocess # pyflakes
|
||||
-except ImportError:
|
||||
- subprocess = None
|
||||
-
|
||||
def get_child_nodes(node):
|
||||
assert node.tagName == 'object'
|
||||
nodes = []
|
||||
@@ -167,7 +161,11 @@
|
||||
|
||||
def to_xml(self):
|
||||
xml = self._dom.toprettyxml("", "")
|
||||
- return xml.encode('utf-8')
|
||||
+ if sys.version_info < (3, 0):
|
||||
+ # Python 2: convert with explicit encoding
|
||||
+ # (For Python 3, the result is left as text)
|
||||
+ xml = xml.encode('utf-8')
|
||||
+ return xml
|
||||
|
||||
#
|
||||
# Private
|
||||
@@ -259,7 +257,7 @@
|
||||
for node in objects:
|
||||
self._convert(node.getAttribute("class"), node)
|
||||
if self._get_object(node.getAttribute('id')) is not None:
|
||||
- print "WARNING: duplicate id \"" + node.getAttribute('id') + "\""
|
||||
+ print("WARNING: duplicate id \"" + node.getAttribute('id') + "\"")
|
||||
self.objects[node.getAttribute('id')] = node
|
||||
|
||||
# Convert Gazpachos UI tag
|
||||
@@ -272,13 +270,9 @@
|
||||
|
||||
# Output the newly created root objects and sort them
|
||||
# by attribute id
|
||||
- # FIXME: Use sorted(self.root_objects,
|
||||
- # key=lambda n: n.getAttribute('id'),
|
||||
- # reverse=True):
|
||||
- # when we can depend on python 2.4 or higher
|
||||
- root_objects = self.root_objects[:]
|
||||
- root_objects.sort(lambda a, b: cmp(b.getAttribute('id'),
|
||||
- a.getAttribute('id')))
|
||||
+ root_objects = sorted(self.root_objects,
|
||||
+ key=lambda n: n.getAttribute('id'),
|
||||
+ reverse=True)
|
||||
for obj in root_objects:
|
||||
self._interface.childNodes.insert(0, obj)
|
||||
|
||||
@@ -461,8 +455,8 @@
|
||||
if signal_name in ['activate', 'toggled']:
|
||||
action.appendChild(signal)
|
||||
else:
|
||||
- print 'Unhandled signal %s::%s' % (node.getAttribute('class'),
|
||||
- signal_name)
|
||||
+ print('Unhandled signal %s::%s' % (node.getAttribute('class'),
|
||||
+ signal_name))
|
||||
|
||||
if not uimgr.childNodes:
|
||||
child = self._dom.createElement('child')
|
||||
@@ -481,8 +475,8 @@
|
||||
for accelerator in get_accelerator_nodes(node):
|
||||
signal_name = accelerator.getAttribute('signal')
|
||||
if signal_name != 'activate':
|
||||
- print 'Unhandled accelerator signal for %s::%s' % (
|
||||
- node.getAttribute('class'), signal_name)
|
||||
+ print('Unhandled accelerator signal for %s::%s' % (
|
||||
+ node.getAttribute('class'), signal_name))
|
||||
continue
|
||||
accelerator.removeAttribute('signal')
|
||||
child.appendChild(accelerator)
|
||||
@@ -741,13 +735,14 @@
|
||||
|
||||
s = subprocess.Popen([filename, '--format', '-'],
|
||||
stdin=subprocess.PIPE,
|
||||
- stdout=subprocess.PIPE)
|
||||
+ stdout=subprocess.PIPE,
|
||||
+ universal_newlines=True)
|
||||
s.stdin.write(output)
|
||||
s.stdin.close()
|
||||
return s.stdout.read()
|
||||
|
||||
def usage():
|
||||
- print __doc__
|
||||
+ print(__doc__)
|
||||
|
||||
def main(args):
|
||||
try:
|
||||
@@ -788,10 +783,10 @@
|
||||
|
||||
xml = _indent(conv.to_xml())
|
||||
if output_filename == "-":
|
||||
- print xml
|
||||
+ print(xml)
|
||||
else:
|
||||
open(output_filename, 'w').write(xml)
|
||||
- print "Wrote", output_filename
|
||||
+ print("Wrote", output_filename)
|
||||
|
||||
return 0
|
||||
|
9
SOURCES/system-python.patch
Normal file
9
SOURCES/system-python.patch
Normal file
@ -0,0 +1,9 @@
|
||||
diff -up gtk+-2.18.2/gtk/gtk-builder-convert.system-python gtk+-2.18.2/gtk/gtk-builder-convert
|
||||
--- gtk+-2.18.2/gtk/gtk-builder-convert.system-python 2009-10-13 15:59:50.423385098 -0400
|
||||
+++ gtk+-2.18.2/gtk/gtk-builder-convert 2009-10-13 16:00:31.876142050 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
#
|
||||
# Copyright (C) 2006-2008 Async Open Source
|
||||
# Henrique Romano <henrique@async.com.br>
|
182
SOURCES/tooltip-positioning.patch
Normal file
182
SOURCES/tooltip-positioning.patch
Normal file
@ -0,0 +1,182 @@
|
||||
diff --git a/gtk/gtktooltip.c b/gtk/gtktooltip.c
|
||||
index 5cc2334..204a2b6 100644
|
||||
--- a/gtk/gtktooltip.c
|
||||
+++ b/gtk/gtktooltip.c
|
||||
@@ -903,53 +903,128 @@ gtk_tooltip_position (GtkTooltip *tooltip,
|
||||
{
|
||||
gint x, y;
|
||||
GdkScreen *screen;
|
||||
+ gint monitor_num;
|
||||
+ GdkRectangle monitor;
|
||||
+ GtkRequisition requisition;
|
||||
+ guint cursor_size;
|
||||
+ GdkRectangle bounds;
|
||||
+
|
||||
+#define MAX_DISTANCE 32
|
||||
|
||||
tooltip->tooltip_widget = new_tooltip_widget;
|
||||
|
||||
+ screen = gtk_widget_get_screen (new_tooltip_widget);
|
||||
+
|
||||
+ gtk_widget_size_request (GTK_WIDGET (tooltip->current_window), &requisition);
|
||||
+
|
||||
+ monitor_num = gdk_screen_get_monitor_at_point (screen,
|
||||
+ tooltip->last_x,
|
||||
+ tooltip->last_y);
|
||||
+ gdk_screen_get_monitor_geometry (screen, monitor_num, &monitor);
|
||||
+
|
||||
+ get_bounding_box (new_tooltip_widget, &bounds);
|
||||
+
|
||||
/* Position the tooltip */
|
||||
- /* FIXME: should we swap this when RTL is enabled? */
|
||||
- if (tooltip->keyboard_mode_enabled)
|
||||
+
|
||||
+ cursor_size = gdk_display_get_default_cursor_size (display);
|
||||
+
|
||||
+ /* Try below */
|
||||
+ x = bounds.x + bounds.width / 2 - requisition.width / 2;
|
||||
+ y = bounds.y + bounds.height + 4;
|
||||
+
|
||||
+ if (y + requisition.height <= monitor.y + monitor.height)
|
||||
{
|
||||
- GdkRectangle bounds;
|
||||
+ if (tooltip->keyboard_mode_enabled)
|
||||
+ goto found;
|
||||
|
||||
- get_bounding_box (new_tooltip_widget, &bounds);
|
||||
+ if (y <= tooltip->last_y + cursor_size + MAX_DISTANCE)
|
||||
+ {
|
||||
+ if (tooltip->last_x + cursor_size + MAX_DISTANCE < x)
|
||||
+ x = tooltip->last_x + cursor_size + MAX_DISTANCE;
|
||||
+ else if (x + requisition.width < tooltip->last_x - MAX_DISTANCE)
|
||||
+ x = tooltip->last_x - MAX_DISTANCE - requisition.width;
|
||||
|
||||
- /* For keyboard mode we position the tooltip below the widget,
|
||||
- * right of the center of the widget.
|
||||
- */
|
||||
- x = bounds.x + bounds.width / 2;
|
||||
- y = bounds.y + bounds.height + 4;
|
||||
+ goto found;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ /* Try above */
|
||||
+ x = bounds.x + bounds.width / 2 - requisition.width / 2;
|
||||
+ y = bounds.y - requisition.height - 4;
|
||||
+
|
||||
+ if (y >= monitor.y)
|
||||
+ {
|
||||
+ if (tooltip->keyboard_mode_enabled)
|
||||
+ goto found;
|
||||
+
|
||||
+ if (y + requisition.height >= tooltip->last_y - MAX_DISTANCE)
|
||||
+ {
|
||||
+ if (tooltip->last_x + cursor_size + MAX_DISTANCE < x)
|
||||
+ x = tooltip->last_x + cursor_size + MAX_DISTANCE;
|
||||
+ else if (x + requisition.width < tooltip->last_x - MAX_DISTANCE)
|
||||
+ x = tooltip->last_x - MAX_DISTANCE - requisition.width;
|
||||
+
|
||||
+ goto found;
|
||||
+ }
|
||||
}
|
||||
- else
|
||||
+
|
||||
+ /* Try right FIXME: flip on rtl ? */
|
||||
+ x = bounds.x + bounds.width + 4;
|
||||
+ y = bounds.y + bounds.height / 2 - requisition.height / 2;
|
||||
+
|
||||
+ if (x + requisition.width <= monitor.x + monitor.width)
|
||||
{
|
||||
- guint cursor_size;
|
||||
+ if (tooltip->keyboard_mode_enabled)
|
||||
+ goto found;
|
||||
|
||||
- x = tooltip->last_x;
|
||||
- y = tooltip->last_y;
|
||||
+ if (x <= tooltip->last_x + cursor_size + MAX_DISTANCE)
|
||||
+ {
|
||||
+ if (tooltip->last_y + cursor_size + MAX_DISTANCE < y)
|
||||
+ y = tooltip->last_y + cursor_size + MAX_DISTANCE;
|
||||
+ else if (y + requisition.height < tooltip->last_y - MAX_DISTANCE)
|
||||
+ y = tooltip->last_y - MAX_DISTANCE - requisition.height;
|
||||
|
||||
- /* For mouse mode, we position the tooltip right of the cursor,
|
||||
- * a little below the cursor's center.
|
||||
- */
|
||||
- cursor_size = gdk_display_get_default_cursor_size (display);
|
||||
- x += cursor_size / 2;
|
||||
- y += cursor_size / 2;
|
||||
+ goto found;
|
||||
+ }
|
||||
}
|
||||
|
||||
- screen = gtk_widget_get_screen (new_tooltip_widget);
|
||||
+ /* Try left FIXME: flip on rtl ? */
|
||||
+ x = bounds.x - requisition.width - 4;
|
||||
+ y = bounds.y + bounds.height / 2 - requisition.height / 2;
|
||||
|
||||
- /* Show it */
|
||||
- if (tooltip->current_window)
|
||||
+ if (x >= monitor.x)
|
||||
{
|
||||
- gint monitor_num;
|
||||
- GdkRectangle monitor;
|
||||
- GtkRequisition requisition;
|
||||
+ if (tooltip->keyboard_mode_enabled)
|
||||
+ goto found;
|
||||
|
||||
- gtk_widget_size_request (GTK_WIDGET (tooltip->current_window),
|
||||
- &requisition);
|
||||
+ if (x + requisition.width >= tooltip->last_x - MAX_DISTANCE)
|
||||
+ {
|
||||
+ if (tooltip->last_y + cursor_size + MAX_DISTANCE < y)
|
||||
+ y = tooltip->last_y + cursor_size + MAX_DISTANCE;
|
||||
+ else if (y + requisition.height < tooltip->last_y - MAX_DISTANCE)
|
||||
+ y = tooltip->last_y - MAX_DISTANCE - requisition.height;
|
||||
|
||||
- monitor_num = gdk_screen_get_monitor_at_point (screen, x, y);
|
||||
- gdk_screen_get_monitor_geometry (screen, monitor_num, &monitor);
|
||||
+ goto found;
|
||||
+ }
|
||||
+ }
|
||||
|
||||
+ /* Fallback */
|
||||
+ if (tooltip->keyboard_mode_enabled)
|
||||
+ {
|
||||
+ x = bounds.x + bounds.width / 2 - requisition.width / 2;
|
||||
+ y = bounds.y + bounds.height + 4;
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ /* At cursor */
|
||||
+ x = tooltip->last_x + cursor_size * 3 / 4;
|
||||
+ y = tooltip->last_y + cursor_size * 3 / 4;
|
||||
+ }
|
||||
+
|
||||
+found:
|
||||
+ /* Show it */
|
||||
+ if (tooltip->current_window)
|
||||
+ {
|
||||
if (x + requisition.width > monitor.x + monitor.width)
|
||||
x -= x - (monitor.x + monitor.width) + requisition.width;
|
||||
else if (x < monitor.x)
|
||||
@@ -957,7 +1032,9 @@ gtk_tooltip_position (GtkTooltip *tooltip,
|
||||
|
||||
if (y + requisition.height > monitor.y + monitor.height)
|
||||
y -= y - (monitor.y + monitor.height) + requisition.height;
|
||||
-
|
||||
+ else if (y < monitor.y)
|
||||
+ y = monitor.y;
|
||||
+
|
||||
if (!tooltip->keyboard_mode_enabled)
|
||||
{
|
||||
/* don't pop up under the pointer */
|
||||
@@ -965,7 +1042,7 @@ gtk_tooltip_position (GtkTooltip *tooltip,
|
||||
y <= tooltip->last_y && tooltip->last_y < y + requisition.height)
|
||||
y = tooltip->last_y - requisition.height - 2;
|
||||
}
|
||||
-
|
||||
+
|
||||
gtk_window_move (GTK_WINDOW (tooltip->current_window), x, y);
|
||||
gtk_widget_show (GTK_WIDGET (tooltip->current_window));
|
||||
}
|
17
SOURCES/update-gtk-immodules
Executable file
17
SOURCES/update-gtk-immodules
Executable file
@ -0,0 +1,17 @@
|
||||
#! /bin/sh
|
||||
|
||||
if test $# != 1; then
|
||||
echo usage: update-gtk-immodules host_triplet 1>&2
|
||||
exit 1
|
||||
fi
|
||||
|
||||
umask 022
|
||||
|
||||
case "$1" in
|
||||
alpha*|ia64*|ppc64*|powerpc64*|s390x*|x86_64*|aarch64*)
|
||||
/usr/bin/gtk-query-immodules-2.0-64 --update-cache
|
||||
;;
|
||||
*)
|
||||
/usr/bin/gtk-query-immodules-2.0-32 --update-cache
|
||||
;;
|
||||
esac
|
52
SOURCES/update-gtk-immodules.1
Normal file
52
SOURCES/update-gtk-immodules.1
Normal file
@ -0,0 +1,52 @@
|
||||
'\" t
|
||||
.\" Title: update-gtk-immodules
|
||||
.\" Author: Matthias Clasen <mclasen@redhat.com>
|
||||
.\" Date: 06/26/2013
|
||||
.\" Manual: User Commands
|
||||
.\" Source: GTK+
|
||||
.\" Language: English
|
||||
.\"
|
||||
.TH "UPDATE\-GTK\-IMMODULES" "1" "" "GTK+" "User Commands"
|
||||
.\" -----------------------------------------------------------------
|
||||
.\" * Define some portability stuff
|
||||
.\" -----------------------------------------------------------------
|
||||
.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||
.\" http://bugs.debian.org/507673
|
||||
.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
|
||||
.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||
.ie \n(.g .ds Aq \(aq
|
||||
.el .ds Aq '
|
||||
.\" -----------------------------------------------------------------
|
||||
.\" * set default formatting
|
||||
.\" -----------------------------------------------------------------
|
||||
.\" disable hyphenation
|
||||
.nh
|
||||
.\" disable justification (adjust text to left margin only)
|
||||
.ad l
|
||||
.\" -----------------------------------------------------------------
|
||||
.\" * MAIN CONTENT STARTS HERE *
|
||||
.\" -----------------------------------------------------------------
|
||||
.SH "NAME"
|
||||
update-gtk-immodules - Update GTK+ immodule cache
|
||||
.SH "SYNOPSIS"
|
||||
.HP \w'\fBupdate-gtk-immodules\fR\ 'u
|
||||
\fBupdate-gtk-immodules\fR [HOST_TRIPLET]
|
||||
.SH "DESCRIPTION"
|
||||
.PP
|
||||
\fBupdate-gtk-immodules\fR
|
||||
is a wrapper around gtk-query-immodules-2.0 that tries to help with
|
||||
multilib installations. It is meant to be used in %post scripts of rpm
|
||||
packages that install input method modules for GTK+ 2.x.
|
||||
|
||||
.PP
|
||||
It needs to be given a GNU-style host triplet as argument, such as
|
||||
"x86_64-redhat-linux-gnu". This argument determines where the tool
|
||||
saves the gtk.immodules file that it creates. It must be the same
|
||||
as the host triplet that GTK+ was configured with.
|
||||
|
||||
.SH "FILES"
|
||||
.PP
|
||||
$libdir/gtk-2.0/2.10.0/immodules.cache - the file created by update-gtk-immodules.
|
||||
|
||||
.SH "SEE ALSO"
|
||||
.BR gtk-query-immodules-2.0 "(1)"
|
116
SOURCES/window-dragging.patch
Normal file
116
SOURCES/window-dragging.patch
Normal file
@ -0,0 +1,116 @@
|
||||
diff -up gtk+-2.24.7/gtk/gtkmenushell.c.window-dragging gtk+-2.24.7/gtk/gtkmenushell.c
|
||||
--- gtk+-2.24.7/gtk/gtkmenushell.c.window-dragging 2011-08-15 22:30:52.000000000 -0400
|
||||
+++ gtk+-2.24.7/gtk/gtkmenushell.c 2011-10-17 19:50:52.180468086 -0400
|
||||
@@ -589,18 +589,45 @@ gtk_menu_shell_button_press (GtkWidget
|
||||
|
||||
if (!menu_shell->active || !menu_shell->button)
|
||||
{
|
||||
- gtk_menu_shell_activate (menu_shell);
|
||||
+ gboolean initially_active = menu_shell->active;
|
||||
|
||||
menu_shell->button = event->button;
|
||||
|
||||
- if (menu_item && _gtk_menu_item_is_selectable (menu_item) &&
|
||||
- menu_item->parent == widget &&
|
||||
- menu_item != menu_shell->active_menu_item)
|
||||
+ if (menu_item)
|
||||
{
|
||||
- if (GTK_MENU_SHELL_GET_CLASS (menu_shell)->submenu_placement == GTK_TOP_BOTTOM)
|
||||
+ if (_gtk_menu_item_is_selectable (menu_item) &&
|
||||
+ menu_item->parent == widget &&
|
||||
+ menu_item != menu_shell->active_menu_item)
|
||||
{
|
||||
- menu_shell->activate_time = event->time;
|
||||
- gtk_menu_shell_select_item (menu_shell, menu_item);
|
||||
+ gtk_menu_shell_activate (menu_shell);
|
||||
+ menu_shell->button = event->button;
|
||||
+
|
||||
+ if (GTK_MENU_SHELL_GET_CLASS (menu_shell)->submenu_placement == GTK_TOP_BOTTOM)
|
||||
+ {
|
||||
+ menu_shell->activate_time = event->time;
|
||||
+ gtk_menu_shell_select_item (menu_shell, menu_item);
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ if (!initially_active)
|
||||
+ {
|
||||
+ gboolean window_drag = FALSE;
|
||||
+
|
||||
+ gtk_widget_style_get (widget,
|
||||
+ "window-dragging", &window_drag,
|
||||
+ NULL);
|
||||
+
|
||||
+ if (window_drag)
|
||||
+ {
|
||||
+ gtk_menu_shell_deactivate (menu_shell);
|
||||
+ gtk_window_begin_move_drag (GTK_WINDOW (gtk_widget_get_toplevel (widget)),
|
||||
+ event->button,
|
||||
+ event->x_root,
|
||||
+ event->y_root,
|
||||
+ event->time);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
}
|
||||
diff -up gtk+-2.24.7/gtk/gtktoolbar.c.window-dragging gtk+-2.24.7/gtk/gtktoolbar.c
|
||||
--- gtk+-2.24.7/gtk/gtktoolbar.c.window-dragging 2011-10-01 11:29:06.000000000 -0400
|
||||
+++ gtk+-2.24.7/gtk/gtktoolbar.c 2011-10-17 19:52:56.104463657 -0400
|
||||
@@ -2701,6 +2701,8 @@ static gboolean
|
||||
gtk_toolbar_button_press (GtkWidget *toolbar,
|
||||
GdkEventButton *event)
|
||||
{
|
||||
+ GtkWidget *window;
|
||||
+
|
||||
if (_gtk_button_event_triggers_context_menu (event))
|
||||
{
|
||||
gboolean return_value;
|
||||
@@ -2711,7 +2713,29 @@ gtk_toolbar_button_press (GtkWidget
|
||||
|
||||
return return_value;
|
||||
}
|
||||
-
|
||||
+
|
||||
+ window = gtk_widget_get_toplevel (toolbar);
|
||||
+
|
||||
+ if (window)
|
||||
+ {
|
||||
+ gboolean window_drag = FALSE;
|
||||
+
|
||||
+ gtk_widget_style_get (toolbar,
|
||||
+ "window-dragging", &window_drag,
|
||||
+ NULL);
|
||||
+
|
||||
+ if (window_drag)
|
||||
+ {
|
||||
+ gtk_window_begin_move_drag (GTK_WINDOW (window),
|
||||
+ event->button,
|
||||
+ event->x_root,
|
||||
+ event->y_root,
|
||||
+ event->time);
|
||||
+
|
||||
+ return TRUE;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
diff -up gtk+-2.24.7/gtk/gtkwidget.c.window-dragging gtk+-2.24.7/gtk/gtkwidget.c
|
||||
--- gtk+-2.24.7/gtk/gtkwidget.c.window-dragging 2011-10-17 19:50:52.175468086 -0400
|
||||
+++ gtk+-2.24.7/gtk/gtkwidget.c 2011-10-17 19:50:52.184468086 -0400
|
||||
@@ -2467,6 +2467,13 @@ gtk_widget_class_init (GtkWidgetClass *k
|
||||
0.0, 1.0, 0.04,
|
||||
GTK_PARAM_READABLE));
|
||||
|
||||
+ gtk_widget_class_install_style_property (klass,
|
||||
+ g_param_spec_boolean ("window-dragging",
|
||||
+ P_("Window dragging"),
|
||||
+ P_("Window dragging"),
|
||||
+ FALSE,
|
||||
+ GTK_PARAM_READWRITE));
|
||||
+
|
||||
/**
|
||||
* GtkWidget:draw-border:
|
||||
*
|
2173
SPECS/gtk2.spec
Normal file
2173
SPECS/gtk2.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user