update patches

This commit is contained in:
Matthias Clasen 2010-06-28 16:10:30 +00:00
parent 109accc1ce
commit 0a80d59fd2
2 changed files with 0 additions and 47 deletions

View File

@ -1,47 +1,3 @@
diff -up gtk+-2.19.1/gdk-pixbuf/gdk-pixbuf-io.c.lib64 gtk+-2.19.1/gdk-pixbuf/gdk-pixbuf-io.c
--- gtk+-2.19.1/gdk-pixbuf/gdk-pixbuf-io.c.lib64 2009-11-30 13:10:35.000000000 -0500
+++ gtk+-2.19.1/gdk-pixbuf/gdk-pixbuf-io.c 2009-11-30 20:54:21.842859303 -0500
@@ -305,7 +305,17 @@ gdk_pixbuf_get_module_file (void)
gchar *result = g_strdup (g_getenv ("GDK_PIXBUF_MODULE_FILE"));
if (!result)
- result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gdk-pixbuf.loaders", NULL);
+ {
+ result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0",
+ HOST, "gdk-pixbuf.loaders", NULL);
+ if (!g_file_test (result, G_FILE_TEST_EXISTS))
+ {
+ g_free (result);
+
+ result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0",
+ "gdk-pixbuf.loaders", NULL);
+ }
+ }
return result;
}
diff -up gtk+-2.19.1/gdk-pixbuf/Makefile.am.lib64 gtk+-2.19.1/gdk-pixbuf/Makefile.am
--- gtk+-2.19.1/gdk-pixbuf/Makefile.am.lib64 2009-11-26 01:35:49.000000000 -0500
+++ gtk+-2.19.1/gdk-pixbuf/Makefile.am 2009-11-30 20:54:21.842859303 -0500
@@ -521,6 +521,7 @@ INCLUDES = \
-I$(top_srcdir)/gdk-pixbuf \
-I$(top_builddir)/gdk-pixbuf \
-DGTK_SYSCONFDIR=\"$(sysconfdir)\" \
+ -DHOST=\"$(host_triplet)\" \
-DGTK_VERSION=\"$(GTK_VERSION)\" \
-DGTK_BINARY_VERSION=\"$(GTK_BINARY_VERSION)\" \
-DGTK_PREFIX=\"$(prefix)\" \
diff -up gtk+-2.19.1/gdk-pixbuf/Makefile.in.lib64 gtk+-2.19.1/gdk-pixbuf/Makefile.in
--- gtk+-2.19.1/gdk-pixbuf/Makefile.in.lib64 2009-11-30 20:54:58.058857713 -0500
+++ gtk+-2.19.1/gdk-pixbuf/Makefile.in 2009-11-30 20:55:21.902591753 -0500
@@ -1344,6 +1344,7 @@ INCLUDES = \
-I$(top_srcdir)/gdk-pixbuf \
-I$(top_builddir)/gdk-pixbuf \
-DGTK_SYSCONFDIR=\"$(sysconfdir)\" \
+ -DHOST=\"$(host_triplet)\" \
-DGTK_VERSION=\"$(GTK_VERSION)\" \
-DGTK_BINARY_VERSION=\"$(GTK_BINARY_VERSION)\" \
-DGTK_PREFIX=\"$(prefix)\" \
diff -up gtk+-2.19.1/gtk/gtkrc.c.lib64 gtk+-2.19.1/gtk/gtkrc.c
--- gtk+-2.19.1/gtk/gtkrc.c.lib64 2009-11-26 01:35:50.000000000 -0500
+++ gtk+-2.19.1/gtk/gtkrc.c 2009-11-30 20:54:21.844826383 -0500

View File

@ -37,8 +37,6 @@ Patch2: icon-padding.patch
Patch4: fresh-tooltips.patch
# https://bugzilla.gnome.org/show_bug.cgi?id=599618
Patch8: tooltip-positioning.patch
# http://bugzilla.redhat.com/show_bug.cgi?id=529364
Patch11: gtk2-remove-connecting-reason.patch
# https://bugzilla.gnome.org/show_bug.cgi?id=592582
#Patch14: gtk2-landscape-pdf-print.patch
# https://bugzilla.gnome.org/show_bug.cgi?id=611313
@ -158,7 +156,6 @@ This package contains developer documentation for the GTK+ widget toolkit.
%patch2 -p1 -b .icon-padding
%patch4 -p1 -b .fresh-tooltips
%patch8 -p1 -b .tooltip-positioning
%patch11 -p1 -b .remove-connecting-reason
#%patch14 -p1 -b .landscape-pdf-print
%patch15 -p1 -b .window-dragging