Update to 0.5.4 release
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
This commit is contained in:
parent
d6011d26f0
commit
0071db3f73
@ -1,37 +0,0 @@
|
||||
From 3bbaa914d9bfafaf5a4d78867a578bddf5fc9134 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <3bbaa914d9bfafaf5a4d78867a578bddf5fc9134.1414608565.git.crobinso@redhat.com>
|
||||
From: "Daniel P. Berrange" <berrange@redhat.com>
|
||||
Date: Wed, 29 Oct 2014 16:13:46 +0000
|
||||
Subject: [PATCH] Enable double buffering on GTK3
|
||||
|
||||
---
|
||||
src/vncdisplay.c | 12 ++++++++++++
|
||||
1 file changed, 12 insertions(+)
|
||||
|
||||
diff --git a/src/vncdisplay.c b/src/vncdisplay.c
|
||||
index c47f8ee..b990f97 100644
|
||||
--- a/gtk-vnc-0.5.3/src/vncdisplay.c
|
||||
+++ b/gtk-vnc-0.5.3/src/vncdisplay.c
|
||||
@@ -2186,7 +2186,19 @@ static void vnc_display_init(VncDisplay *display)
|
||||
GDK_LEAVE_NOTIFY_MASK |
|
||||
GDK_SCROLL_MASK |
|
||||
GDK_KEY_PRESS_MASK);
|
||||
+ /* We already have off-screen buffers we render to
|
||||
+ * but with GTK-3 there are problems with overlaid
|
||||
+ * windows. We end up rendering over the top of the
|
||||
+ * child overlaid windows despite having a clip
|
||||
+ * mask set :-( We've turned on GTK3's built-in
|
||||
+ * double buffering to work around this until we
|
||||
+ * find a better idea.
|
||||
+ */
|
||||
+#if GTK_CHECK_VERSION(3, 0, 0)
|
||||
+ gtk_widget_set_double_buffered(widget, TRUE);
|
||||
+#else
|
||||
gtk_widget_set_double_buffered(widget, FALSE);
|
||||
+#endif
|
||||
|
||||
priv = display->priv = VNC_DISPLAY_GET_PRIVATE(display);
|
||||
memset(priv, 0, sizeof(VncDisplayPrivate));
|
||||
--
|
||||
2.1.0
|
||||
|
11
gtk-vnc.spec
11
gtk-vnc.spec
@ -19,14 +19,12 @@
|
||||
|
||||
Summary: A GTK2 widget for VNC clients
|
||||
Name: gtk-vnc
|
||||
Version: 0.5.3
|
||||
Release: 6%{?dist}%{?extra_release}
|
||||
Version: 0.5.4
|
||||
Release: 1%{?dist}%{?extra_release}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.5/%{name}-%{version}.tar.xz
|
||||
|
||||
# Fix virt-viewer fullscreen widget (bz #1036824)
|
||||
Patch0001: 0001-Enable-double-buffering-on-GTK3.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
URL: http://live.gnome.org/gtk-vnc
|
||||
Requires: gvnc = %{version}-%{release}
|
||||
@ -158,8 +156,6 @@ Libraries, includes, etc. to compile with the gtk-vnc library
|
||||
%prep
|
||||
%setup -q -n gtk-vnc-%{version} -c
|
||||
|
||||
# Fix virt-viewer fullscreen widget (bz #1036824)
|
||||
%patch0001 -p1
|
||||
%if %{with_gtk3}
|
||||
cp -a gtk-vnc-%{version} gtk-vnc2-%{version}
|
||||
%endif
|
||||
@ -329,6 +325,9 @@ rm -fr %{buildroot}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Feb 10 2015 Daniel P. Berrange <berrange@redhat.com> - 0.5.4-1
|
||||
- Update to 0.5.4 release
|
||||
|
||||
* Wed Oct 29 2014 Cole Robinson <crobinso@redhat.com> - 0.5.3-6
|
||||
- Fix virt-viewer fullscreen widget (bz #1036824)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user