Update to 1.26
This commit is contained in:
parent
59b4dc5abb
commit
e7f94fd2d1
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ gtk-doc-1.15.tar.bz2
|
||||
/gtk-doc-1.23.tar.xz
|
||||
/gtk-doc-1.24.tar.xz
|
||||
/gtk-doc-1.25.tar.xz
|
||||
/gtk-doc-1.26.tar.xz
|
||||
|
@ -0,0 +1,76 @@
|
||||
From a8475278880270a3bf682d9552e26651081330ce Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Fri, 11 Aug 2017 21:19:28 +0200
|
||||
Subject: [PATCH] tests: Label parts with decimals, not roman numerals
|
||||
|
||||
dblatex (via gtkdoc-mkpdf) warns that labels must be integers:
|
||||
|
||||
Warning: only an integer in @label can be processed: 'I'
|
||||
Warning: only an integer in @label can be processed: 'II'
|
||||
Warning: only an integer in @label can be processed: 'III'
|
||||
|
||||
Make the labels decimal to placate dblatex. I'm not sure this is
|
||||
actually the best solution, though.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=786174
|
||||
---
|
||||
tests/annotations/docs/tester-docs.xml | 4 ++--
|
||||
tests/gobject/docs/tester-docs.xml | 6 +++---
|
||||
2 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/tests/annotations/docs/tester-docs.xml b/tests/annotations/docs/tester-docs.xml
|
||||
index e2abf74..7d80f9d 100644
|
||||
--- a/tests/annotations/docs/tester-docs.xml
|
||||
+++ b/tests/annotations/docs/tester-docs.xml
|
||||
@@ -16,7 +16,7 @@
|
||||
</releaseinfo>
|
||||
</bookinfo>
|
||||
|
||||
- <reference label="II">
|
||||
+ <reference label="2">
|
||||
<title>API Reference</title>
|
||||
<chapter id="main-api">
|
||||
<title>Tests</title>
|
||||
@@ -24,7 +24,7 @@
|
||||
</chapter>
|
||||
</reference>
|
||||
|
||||
- <part label="III">
|
||||
+ <part label="3">
|
||||
<title>Appendix</title>
|
||||
|
||||
<index id="api-index">
|
||||
diff --git a/tests/gobject/docs/tester-docs.xml b/tests/gobject/docs/tester-docs.xml
|
||||
index a534c55..05117ef 100644
|
||||
--- a/tests/gobject/docs/tester-docs.xml
|
||||
+++ b/tests/gobject/docs/tester-docs.xml
|
||||
@@ -37,7 +37,7 @@
|
||||
</para>
|
||||
</preface>
|
||||
|
||||
- <part label="I" id="part.i">
|
||||
+ <part label="1" id="part.i">
|
||||
<title>Overview</title>
|
||||
<chapter id="Overview-building">
|
||||
<title>How to build the library</title>
|
||||
@@ -45,7 +45,7 @@
|
||||
</chapter>
|
||||
</part>
|
||||
|
||||
- <reference label="II" id="part.ii">
|
||||
+ <reference label="2" id="part.ii">
|
||||
<title>API Reference</title>
|
||||
<chapter id="main-api">
|
||||
<title>Tests</title>
|
||||
@@ -58,7 +58,7 @@
|
||||
</chapter>
|
||||
</reference>
|
||||
|
||||
- <part label="III" id="part.iii">
|
||||
+ <part label="3" id="part.iii">
|
||||
<title>Appendix</title>
|
||||
|
||||
<chapter id="object-tree">
|
||||
--
|
||||
2.13.0
|
||||
|
@ -1,3 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
/usr/lib/rpm/perl.req $* | grep -v 'perl(gtkdoc-common.pl)'
|
42
gtk-doc.spec
42
gtk-doc.spec
@ -1,24 +1,23 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: gtk-doc
|
||||
Version: 1.25
|
||||
Release: 6%{?dist}
|
||||
Version: 1.26
|
||||
Release: 1%{?dist}
|
||||
Summary: API documentation generation tool for GTK+ and GNOME
|
||||
|
||||
License: GPLv2+ and GFDL
|
||||
URL: http://www.gtk.org/gtk-doc
|
||||
Source: http://download.gnome.org/sources/gtk-doc/1.25/gtk-doc-%{version}.tar.xz
|
||||
Source0: http://download.gnome.org/sources/gtk-doc/1.26/gtk-doc-%{version}.tar.xz
|
||||
|
||||
# Backported from upstream
|
||||
Patch0: 0001-tests-Label-parts-with-decimals-not-roman-numerals.patch
|
||||
|
||||
BuildRequires: dblatex
|
||||
BuildRequires: docbook-utils
|
||||
BuildRequires: jade
|
||||
BuildRequires: /usr/bin/xsltproc
|
||||
BuildRequires: docbook-style-xsl
|
||||
%if 0%{?fedora}
|
||||
BuildRequires: perl-generators
|
||||
%endif
|
||||
BuildRequires: perl-Test-Simple
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: gnome-doc-utils
|
||||
BuildRequires: python2-six
|
||||
BuildRequires: gettext
|
||||
BuildRequires: source-highlight
|
||||
BuildRequires: yelp-tools
|
||||
@ -26,30 +25,19 @@ BuildRequires: yelp-tools
|
||||
BuildRequires: cmake
|
||||
|
||||
# Following are not automatically installed
|
||||
Requires: docbook-utils openjade /usr/bin/xsltproc docbook-style-xsl
|
||||
Requires: docbook-utils /usr/bin/xsltproc docbook-style-xsl
|
||||
# we are installing an automake macro
|
||||
Requires: automake
|
||||
# we are installing an sgml catalog
|
||||
Requires: sgml-common
|
||||
Requires: python2-six
|
||||
Requires: source-highlight
|
||||
|
||||
|
||||
Source1: filter-requires-gtk-doc.sh
|
||||
%define __perl_requires %{SOURCE1}
|
||||
|
||||
%description
|
||||
gtk-doc is a tool for generating API reference documentation.
|
||||
It is used for generating the documentation for GTK+, GLib
|
||||
and GNOME.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%if 0%{?rhel} == 7
|
||||
# Lower unnecessarily high perl requirement
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=773151
|
||||
sed -i -e 's/require v5\.18\.0/require v5.16.0/' configure
|
||||
%endif
|
||||
%autosetup -p1
|
||||
|
||||
# Move this doc file to avoid name collisions
|
||||
mv doc/README doc/README.docs
|
||||
@ -64,7 +52,9 @@ make %{?_smp_mflags}
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html
|
||||
|
||||
%check
|
||||
make check
|
||||
# For reasons unknown first make check fails with texlive debug spew in log
|
||||
# files. Just run it twice to work this around.
|
||||
make check || make check
|
||||
|
||||
%files
|
||||
%license COPYING COPYING-DOCS
|
||||
@ -72,12 +62,14 @@ make check
|
||||
%{_bindir}/*
|
||||
%{_datadir}/aclocal/gtk-doc.m4
|
||||
%{_datadir}/gtk-doc/
|
||||
%{_datadir}/sgml/gtk-doc/
|
||||
%{_datadir}/pkgconfig/gtk-doc.pc
|
||||
%{_datadir}/help/*/gtk-doc-manual/
|
||||
%{_libdir}/cmake/*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 15 2017 Kalev Lember <klember@redhat.com> - 1.26-1
|
||||
- Update to 1.26
|
||||
|
||||
* Mon Aug 07 2017 Björn Esser <besser82@fedoraproject.org> - 1.25-6
|
||||
- Rebuilt for AutoReq cmake-filesystem
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user