fix location of the manual
This commit is contained in:
parent
7b6e98b9e0
commit
e6ae5a69a3
70
dochelpdir.patch
Normal file
70
dochelpdir.patch
Normal file
@ -0,0 +1,70 @@
|
|||||||
|
--- trunk/xmldocs.make 2006/04/15 12:04:42 388
|
||||||
|
+++ trunk/xmldocs.make 2007/01/03 15:05:00 413
|
||||||
|
@@ -33,19 +33,17 @@
|
||||||
|
#
|
||||||
|
|
||||||
|
|
||||||
|
-# ************* Begin of section some packagers may need to modify **************
|
||||||
|
-# This variable (gtkdochelpdir) specifies where the documents should be installed.
|
||||||
|
+# ********** Begin of section some packagers may need to modify **********
|
||||||
|
+# This variable (docdir) specifies where the documents should be installed.
|
||||||
|
# This default value should work for most packages.
|
||||||
|
-# gtkdochelpdir = $(datadir)/@PACKAGE@/doc/$(docname)/$(lang)
|
||||||
|
-gtkdochelpdir = $(datadir)/gnome/help/$(docname)/$(lang)
|
||||||
|
+docdir = $(datadir)/gnome/help/$(docname)/$(lang)
|
||||||
|
|
||||||
|
-# ************** You should not have to edit below this line *******************
|
||||||
|
+# ********** You should not have to edit below this line **********
|
||||||
|
xml_files = $(entities) $(docname).xml
|
||||||
|
|
||||||
|
EXTRA_DIST = $(xml_files) $(omffile)
|
||||||
|
CLEANFILES = omf_timestamp
|
||||||
|
|
||||||
|
-# If the following file is in a subdir (like help/) you need to add that to the path
|
||||||
|
include $(top_srcdir)/omf.make
|
||||||
|
|
||||||
|
all: omf
|
||||||
|
@@ -65,15 +63,15 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
install-data-local: omf
|
||||||
|
- $(mkinstalldirs) $(DESTDIR)$(gtkdochelpdir)
|
||||||
|
+ $(mkinstalldirs) $(DESTDIR)$(docdir)
|
||||||
|
for file in $(xml_files); do \
|
||||||
|
- cp $(srcdir)/$$file $(DESTDIR)$(gtkdochelpdir); \
|
||||||
|
+ cp $(srcdir)/$$file $(DESTDIR)$(docdir); \
|
||||||
|
done
|
||||||
|
if test "$(figdir)"; then \
|
||||||
|
- $(mkinstalldirs) $(DESTDIR)$(gtkdochelpdir)/$(figdir); \
|
||||||
|
+ $(mkinstalldirs) $(DESTDIR)$(docdir)/$(figdir); \
|
||||||
|
for file in $(srcdir)/$(figdir)/*.png; do \
|
||||||
|
basefile=`echo $$file | sed -e 's,^.*/,,'`; \
|
||||||
|
- $(INSTALL_DATA) $$file $(DESTDIR)$(gtkdochelpdir)/$(figdir)/$$basefile; \
|
||||||
|
+ $(INSTALL_DATA) $$file $(DESTDIR)$(docdir)/$(figdir)/$$basefile; \
|
||||||
|
done \
|
||||||
|
fi
|
||||||
|
|
||||||
|
@@ -85,12 +83,19 @@
|
||||||
|
-if test "$(figdir)"; then \
|
||||||
|
for file in $(srcdir)/$(figdir)/*.png; do \
|
||||||
|
basefile=`echo $$file | sed -e 's,^.*/,,'`; \
|
||||||
|
- rm -f $(gtkdochelpdir)/$(figdir)/$$basefile; \
|
||||||
|
+ rm -f $(DESTDIR)$(docdir)/$(figdir)/$$basefile; \
|
||||||
|
done; \
|
||||||
|
- rmdir $(DESTDIR)$(gtkdochelpdir)/$(figdir); \
|
||||||
|
+ rmdir $(DESTDIR)$(docdir)/$(figdir); \
|
||||||
|
fi
|
||||||
|
-for file in $(xml_files); do \
|
||||||
|
- rm -f $(DESTDIR)$(gtkdochelpdir)/$$file; \
|
||||||
|
+ rm -f $(DESTDIR)$(docdir)/$$file; \
|
||||||
|
done
|
||||||
|
- -rmdir $(DESTDIR)$(gtkdochelpdir)
|
||||||
|
+ -rmdir $(DESTDIR)$(docdir)
|
||||||
|
|
||||||
|
+clean-local: clean-local-doc clean-local-omf
|
||||||
|
+
|
||||||
|
+# for non-srcdir builds, remove the copied entities.
|
||||||
|
+clean-local-doc:
|
||||||
|
+ if test $(srcdir) != .; then \
|
||||||
|
+ rm -f $(entities); \
|
||||||
|
+ fi
|
10
gtk-doc.spec
10
gtk-doc.spec
@ -31,6 +31,9 @@ Requires: sgml-common
|
|||||||
Source1: filter-requires-gtk-doc.sh
|
Source1: filter-requires-gtk-doc.sh
|
||||||
%define __perl_requires %{SOURCE1}
|
%define __perl_requires %{SOURCE1}
|
||||||
|
|
||||||
|
# revert a broken upstream change
|
||||||
|
Patch0: dochelpdir.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
gtk-doc is a tool for generating API reference documentation.
|
gtk-doc is a tool for generating API reference documentation.
|
||||||
It is used for generating the documentation for GTK+, GLib
|
It is used for generating the documentation for GTK+, GLib
|
||||||
@ -39,11 +42,15 @@ and GNOME.
|
|||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -R -b .dochelpdir
|
||||||
|
|
||||||
# Move this doc file to avoid name collisions
|
# Move this doc file to avoid name collisions
|
||||||
mv doc/README doc/README.docs
|
mv doc/README doc/README.docs
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
aclocal
|
||||||
|
automake
|
||||||
|
autoconf
|
||||||
%configure --enable-public-id --disable-scrollkeeper
|
%configure --enable-public-id --disable-scrollkeeper
|
||||||
make
|
make
|
||||||
|
|
||||||
@ -57,9 +64,6 @@ rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
|
|||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html
|
mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html
|
||||||
|
|
||||||
# we already package the files from the source tree
|
|
||||||
rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/gtk-doc
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user