Update to 1.11
This commit is contained in:
parent
11e14560bf
commit
a5d930f5bf
@ -1 +1 @@
|
|||||||
gtk-doc-1.10.tar.bz2
|
gtk-doc-1.11.tar.bz2
|
||||||
|
54
docdir.patch
54
docdir.patch
@ -1,54 +0,0 @@
|
|||||||
diff -up gtk-doc-1.9/xmldocs.make.docdir gtk-doc-1.9/xmldocs.make
|
|
||||||
--- gtk-doc-1.9/xmldocs.make.docdir 2007-02-05 11:51:22.000000000 -0500
|
|
||||||
+++ gtk-doc-1.9/xmldocs.make 2007-11-18 11:27:57.000000000 -0500
|
|
||||||
@@ -34,9 +34,9 @@
|
|
||||||
|
|
||||||
|
|
||||||
# ********** Begin of section some packagers may need to modify **********
|
|
||||||
-# This variable (docdir) specifies where the documents should be installed.
|
|
||||||
+# This variable (docsdir) specifies where the documents should be installed.
|
|
||||||
# This default value should work for most packages.
|
|
||||||
-docdir = $(datadir)/gnome/help/$(docname)/$(lang)
|
|
||||||
+docsdir = $(datadir)/gnome/help/$(docname)/$(lang)
|
|
||||||
|
|
||||||
# ********** You should not have to edit below this line **********
|
|
||||||
xml_files = $(entities) $(docname).xml
|
|
||||||
@@ -63,15 +63,15 @@ app-dist-hook:
|
|
||||||
fi
|
|
||||||
|
|
||||||
install-data-local: omf
|
|
||||||
- $(mkinstalldirs) $(DESTDIR)$(docdir)
|
|
||||||
+ $(mkinstalldirs) $(DESTDIR)$(docsdir)
|
|
||||||
for file in $(xml_files); do \
|
|
||||||
- cp $(srcdir)/$$file $(DESTDIR)$(docdir); \
|
|
||||||
+ cp $(srcdir)/$$file $(DESTDIR)$(docsdir); \
|
|
||||||
done
|
|
||||||
if test "$(figdir)"; then \
|
|
||||||
- $(mkinstalldirs) $(DESTDIR)$(docdir)/$(figdir); \
|
|
||||||
+ $(mkinstalldirs) $(DESTDIR)$(docsdir)/$(figdir); \
|
|
||||||
for file in $(srcdir)/$(figdir)/*.png; do \
|
|
||||||
basefile=`echo $$file | sed -e 's,^.*/,,'`; \
|
|
||||||
- $(INSTALL_DATA) $$file $(DESTDIR)$(docdir)/$(figdir)/$$basefile; \
|
|
||||||
+ $(INSTALL_DATA) $$file $(DESTDIR)$(docsdir)/$(figdir)/$$basefile; \
|
|
||||||
done \
|
|
||||||
fi
|
|
||||||
|
|
||||||
@@ -83,14 +83,14 @@ uninstall-local-doc:
|
|
||||||
-if test "$(figdir)"; then \
|
|
||||||
for file in $(srcdir)/$(figdir)/*.png; do \
|
|
||||||
basefile=`echo $$file | sed -e 's,^.*/,,'`; \
|
|
||||||
- rm -f $(DESTDIR)$(docdir)/$(figdir)/$$basefile; \
|
|
||||||
+ rm -f $(DESTDIR)$(docsdir)/$(figdir)/$$basefile; \
|
|
||||||
done; \
|
|
||||||
- rmdir $(DESTDIR)$(docdir)/$(figdir); \
|
|
||||||
+ rmdir $(DESTDIR)$(docsdir)/$(figdir); \
|
|
||||||
fi
|
|
||||||
-for file in $(xml_files); do \
|
|
||||||
- rm -f $(DESTDIR)$(docdir)/$$file; \
|
|
||||||
+ rm -f $(DESTDIR)$(docsdir)/$$file; \
|
|
||||||
done
|
|
||||||
- -rmdir $(DESTDIR)$(docdir)
|
|
||||||
+ -rmdir $(DESTDIR)$(docsdir)
|
|
||||||
|
|
||||||
clean-local: clean-local-doc clean-local-omf
|
|
||||||
|
|
@ -1,70 +0,0 @@
|
|||||||
--- trunk/xmldocs.make 2006/04/15 12:04:42 388
|
|
||||||
+++ trunk/xmldocs.make 2007/01/03 15:05:00 413
|
|
||||||
@@ -33,19 +33,17 @@
|
|
||||||
#
|
|
||||||
|
|
||||||
|
|
||||||
-# ************* Begin of section some packagers may need to modify **************
|
|
||||||
-# This variable (gtkdochelpdir) specifies where the documents should be installed.
|
|
||||||
+# ********** Begin of section some packagers may need to modify **********
|
|
||||||
+# This variable (docdir) specifies where the documents should be installed.
|
|
||||||
# This default value should work for most packages.
|
|
||||||
-# gtkdochelpdir = $(datadir)/@PACKAGE@/doc/$(docname)/$(lang)
|
|
||||||
-gtkdochelpdir = $(datadir)/gnome/help/$(docname)/$(lang)
|
|
||||||
+docdir = $(datadir)/gnome/help/$(docname)/$(lang)
|
|
||||||
|
|
||||||
-# ************** You should not have to edit below this line *******************
|
|
||||||
+# ********** You should not have to edit below this line **********
|
|
||||||
xml_files = $(entities) $(docname).xml
|
|
||||||
|
|
||||||
EXTRA_DIST = $(xml_files) $(omffile)
|
|
||||||
CLEANFILES = omf_timestamp
|
|
||||||
|
|
||||||
-# If the following file is in a subdir (like help/) you need to add that to the path
|
|
||||||
include $(top_srcdir)/omf.make
|
|
||||||
|
|
||||||
all: omf
|
|
||||||
@@ -65,15 +63,15 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
install-data-local: omf
|
|
||||||
- $(mkinstalldirs) $(DESTDIR)$(gtkdochelpdir)
|
|
||||||
+ $(mkinstalldirs) $(DESTDIR)$(docdir)
|
|
||||||
for file in $(xml_files); do \
|
|
||||||
- cp $(srcdir)/$$file $(DESTDIR)$(gtkdochelpdir); \
|
|
||||||
+ cp $(srcdir)/$$file $(DESTDIR)$(docdir); \
|
|
||||||
done
|
|
||||||
if test "$(figdir)"; then \
|
|
||||||
- $(mkinstalldirs) $(DESTDIR)$(gtkdochelpdir)/$(figdir); \
|
|
||||||
+ $(mkinstalldirs) $(DESTDIR)$(docdir)/$(figdir); \
|
|
||||||
for file in $(srcdir)/$(figdir)/*.png; do \
|
|
||||||
basefile=`echo $$file | sed -e 's,^.*/,,'`; \
|
|
||||||
- $(INSTALL_DATA) $$file $(DESTDIR)$(gtkdochelpdir)/$(figdir)/$$basefile; \
|
|
||||||
+ $(INSTALL_DATA) $$file $(DESTDIR)$(docdir)/$(figdir)/$$basefile; \
|
|
||||||
done \
|
|
||||||
fi
|
|
||||||
|
|
||||||
@@ -85,12 +83,19 @@
|
|
||||||
-if test "$(figdir)"; then \
|
|
||||||
for file in $(srcdir)/$(figdir)/*.png; do \
|
|
||||||
basefile=`echo $$file | sed -e 's,^.*/,,'`; \
|
|
||||||
- rm -f $(gtkdochelpdir)/$(figdir)/$$basefile; \
|
|
||||||
+ rm -f $(DESTDIR)$(docdir)/$(figdir)/$$basefile; \
|
|
||||||
done; \
|
|
||||||
- rmdir $(DESTDIR)$(gtkdochelpdir)/$(figdir); \
|
|
||||||
+ rmdir $(DESTDIR)$(docdir)/$(figdir); \
|
|
||||||
fi
|
|
||||||
-for file in $(xml_files); do \
|
|
||||||
- rm -f $(DESTDIR)$(gtkdochelpdir)/$$file; \
|
|
||||||
+ rm -f $(DESTDIR)$(docdir)/$$file; \
|
|
||||||
done
|
|
||||||
- -rmdir $(DESTDIR)$(gtkdochelpdir)
|
|
||||||
+ -rmdir $(DESTDIR)$(docdir)
|
|
||||||
|
|
||||||
+clean-local: clean-local-doc clean-local-omf
|
|
||||||
+
|
|
||||||
+# for non-srcdir builds, remove the copied entities.
|
|
||||||
+clean-local-doc:
|
|
||||||
+ if test $(srcdir) != .; then \
|
|
||||||
+ rm -f $(entities); \
|
|
||||||
+ fi
|
|
@ -1,13 +0,0 @@
|
|||||||
--- gtk-doc-1.3/gtk-doc.dcl.colon 2005-05-05 11:51:25.259630000 -0400
|
|
||||||
+++ gtk-doc-1.3/gtk-doc.dcl 2005-05-05 11:51:37.601276000 -0400
|
|
||||||
@@ -61,8 +61,8 @@
|
|
||||||
NAMING
|
|
||||||
LCNMSTRT ""
|
|
||||||
UCNMSTRT ""
|
|
||||||
- LCNMCHAR ".-_"
|
|
||||||
- UCNMCHAR ".-_"
|
|
||||||
+ LCNMCHAR ".-_:"
|
|
||||||
+ UCNMCHAR ".-_:"
|
|
||||||
NAMECASE
|
|
||||||
GENERAL YES
|
|
||||||
ENTITY NO
|
|
17
gtk-doc.spec
17
gtk-doc.spec
@ -1,11 +1,10 @@
|
|||||||
Summary: API documentation generation tool for GTK+ and GNOME
|
Summary: API documentation generation tool for GTK+ and GNOME
|
||||||
Name: gtk-doc
|
Name: gtk-doc
|
||||||
Version: 1.10
|
Version: 1.11
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and GFDL
|
License: GPLv2+ and GFDL
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Source: http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/1.10/gtk-doc-%{version}.tar.bz2
|
Source: http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/1.11/gtk-doc-%{version}.tar.bz2
|
||||||
Patch0: docdir.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
URL: http://www.gtk.org/gtk-doc
|
URL: http://www.gtk.org/gtk-doc
|
||||||
@ -16,7 +15,6 @@ BuildRequires: libxslt
|
|||||||
BuildRequires: docbook-style-xsl
|
BuildRequires: docbook-style-xsl
|
||||||
BuildRequires: scrollkeeper
|
BuildRequires: scrollkeeper
|
||||||
BuildRequires: python
|
BuildRequires: python
|
||||||
BuildRequires: autoconf automake libtool
|
|
||||||
|
|
||||||
Requires(post): scrollkeeper
|
Requires(post): scrollkeeper
|
||||||
Requires(postun): scrollkeeper
|
Requires(postun): scrollkeeper
|
||||||
@ -42,10 +40,6 @@ and GNOME.
|
|||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .docdir
|
|
||||||
|
|
||||||
aclocal
|
|
||||||
automake
|
|
||||||
|
|
||||||
# Move this doc file to avoid name collisions
|
# Move this doc file to avoid name collisions
|
||||||
mv doc/README doc/README.docs
|
mv doc/README doc/README.docs
|
||||||
@ -82,9 +76,12 @@ scrollkeeper-update -q
|
|||||||
%{_datadir}/sgml/gtk-doc/
|
%{_datadir}/sgml/gtk-doc/
|
||||||
%{_datadir}/pkgconfig/gtk-doc.pc
|
%{_datadir}/pkgconfig/gtk-doc.pc
|
||||||
%{_datadir}/gnome/help/gtk-doc-manual/
|
%{_datadir}/gnome/help/gtk-doc-manual/
|
||||||
%{_datadir}/omf/gtk-doc/
|
%{_datadir}/omf/gtk-doc-manual
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.11-1
|
||||||
|
- Update to 1.11
|
||||||
|
|
||||||
* Fri Jul 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.10-2
|
* Fri Jul 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.10-2
|
||||||
- fix license tag
|
- fix license tag
|
||||||
|
|
||||||
|
29
rebase.patch
29
rebase.patch
@ -1,29 +0,0 @@
|
|||||||
diff -up gtk-doc-1.9/gtk-doc.make.rebase gtk-doc-1.9/gtk-doc.make
|
|
||||||
--- gtk-doc-1.9/gtk-doc.make.rebase 2007-12-18 11:57:20.000000000 -0500
|
|
||||||
+++ gtk-doc-1.9/gtk-doc.make 2007-12-18 12:00:35.000000000 -0500
|
|
||||||
@@ -139,9 +139,8 @@ install-data-local:
|
|
||||||
done; \
|
|
||||||
echo '-- Installing $(srcdir)/html/index.sgml' ; \
|
|
||||||
$(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
|
|
||||||
- if test `which gtkdoc-rebase` != ""; then \
|
|
||||||
- gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
|
|
||||||
- fi \
|
|
||||||
+ (which gtkdoc-rebase >& /dev/null && \
|
|
||||||
+ gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR)) || : ; \
|
|
||||||
fi
|
|
||||||
|
|
||||||
|
|
||||||
diff -up gtk-doc-1.9/gtk-doc.notmpl.make.rebase gtk-doc-1.9/gtk-doc.notmpl.make
|
|
||||||
--- gtk-doc-1.9/gtk-doc.notmpl.make.rebase 2007-12-18 11:59:06.000000000 -0500
|
|
||||||
+++ gtk-doc-1.9/gtk-doc.notmpl.make 2007-12-18 11:59:56.000000000 -0500
|
|
||||||
@@ -124,9 +124,8 @@ install-data-local:
|
|
||||||
done; \
|
|
||||||
echo '-- Installing $(srcdir)/html/index.sgml' ; \
|
|
||||||
$(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
|
|
||||||
- if test `which gtkdoc-rebase` != ""; then \
|
|
||||||
+ which gtkdoc-rebase > /dev/null && \
|
|
||||||
gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
|
|
||||||
- fi \
|
|
||||||
fi
|
|
||||||
|
|
||||||
uninstall-local:
|
|
Loading…
Reference in New Issue
Block a user