Update to 1.22.12
This commit is contained in:
parent
b6a0616cc6
commit
e95e43281d
1
.gitignore
vendored
1
.gitignore
vendored
@ -76,3 +76,4 @@
|
||||
/gstreamer-1.18.2.tar.xz
|
||||
/gstreamer-1.18.4.tar.xz
|
||||
/gstreamer-1.22.1.tar.xz
|
||||
/gstreamer-1.22.12.tar.xz
|
||||
|
@ -1,26 +1,17 @@
|
||||
From 642d0d6fef226fb89eaecf0016f8e5e333b9023e Mon Sep 17 00:00:00 2001
|
||||
From 90d355aea6867f18c10431775f2d0cc52aa6c9d2 Mon Sep 17 00:00:00 2001
|
||||
From: Wim Taymans <wtaymans@redhat.com>
|
||||
Date: Tue, 23 Jun 2015 10:28:29 +0200
|
||||
Date: Tue, 5 Mar 2024 10:05:36 +0100
|
||||
Subject: [PATCH] gst-inspect: add mode to output RPM requires format
|
||||
|
||||
---
|
||||
tools/gst-inspect.c | 279 +++++++++++++++++++++++++++++++++++++++++---
|
||||
1 file changed, 263 insertions(+), 16 deletions(-)
|
||||
subprojects/gstreamer/tools/gst-inspect.c | 277 ++++++++++++++++++++--
|
||||
1 file changed, 262 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/tools/gst-inspect.c b/tools/gst-inspect.c
|
||||
index 8da042946..a057cba09 100644
|
||||
--- a/tools/gst-inspect.c
|
||||
+++ b/tools/gst-inspect.c
|
||||
@@ -394,7 +394,7 @@ print_object_properties_info (GObject * obj, GObjectClass * obj_class,
|
||||
|
||||
first_flag = TRUE;
|
||||
n_print ("%sflags%s: ", PROP_ATTR_NAME_COLOR, RESET_COLOR);
|
||||
- readable = ! !(param->flags & G_PARAM_READABLE);
|
||||
+ readable = !!(param->flags & G_PARAM_READABLE);
|
||||
if (readable && obj != NULL) {
|
||||
g_object_get_property (obj, param->name, &value);
|
||||
} else {
|
||||
@@ -1739,11 +1739,228 @@ print_tracer_info (GstPluginFeature * feature, gboolean print_names)
|
||||
diff --git a/subprojects/gstreamer/tools/gst-inspect.c b/subprojects/gstreamer/tools/gst-inspect.c
|
||||
index 10cba8ddb6..3cf75fe15e 100644
|
||||
--- a/subprojects/gstreamer/tools/gst-inspect.c
|
||||
+++ b/subprojects/gstreamer/tools/gst-inspect.c
|
||||
@@ -1904,11 +1904,228 @@ print_tracer_info (GstPluginFeature * feature, gboolean print_names)
|
||||
return 0;
|
||||
}
|
||||
|
||||
@ -250,7 +241,7 @@ index 8da042946..a057cba09 100644
|
||||
{
|
||||
GstPadDirection direction;
|
||||
const gchar *type_name;
|
||||
@@ -1769,6 +1986,13 @@ print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
|
||||
@@ -1934,6 +2151,13 @@ print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
|
||||
return;
|
||||
}
|
||||
|
||||
@ -264,7 +255,7 @@ index 8da042946..a057cba09 100644
|
||||
/* decoder/demuxer sink pads should always be static and there should only
|
||||
* be one, the same applies to encoders/muxers and source pads */
|
||||
static_templates = gst_element_factory_get_static_pad_templates (factory);
|
||||
@@ -1805,15 +2029,20 @@ print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
|
||||
@@ -1970,15 +2194,20 @@ print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
|
||||
gst_structure_remove_field (s, "rate");
|
||||
gst_structure_remove_field (s, "depth");
|
||||
gst_structure_remove_field (s, "clock-rate");
|
||||
@ -289,7 +280,7 @@ index 8da042946..a057cba09 100644
|
||||
{
|
||||
const gchar *const *protocols;
|
||||
|
||||
@@ -1822,13 +2051,19 @@ print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
|
||||
@@ -1987,13 +2216,19 @@ print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
|
||||
switch (gst_element_factory_get_uri_type (factory)) {
|
||||
case GST_URI_SINK:
|
||||
while (*protocols != NULL) {
|
||||
@ -311,7 +302,7 @@ index 8da042946..a057cba09 100644
|
||||
++protocols;
|
||||
}
|
||||
break;
|
||||
@@ -1839,7 +2074,7 @@ print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
|
||||
@@ -2004,7 +2239,7 @@ print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
|
||||
}
|
||||
|
||||
static void
|
||||
@ -320,7 +311,7 @@ index 8da042946..a057cba09 100644
|
||||
{
|
||||
GList *features, *l;
|
||||
|
||||
@@ -1858,11 +2093,15 @@ print_plugin_automatic_install_info (GstPlugin * plugin)
|
||||
@@ -2023,11 +2258,15 @@ print_plugin_automatic_install_info (GstPlugin * plugin)
|
||||
if (feature_plugin == plugin) {
|
||||
GstElementFactory *factory;
|
||||
|
||||
@ -339,7 +330,7 @@ index 8da042946..a057cba09 100644
|
||||
}
|
||||
if (feature_plugin)
|
||||
gst_object_unref (feature_plugin);
|
||||
@@ -1884,7 +2123,7 @@ print_all_plugin_automatic_install_info (void)
|
||||
@@ -2051,7 +2290,7 @@ print_all_plugin_automatic_install_info (void)
|
||||
plugin = (GstPlugin *) (plugins->data);
|
||||
plugins = g_list_next (plugins);
|
||||
|
||||
@ -348,15 +339,15 @@ index 8da042946..a057cba09 100644
|
||||
}
|
||||
gst_plugin_list_free (orig_plugins);
|
||||
}
|
||||
@@ -1951,6 +2190,7 @@ main (int argc, char *argv[])
|
||||
@@ -2137,6 +2376,7 @@ real_main (int argc, char *argv[])
|
||||
gboolean do_print_blacklist = FALSE;
|
||||
gboolean plugin_name = FALSE;
|
||||
gboolean print_aii = FALSE;
|
||||
+ gboolean print_aii_rpm = FALSE;
|
||||
gboolean uri_handlers = FALSE;
|
||||
gboolean check_exists = FALSE;
|
||||
gboolean color_always = FALSE;
|
||||
@@ -1972,6 +2212,9 @@ main (int argc, char *argv[])
|
||||
gboolean check_version = FALSE;
|
||||
@@ -2159,6 +2399,9 @@ real_main (int argc, char *argv[])
|
||||
"or all plugins provide.\n "
|
||||
"Useful in connection with external automatic plugin "
|
||||
"installation mechanisms"), NULL},
|
||||
@ -366,7 +357,7 @@ index 8da042946..a057cba09 100644
|
||||
{"plugin", '\0', 0, G_OPTION_ARG_NONE, &plugin_name,
|
||||
N_("List the plugin contents"), NULL},
|
||||
{"types", 't', 0, G_OPTION_ARG_STRING, &types,
|
||||
@@ -2135,7 +2378,7 @@ main (int argc, char *argv[])
|
||||
@@ -2338,7 +2581,7 @@ real_main (int argc, char *argv[])
|
||||
/* if there is such a plugin, print out info */
|
||||
if (plugin) {
|
||||
if (print_aii) {
|
||||
@ -375,7 +366,7 @@ index 8da042946..a057cba09 100644
|
||||
} else {
|
||||
print_plugin_info (plugin);
|
||||
print_plugin_features (plugin);
|
||||
@@ -2148,13 +2391,17 @@ main (int argc, char *argv[])
|
||||
@@ -2351,13 +2594,17 @@ real_main (int argc, char *argv[])
|
||||
|
||||
if (plugin) {
|
||||
if (print_aii) {
|
||||
@ -396,5 +387,5 @@ index 8da042946..a057cba09 100644
|
||||
exit_code = -1;
|
||||
goto done;
|
||||
--
|
||||
2.26.2
|
||||
2.45.2
|
||||
|
||||
|
110
gstreamer1.spec
110
gstreamer1.spec
@ -2,7 +2,7 @@
|
||||
|
||||
#global gitrel 140
|
||||
#global gitcommit a70055b58568f7304ba46bd8742232337013487b
|
||||
#global shortcommit %(c=%{gitcommit}; echo ${c:0:5})
|
||||
#global shortcommit %%(c=%%{gitcommit}; echo ${c:0:5})
|
||||
|
||||
%global _glib2 2.32.0
|
||||
%global _libxml2 2.4.0
|
||||
@ -16,11 +16,11 @@
|
||||
%endif
|
||||
|
||||
Name: gstreamer1
|
||||
Version: 1.22.1
|
||||
Release: 2%{?gitcommit:.git%{shortcommit}}%{?dist}
|
||||
Version: 1.22.12
|
||||
Release: 1%{?dist}
|
||||
Summary: GStreamer streaming media framework runtime
|
||||
|
||||
License: LGPLv2+
|
||||
License: LGPL-2.1-or-later
|
||||
URL: http://gstreamer.freedesktop.org/
|
||||
%if 0%{?gitrel}
|
||||
# git clone git://anongit.freedesktop.org/gstreamer/gstreamer
|
||||
@ -87,7 +87,7 @@ GStreamer streaming media framework.
|
||||
|
||||
%prep
|
||||
%setup -q -n gstreamer-%{version}
|
||||
%patch0 -p1 -b .rpm-provides
|
||||
%patch -P 0 -p3 -b .rpm-provides
|
||||
|
||||
%build
|
||||
%meson \
|
||||
@ -120,7 +120,12 @@ install -m0644 -D %{SOURCE2} $RPM_BUILD_ROOT%{_rpmconfigdir}/fileattrs/gstreamer
|
||||
%{_libdir}/libgstcontroller-%{majorminor}.so.*
|
||||
%{_libdir}/libgstnet-%{majorminor}.so.*
|
||||
|
||||
%{_libexecdir}/gstreamer-%{majorminor}/
|
||||
%dir %{_libexecdir}/gstreamer-%{majorminor}/
|
||||
%{_libexecdir}/gstreamer-%{majorminor}/gst-completion-helper
|
||||
%{_libexecdir}/gstreamer-%{majorminor}/gst-hotdoc-plugins-scanner
|
||||
%{_libexecdir}/gstreamer-%{majorminor}/gst-plugins-doc-cache-generator
|
||||
%{_libexecdir}/gstreamer-%{majorminor}/gst-plugin-scanner
|
||||
%attr(755,root,root) %caps(cap_net_bind_service,cap_net_admin,cap_sys_nice=ep) %{_libexecdir}/gstreamer-%{majorminor}/gst-ptp-helper
|
||||
|
||||
%dir %{_libdir}/gstreamer-%{majorminor}
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgstcoreelements.so
|
||||
@ -176,7 +181,7 @@ install -m0644 -D %{SOURCE2} $RPM_BUILD_ROOT%{_rpmconfigdir}/fileattrs/gstreamer
|
||||
|
||||
%{_datadir}/aclocal/gst-element-check-%{majorminor}.m4
|
||||
|
||||
%dir %{_datadir}/gstreamer-%{majorminor}/gdb/
|
||||
%dir %{_datadir}/gstreamer-%{majorminor}/gdb
|
||||
%{_datadir}/gstreamer-%{majorminor}/gdb/
|
||||
%{_datadir}/gdb/auto-load/
|
||||
|
||||
@ -195,18 +200,93 @@ install -m0644 -D %{SOURCE2} $RPM_BUILD_ROOT%{_rpmconfigdir}/fileattrs/gstreamer
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 12 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.1-2
|
||||
- Bump for rebuild
|
||||
* Fri Jun 14 2024 Wim Taymans <wtaymans@redhat.com> - 1.22.12-1
|
||||
- Update to 1.22.12
|
||||
|
||||
* Tue Mar 21 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.1-1
|
||||
* Thu Jan 25 2024 Gwyn Ciesla <gwync@protonmail.com> - 1.22.9-1
|
||||
- 1.22.9
|
||||
|
||||
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sat Jan 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Mon Dec 18 2023 Gwyn Ciesla <gwync@protonmail.com> - 1.22.8-1
|
||||
- 1.22.8
|
||||
|
||||
* Mon Nov 20 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.7-2
|
||||
- Set cap information correctly
|
||||
- Resolves: rhbz#2238703
|
||||
|
||||
* Mon Nov 13 2023 Gwyn Ciesla <gwync@protonmail.com> - 1.22.7-1
|
||||
- 1.22.7
|
||||
|
||||
* Wed Sep 20 2023 Gwyn Ciesla <gwync@protonmail.com> - 1.22.6-1
|
||||
- 1.22.6
|
||||
|
||||
* Fri Jul 21 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.5-1
|
||||
- Update to 1.22.5
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Tue Jun 20 2023 Gwyn Ciesla <gwync@protonmail.com> - 1.22.4-1
|
||||
- 1.22.4
|
||||
|
||||
* Thu Jun 8 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.3-2
|
||||
- Do setcap on gst-ptp-helper to give the right permissions.
|
||||
|
||||
* Thu May 25 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.3-1
|
||||
- Update to 1.22.3
|
||||
|
||||
* Thu Apr 13 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.2-1
|
||||
- Update to 1.22.2
|
||||
|
||||
* Mon Mar 13 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.1-1
|
||||
- Update to 1.22.1
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.18.4-4
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
* Tue Jan 24 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.0-1
|
||||
- Update to 1.22.0
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.18.4-3
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
* Fri Jan 20 2023 Wim Taymans <wtaymans@redhat.com> - 1.21.90-1
|
||||
- Update to 1.21.90
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.20.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Wed Jan 11 2023 Wim Taymans <wtaymans@redhat.com> - 1.20.5-1
|
||||
- Update to 1.20.5
|
||||
|
||||
* Thu Oct 13 2022 Wim Taymans <wtaymans@redhat.com> - 1.20.4-1
|
||||
- Update to 1.20.4
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.20.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Mon Jul 18 2022 Wim Taymans <wtaymans@redhat.com> - 1.20.3-1
|
||||
- Update to 1.20.3
|
||||
|
||||
* Fri Feb 4 2022 Wim Taymans <wtaymans@redhat.com> - 1.20.0-1
|
||||
- Update to 1.20.0
|
||||
|
||||
* Wed Jan 26 2022 Wim Taymans <wtaymans@redhat.com> - 1.19.3-3
|
||||
- Fix build, gtk_doc does not exist anymore.
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Thu Nov 11 2021 Wim Taymans <wtaymans@redhat.com> - 1.19.3-1
|
||||
- Update to 1.19.3
|
||||
|
||||
* Thu Sep 23 2021 Wim Taymans <wtaymans@redhat.com> - 1.19.2-1
|
||||
- Update to 1.19.2
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Thu Jun 03 2021 Wim Taymans <wtaymans@redhat.com> - 1.19.1-1
|
||||
- Update to 1.19.1
|
||||
|
||||
* Tue Apr 6 2021 Wim Taymans <wtaymans@redhat.com> - 1.18.4-2
|
||||
- Fix build options to disable libunwind and libdw
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gstreamer-1.22.1.tar.xz) = 3a02ffdaedebaa3624c76ee3c21d86b20ebfe51c1d14b8660ce96847a83747db0633fd6bd6bcf0274a72b9e167cc5c220ec55a1bf6632e9c075f16cd925bfe6e
|
||||
SHA512 (gstreamer-1.22.12.tar.xz) = 2443a337a97ac805267d683d049b5023281db54d0d9c561510cff478b0a13256078eb08b1dd89440d2348c84e6e64c8137ce8e6e7c131440a7bd3a8975ebe722
|
||||
|
Loading…
Reference in New Issue
Block a user