import gstreamer1-1.14.0-3.el8

This commit is contained in:
CentOS Sources 2019-05-07 06:27:06 -04:00 committed by Andrew Lukoshko
commit 10a6625bc7
7 changed files with 958 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/gstreamer-1.14.0.tar.xz

1
.gstreamer1.metadata Normal file
View File

@ -0,0 +1 @@
6ed978dff1d04c2b65e55c9e1c7c815ecd5c0e1f SOURCES/gstreamer-1.14.0.tar.xz

View File

@ -0,0 +1,41 @@
From b4ff2c8805221bcff6895c543cb019a817ad7104 Mon Sep 17 00:00:00 2001
From: Wim Taymans <wtaymans@redhat.com>
Date: Thu, 22 Feb 2018 09:52:03 +0100
Subject: [PATCH] avoid compilation errors with newer glib
Newest glib does type propagation. Do an explicit cast to the
right type to silence the compiler.
---
gst/gstchildproxy.c | 2 +-
gst/parse/grammar.y | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/gst/gstchildproxy.c b/gst/gstchildproxy.c
index ca5e47ea3..1bf983afa 100644
--- a/gst/gstchildproxy.c
+++ b/gst/gstchildproxy.c
@@ -209,7 +209,7 @@ gst_child_proxy_lookup (GstChildProxy * object, const gchar * name,
g_return_val_if_fail (GST_IS_CHILD_PROXY (object), FALSE);
g_return_val_if_fail (name != NULL, FALSE);
- obj = g_object_ref (object);
+ obj = G_OBJECT (g_object_ref (object));
current = names = g_strsplit (name, "::", -1);
/* find the owner of the property */
diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y
index bc4c3c1ed..0b3d04821 100644
--- a/gst/parse/grammar.y
+++ b/gst/parse/grammar.y
@@ -406,7 +406,7 @@ static void gst_parse_element_set (gchar *value, GstElement *element, graph_t *g
} else {
pspec = g_object_class_find_property (G_OBJECT_GET_CLASS (element), value);
if (pspec != NULL) {
- target = g_object_ref (element);
+ target = G_OBJECT(g_object_ref (element));
GST_CAT_LOG_OBJECT (GST_CAT_PIPELINE, target, "found %s property", value);
} else {
SET_ERROR (graph->error, GST_PARSE_ERROR_NO_SUCH_PROPERTY, \
--
2.14.3

View File

@ -0,0 +1,387 @@
From 7c0fb2de2921d15493d7353ae269140b17e8d88e Mon Sep 17 00:00:00 2001
From: Wim Taymans <wtaymans@redhat.com>
Date: Mon, 4 Jan 2016 11:39:33 +0100
Subject: [PATCH] inspect: Add RPM output format
---
tools/gst-inspect.c | 277 +++++++++++++++++++++++++++++++++++++++++++++++++---
1 file changed, 262 insertions(+), 15 deletions(-)
diff --git a/tools/gst-inspect.c b/tools/gst-inspect.c
index 89a1fab92..6d2369814 100644
--- a/tools/gst-inspect.c
+++ b/tools/gst-inspect.c
@@ -1524,7 +1524,224 @@ print_tracer_info (GstPluginFeature * feature, gboolean print_names)
}
static void
-print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
+print_gst_structure_append_field (GList * strings, const char *field)
+{
+ GList *s;
+
+ //g_message ("adding '%s' to the string", field);
+
+ for (s = strings; s != NULL; s = s->next) {
+ g_string_append (s->data, field);
+ }
+}
+
+static void
+print_gst_structure_append_field_index (GList * strings, const char *field,
+ guint num_items, guint offset)
+{
+ GList *s;
+ guint i;
+
+ //g_message ("adding '%s' to the string (num: %d offset: %d)", field, num_items, offset);
+
+ for (s = strings, i = 0; s != NULL; s = s->next, i++) {
+ if (i == offset) {
+ //g_message ("adding '%s' at '%d'", field, i);
+ g_string_append (s->data, field);
+ }
+ if (i == num_items)
+ i = 0;
+ }
+
+}
+
+static GList *
+print_gst_structure_dup_fields (GList * strings, guint num_items)
+{
+ guint new_items, i;
+
+ if (num_items == 1)
+ return strings;
+
+ //g_message ("creating %d new items", num_items);
+
+ new_items = g_list_length (strings) * (num_items - 1);
+ for (i = 0; i < new_items; i++) {
+ GString *s, *first;
+
+ first = strings->data;
+ s = g_string_new_len (first->str, first->len);
+ strings = g_list_prepend (strings, s);
+ }
+
+ return strings;
+}
+
+enum
+{
+ FIELD_VERSION = 0,
+ FIELD_LAYER,
+ FIELD_VARIANT,
+ FIELD_SYSTEMSTREAM
+};
+
+static int
+field_get_type (const char *field_name)
+{
+ if (strstr (field_name, "version") != NULL)
+ return FIELD_VERSION;
+ if (strcmp (field_name, "layer") == 0)
+ return FIELD_LAYER;
+ if (strcmp (field_name, "systemstream") == 0)
+ return FIELD_SYSTEMSTREAM;
+ if (strcmp (field_name, "variant") == 0)
+ return FIELD_VARIANT;
+
+ return -1;
+}
+
+static gint
+fields_type_compare (const char *a, const char *b)
+{
+ gint a_type, b_type;
+
+ a_type = field_get_type (a);
+ b_type = field_get_type (b);
+ if (a_type < b_type)
+ return -1;
+ if (b_type < a_type)
+ return 1;
+ return 0;
+}
+
+static void
+print_gst_structure_for_rpm (const char *type_name, GstStructure * s)
+{
+ guint i, num_fields;
+ const char *name;
+ GList *fields, *l, *strings;
+ GString *string;
+
+ name = gst_structure_get_name (s);
+ strings = NULL;
+ num_fields = gst_structure_n_fields (s);
+ fields = NULL;
+
+ for (i = 0; i < num_fields; i++) {
+ const char *field_name;
+
+ field_name = gst_structure_nth_field_name (s, i);
+ if (field_get_type (field_name) < 0) {
+ //g_message ("ignoring field named %s", field_name);
+ continue;
+ }
+
+ fields =
+ g_list_insert_sorted (fields, g_strdup (field_name),
+ (GCompareFunc) fields_type_compare);
+ }
+
+ /* Example:
+ * gstreamer1(decoder-video/mpeg)(mpegversion=1)()(64bit) */
+ string = g_string_new ("gstreamer1");
+ g_string_append_c (string, '(');
+ g_string_append (string, type_name);
+ g_string_append_c (string, '-');
+ g_string_append (string, name);
+ g_string_append_c (string, ')');
+
+ strings = g_list_append (strings, string);
+
+ for (l = fields; l != NULL; l = l->next) {
+ char *field_name;
+ GType type;
+
+ field_name = l->data;
+
+ type = gst_structure_get_field_type (s, field_name);
+ //g_message ("field is: %s, type: %s", field_name, g_type_name (type));
+
+ if (type == G_TYPE_INT) {
+ char *field;
+ int value;
+
+ gst_structure_get_int (s, field_name, &value);
+ field = g_strdup_printf ("(%s=%d)", field_name, value);
+ print_gst_structure_append_field (strings, field);
+ g_free (field);
+ } else if (type == G_TYPE_BOOLEAN) {
+ char *field;
+ int value;
+
+ gst_structure_get_boolean (s, field_name, &value);
+ field = g_strdup_printf ("(%s=%s)", field_name, value ? "true" : "false");
+ print_gst_structure_append_field (strings, field);
+ g_free (field);
+ } else if (type == GST_TYPE_INT_RANGE) {
+ const GValue *value;
+ int min, max;
+
+ value = gst_structure_get_value (s, field_name);
+ min = gst_value_get_int_range_min (value);
+ max = gst_value_get_int_range_max (value);
+
+ strings = print_gst_structure_dup_fields (strings, max - min + 1);
+
+ for (i = min; i <= max; i++) {
+ char *field;
+
+ field = g_strdup_printf ("(%s=%d)", field_name, i);
+ print_gst_structure_append_field_index (strings, field, max - min + 1,
+ i - min);
+ g_free (field);
+ }
+ } else if (type == GST_TYPE_LIST) {
+ const GValue *value;
+ int num_items;
+
+ value = gst_structure_get_value (s, field_name);
+ num_items = gst_value_list_get_size (value);
+
+ strings = print_gst_structure_dup_fields (strings, num_items);
+
+ for (i = 0; i < num_items; i++) {
+ char *field;
+ const GValue *item_value;
+
+ item_value = gst_value_list_get_value (value, i);
+ field = g_strdup_printf ("(%s=%d)", field_name,
+ g_value_get_int (item_value));
+ print_gst_structure_append_field_index (strings, field, num_items, i);
+ g_free (field);
+ }
+ } else if (type == G_TYPE_STRING) {
+ char *field;
+ const char *value;
+
+ value = gst_structure_get_string (s, field_name);
+ field = g_strdup_printf ("(%s=%s)", field_name, value);
+ print_gst_structure_append_field (strings, field);
+ g_free (field);
+ } else {
+ g_warning ("unhandled type! %s", g_type_name (type));
+ }
+
+ g_free (field_name);
+ }
+
+ g_list_free (fields);
+
+ for (l = strings; l != NULL; l = l->next) {
+ string = l->data;
+ g_print ("%s\n", string->str);
+ g_string_free (string, TRUE);
+ }
+ g_list_free (strings);
+}
+
+static void
+print_plugin_automatic_install_info_codecs (GstElementFactory * factory,
+ gboolean rpm_format)
{
GstPadDirection direction;
const gchar *type_name;
@@ -1550,6 +1767,13 @@ print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
return;
}
+ if (rpm_format) {
+ /* Ignore NONE ranked plugins */
+ if ((gst_plugin_feature_get_rank (GST_PLUGIN_FEATURE (factory))) ==
+ GST_RANK_NONE)
+ return;
+ }
+
/* decoder/demuxer sink pads should always be static and there should only
* be one, the same applies to encoders/muxers and source pads */
static_templates = gst_element_factory_get_static_pad_templates (factory);
@@ -1586,15 +1810,20 @@ print_plugin_automatic_install_info_codecs (GstElementFactory * factory)
gst_structure_remove_field (s, "rate");
gst_structure_remove_field (s, "depth");
gst_structure_remove_field (s, "clock-rate");
- s_str = gst_structure_to_string (s);
- g_print ("%s-%s\n", type_name, s_str);
- g_free (s_str);
+ if (!rpm_format) {
+ s_str = gst_structure_to_string (s);
+ g_print ("%s-%s\n", type_name, s_str);
+ g_free (s_str);
+ } else {
+ print_gst_structure_for_rpm (type_name, s);
+ }
}
gst_caps_unref (caps);
}
static void
-print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
+print_plugin_automatic_install_info_protocols (GstElementFactory * factory,
+ gboolean rpm_format)
{
const gchar *const *protocols;
@@ -1603,13 +1832,19 @@ print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
switch (gst_element_factory_get_uri_type (factory)) {
case GST_URI_SINK:
while (*protocols != NULL) {
- g_print ("urisink-%s\n", *protocols);
+ if (!rpm_format)
+ g_print ("urisink-%s\n", *protocols);
+ else
+ g_print ("gstreamer1(urisink-%s)\n", *protocols);
++protocols;
}
break;
case GST_URI_SRC:
while (*protocols != NULL) {
- g_print ("urisource-%s\n", *protocols);
+ if (!rpm_format)
+ g_print ("urisource-%s\n", *protocols);
+ else
+ g_print ("gstreamer1(urisource-%s)\n", *protocols);
++protocols;
}
break;
@@ -1620,7 +1855,7 @@ print_plugin_automatic_install_info_protocols (GstElementFactory * factory)
}
static void
-print_plugin_automatic_install_info (GstPlugin * plugin)
+print_plugin_automatic_install_info (GstPlugin * plugin, gboolean rpm_format)
{
GList *features, *l;
@@ -1639,11 +1874,15 @@ print_plugin_automatic_install_info (GstPlugin * plugin)
if (feature_plugin == plugin) {
GstElementFactory *factory;
- g_print ("element-%s\n", gst_plugin_feature_get_name (feature));
+ if (!rpm_format)
+ g_print ("element-%s\n", gst_plugin_feature_get_name (feature));
+ else
+ g_print ("gstreamer1(element-%s)\n",
+ gst_plugin_feature_get_name (feature));
factory = GST_ELEMENT_FACTORY (feature);
- print_plugin_automatic_install_info_protocols (factory);
- print_plugin_automatic_install_info_codecs (factory);
+ print_plugin_automatic_install_info_protocols (factory, rpm_format);
+ print_plugin_automatic_install_info_codecs (factory, rpm_format);
}
if (feature_plugin)
gst_object_unref (feature_plugin);
@@ -1665,7 +1904,7 @@ print_all_plugin_automatic_install_info (void)
plugin = (GstPlugin *) (plugins->data);
plugins = g_list_next (plugins);
- print_plugin_automatic_install_info (plugin);
+ print_plugin_automatic_install_info (plugin, FALSE);
}
gst_plugin_list_free (orig_plugins);
}
@@ -1677,6 +1916,7 @@ main (int argc, char *argv[])
gboolean do_print_blacklist = FALSE;
gboolean plugin_name = FALSE;
gboolean print_aii = FALSE;
+ gboolean print_aii_rpm = FALSE;
gboolean uri_handlers = FALSE;
gboolean check_exists = FALSE;
gchar *min_version = NULL;
@@ -1695,6 +1935,9 @@ main (int argc, char *argv[])
"or all plugins provide.\n "
"Useful in connection with external automatic plugin "
"installation mechanisms"), NULL},
+ {"rpm", '\0', 0, G_OPTION_ARG_NONE, &print_aii_rpm,
+ N_("Print the machine-parsable list of features of a plugin in RPM "
+ "Provides compatible-format"), NULL},
{"plugin", '\0', 0, G_OPTION_ARG_NONE, &plugin_name,
N_("List the plugin contents"), NULL},
{"types", 't', 0, G_OPTION_ARG_STRING, &types,
@@ -1825,7 +2068,7 @@ main (int argc, char *argv[])
/* if there is such a plugin, print out info */
if (plugin) {
if (print_aii) {
- print_plugin_automatic_install_info (plugin);
+ print_plugin_automatic_install_info (plugin, print_aii_rpm);
} else {
print_plugin_info (plugin);
print_plugin_features (plugin);
@@ -1838,13 +2081,17 @@ main (int argc, char *argv[])
if (plugin) {
if (print_aii) {
- print_plugin_automatic_install_info (plugin);
+ print_plugin_automatic_install_info (plugin, print_aii_rpm);
} else {
print_plugin_info (plugin);
print_plugin_features (plugin);
}
} else {
- g_printerr (_("Could not load plugin file: %s\n"), error->message);
+ if (!print_aii_rpm)
+ g_print (_("Could not load plugin file: %s\n"), error->message);
+ else
+ g_printerr (_("Could not load plugin file: %s\n"),
+ error->message);
g_clear_error (&error);
return -1;
}
--
2.14.3

2
SOURCES/gstreamer1.attr Normal file
View File

@ -0,0 +1,2 @@
%__gstreamer1_provides %{_rpmconfigdir}/gstreamer1.prov
%__gstreamer1_path ^%{_libdir}/gstreamer-1.*/.*\.so$

44
SOURCES/gstreamer1.prov Normal file
View File

@ -0,0 +1,44 @@
#!/bin/sh
#
# Script to install in:
# /usr/lib/rpm/redhat/find-provides.d
#
# Transform GStreamer auto install info into RPM provides
#
# Author: Bastien Nocera <hadess@hadess.net>
# Based on other provides scripts from RPM
#
filelist=`grep -e '.so$' | sed "s/['\"]/\\\&/g"`
# --- Alpha does not mark 64bit dependencies•
case `uname -m` in
alpha*) mark64="" ;;
*) mark64="()(64bit)" ;;
esac
solist=$(echo $filelist | grep "libgst" | \
xargs file -L 2>/dev/null | grep "ELF.*shared object" | cut -d: -f1 )
function getmark()
{
lib64=`if file -L $1 2>/dev/null | \
grep "ELF 64-bit" >/dev/null; then echo -n "$mark64"; fi`
}
function libdir()
{
buildlibdir=`dirname $1`
buildlibdir=`dirname $buildlibdir`
}
for so in $solist ; do
getmark $so
libdir $so
LD_LIBRARY_PATH=$buildlibdir gst-inspect-1.0 --print-plugin-auto-install-info --rpm $so 2> /dev/null | while read line ; do
echo -n "$line";
echo -n "$lib64"
echo
done
done

482
SPECS/gstreamer1.spec Normal file
View File

@ -0,0 +1,482 @@
%global majorminor 1.0
#global gitrel 140
#global gitcommit a70055b58568f7304ba46bd8742232337013487b
#global shortcommit %(c=%{gitcommit}; echo ${c:0:5})
%global _glib2 2.32.0
%global _libxml2 2.4.0
%global _gobject_introspection 1.31.1
Name: gstreamer1
Version: 1.14.0
Release: 3%{?gitcommit:.git%{shortcommit}}%{?dist}
Summary: GStreamer streaming media framework runtime
License: LGPLv2+
URL: http://gstreamer.freedesktop.org/
%if 0%{?gitrel}
# git clone git://anongit.freedesktop.org/gstreamer/gstreamer
# cd gstreamer; git reset --hard %{gitcommit}; ./autogen.sh; make; make distcheck
Source0: gstreamer-%{version}.tar.xz
%else
Source0: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
%endif
## For GStreamer RPM provides
Patch0: gstreamer-inspect-rpm-format.patch
Patch1: 0001-avoid-compilation-errors-with-newer-glib.patch
Source1: gstreamer1.prov
Source2: gstreamer1.attr
BuildRequires: glib2-devel >= %{_glib2}
BuildRequires: libxml2-devel >= %{_libxml2}
BuildRequires: gobject-introspection-devel >= %{_gobject_introspection}
BuildRequires: bison
BuildRequires: flex
BuildRequires: m4
BuildRequires: check-devel
BuildRequires: gtk-doc >= 1.3
BuildRequires: gettext
BuildRequires: pkgconfig
# ./autogen.sh deps
BuildRequires: automake gettext-devel libtool
BuildRequires: chrpath
### documentation requirements
BuildRequires: python3-devel
BuildRequires: openjade
BuildRequires: texlive-jadetex
BuildRequires: libxslt
BuildRequires: docbook-style-dsssl
BuildRequires: docbook-style-xsl
BuildRequires: docbook-utils
BuildRequires: transfig
BuildRequires: netpbm-progs
BuildRequires: texlive-dvips
BuildRequires: ghostscript
%description
GStreamer is a streaming media framework, based on graphs of filters which
operate on media data. Applications using this library can do anything
from real-time sound processing to playing videos, and just about anything
else media-related. Its plugin-based architecture means that new data
types or processing capabilities can be added simply by installing new
plugins.
%package devel
Summary: Libraries/include files for GStreamer streaming media framework
Requires: %{name}%{?isa} = %{version}-%{release}
Requires: glib2-devel%{?_isa} >= %{_glib2}
Requires: libxml2-devel%{?_isa} >= %{_libxml2}
Requires: check-devel
# file /usr/include/gstreamer-1.0/gst/base/gstaggregator.h conflicts between attempted installs of gstreamer1-plugins-bad-free-devel-1.12.4-3.fc28.x86_64 and gstreamer1-devel-1.13.1-1.fc29.x86_64
Conflicts: gstreamer1-plugins-bad-free-devel < 1.13
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%package devel-docs
Summary: Developer documentation for GStreamer streaming media framework
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
%description devel-docs
This %{name}-devel-docs contains developer documentation for the
GStreamer streaming media framework.
%prep
%setup -q -n gstreamer-%{version}
%patch0 -p1 -b .rpm-provides
%patch1 -p1 -b .0001
%build
NOCONFIGURE=1 \
./autogen.sh
%configure \
--with-package-name='Fedora GStreamer package' \
--with-package-origin='http://download.fedoraproject.org' \
--enable-gtk-doc \
--enable-debug \
--disable-fatal-warnings \
--disable-silent-rules \
--disable-tests --disable-examples
%make_build V=1
%install
%make_install
%find_lang gstreamer-%{majorminor}
# Clean out files that should not be part of the rpm.
find $RPM_BUILD_ROOT -name '*.la' -exec rm -fv {} ';'
find $RPM_BUILD_ROOT -name '*.a' -exec rm -fv {} ';'
# Add the provides script
install -m0755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_rpmconfigdir}/gstreamer1.prov
# Add the gstreamer plugin file attribute entry (rpm >= 4.9.0)
install -m0644 -D %{SOURCE2} $RPM_BUILD_ROOT%{_rpmconfigdir}/fileattrs/gstreamer1.attr
%ldconfig_scriptlets
%files -f gstreamer-%{majorminor}.lang
%license COPYING
%doc AUTHORS NEWS README RELEASE
%{_libdir}/libgstreamer-%{majorminor}.so.*
%{_libdir}/libgstbase-%{majorminor}.so.*
%{_libdir}/libgstcheck-%{majorminor}.so.*
%{_libdir}/libgstcontroller-%{majorminor}.so.*
%{_libdir}/libgstnet-%{majorminor}.so.*
%{_libexecdir}/gstreamer-%{majorminor}/
%dir %{_libdir}/gstreamer-%{majorminor}
%{_libdir}/gstreamer-%{majorminor}/libgstcoreelements.so
%{_libdir}/gstreamer-%{majorminor}/libgstcoretracers.so
%{_libdir}/girepository-1.0/Gst-%{majorminor}.typelib
%{_libdir}/girepository-1.0/GstBase-%{majorminor}.typelib
%{_libdir}/girepository-1.0/GstCheck-%{majorminor}.typelib
%{_libdir}/girepository-1.0/GstController-%{majorminor}.typelib
%{_libdir}/girepository-1.0/GstNet-%{majorminor}.typelib
%{_bindir}/gst-inspect-%{majorminor}
%{_bindir}/gst-launch-%{majorminor}
%{_bindir}/gst-stats-%{majorminor}
%{_bindir}/gst-typefind-%{majorminor}
%{_rpmconfigdir}/gstreamer1.prov
%{_rpmconfigdir}/fileattrs/gstreamer1.attr
%doc %{_mandir}/man1/gst-inspect-%{majorminor}.*
%doc %{_mandir}/man1/gst-launch-%{majorminor}.*
%doc %{_mandir}/man1/gst-stats-%{majorminor}.*
%doc %{_mandir}/man1/gst-typefind-%{majorminor}.*
%{_datadir}/bash-completion/completions/gst-inspect-1.0
%{_datadir}/bash-completion/completions/gst-launch-1.0
%{_datadir}/bash-completion/helpers/gst
%files devel
%dir %{_includedir}/gstreamer-%{majorminor}
%dir %{_includedir}/gstreamer-%{majorminor}/gst
%dir %{_includedir}/gstreamer-%{majorminor}/gst/base
%dir %{_includedir}/gstreamer-%{majorminor}/gst/check
%dir %{_includedir}/gstreamer-%{majorminor}/gst/controller
%dir %{_includedir}/gstreamer-%{majorminor}/gst/net
%{_includedir}/gstreamer-%{majorminor}/gst/*.h
%{_includedir}/gstreamer-%{majorminor}/gst/base/*.h
%{_includedir}/gstreamer-%{majorminor}/gst/check/*.h
%{_includedir}/gstreamer-%{majorminor}/gst/controller/*.h
%{_includedir}/gstreamer-%{majorminor}/gst/net/*.h
%{_libdir}/libgstreamer-%{majorminor}.so
%{_libdir}/libgstbase-%{majorminor}.so
%{_libdir}/libgstcheck-%{majorminor}.so
%{_libdir}/libgstcontroller-%{majorminor}.so
%{_libdir}/libgstnet-%{majorminor}.so
%{_datadir}/gir-1.0/Gst-%{majorminor}.gir
%{_datadir}/gir-1.0/GstBase-%{majorminor}.gir
%{_datadir}/gir-1.0/GstCheck-%{majorminor}.gir
%{_datadir}/gir-1.0/GstController-%{majorminor}.gir
%{_datadir}/gir-1.0/GstNet-%{majorminor}.gir
%{_datadir}/aclocal/gst-element-check-%{majorminor}.m4
%{_libdir}/pkgconfig/gstreamer-%{majorminor}.pc
%{_libdir}/pkgconfig/gstreamer-base-%{majorminor}.pc
%{_libdir}/pkgconfig/gstreamer-controller-%{majorminor}.pc
%{_libdir}/pkgconfig/gstreamer-check-%{majorminor}.pc
%{_libdir}/pkgconfig/gstreamer-net-%{majorminor}.pc
%files devel-docs
%doc %{_datadir}/gtk-doc/html/gstreamer-%{majorminor}
%doc %{_datadir}/gtk-doc/html/gstreamer-libs-%{majorminor}
%doc %{_datadir}/gtk-doc/html/gstreamer-plugins-%{majorminor}
%changelog
* Fri Jun 29 2018 Charalampos Stratakis <cstratak@redhat.com> - 1.14.0-3
- Use python3 for docs generation
* Fri Jun 15 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.0-2
- Remove (obsolete since 1.2.0) xfig build dependency.
* Tue Mar 20 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.0-1
- Update to 1.14.0
* Wed Mar 14 2018 Wim Taymans <wtaymans@redhat.com> - 1.13.91-1
- Update to 1.13.91
- fix doc dependencies
* Mon Mar 05 2018 Wim Taymans <wtaymans@redhat.com> - 1.13.90-1
- Update to 1.13.90
* Fri Feb 23 2018 Rex Dieter <rdieter@fedoraproject.org> - 1.13.1-3
- %%build: --disable-fatal-warnings --disable-silent-rules
- fix rpath harder
- use %%ldconfig_scriptlets, %%make_build, %%make_install
- -devel: tighten deps with %%{_isa}
* Fri Feb 23 2018 Rex Dieter <rdieter@fedoraproject.org> - 1.13.1-2
- -devel: Conflicts: gstreamer1-plugins-bad-free-devel < 1.13
* Thu Feb 22 2018 Wim Taymans <wtaymans@redhat.com> - 1.13.1-1
- Update to 1.13.1
- Update rpm patch
- Fix compiler error
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Mon Dec 11 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.4-1
- Update to 1.12.4
* Fri Oct 13 2017 Troy Dawson <tdawson@redhat.com> - 1.12.3-2
- Cleanup spec file conditionals
* Tue Sep 19 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.3-1
- Update to 1.12.3
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Mon Jul 17 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.2-1
- Update to 1.12.2
* Tue Jun 20 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.1-1
- Update to 1.12.1
- Add gst-stats manpage
* Wed May 10 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.0-1
- Update to 1.12.0
* Fri Apr 28 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.91-1
- Update to 1.11.91
* Tue Apr 11 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.90-1
- Update to 1.11.90
* Thu Mar 30 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.2-2
- rebuild for https://github.com/UnitedRPMs/packages/issues/106#issuecomment-290404434
* Fri Feb 24 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.2-1
- Update to 1.11.2
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- fix build
* Fri Jan 13 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.1-1
- Update to 1.11.1
- update rpm patch
* Mon Dec 05 2016 Wim Taymans <wtaymans@redhat.com> - 1.10.2-1
- Update to 1.10.2
* Mon Nov 28 2016 Wim Taymans <wtaymans@redhat.com> - 1.10.1-1
- Update to 1.10.1
* Thu Nov 3 2016 Wim Taymans <wtaymans@redhat.com> - 1.10.0-1
- Update to 1.10.0
* Fri Sep 30 2016 Wim Taymans <wtaymans@redhat.com> - 1.9.90-1
- Update to 1.9.90
- remove obsolete patches
* Thu Sep 8 2016 Peter Robinson <pbrobinson@fedoraproject.org> 1.9.2-3
- fix build on Power64
* Thu Sep 01 2016 Wim Taymans <wtaymans@redhat.com> - 1.9.2-2
- fix build on s390x
* Thu Sep 01 2016 Wim Taymans <wtaymans@redhat.com> - 1.9.2-1
- Update to 1.9.2
- gstconfig.h was moved to normal include dir
* Thu Jul 07 2016 Wim Taymans <wtaymans@redhat.com> - 1.9.1-1
- Update to 1.9.1
* Thu Jun 09 2016 Wim Taymans <wtaymans@redhat.com> - 1.8.2-1
- Update to 1.8.2
* Thu Apr 21 2016 Wim Taymans <wtaymans@redhat.com> - 1.8.1-1
- Update to 1.8.1
* Thu Mar 24 2016 Wim Taymans <wtaymans@redhat.com> - 1.8.0-1
- Update to 1.8.0
* Wed Mar 16 2016 Wim Taymans <wtaymans@redhat.com> - 1.7.91-1
- Update to 1.7.91
* Wed Mar 02 2016 Wim Taymans <wtaymans@redhat.com> - 1.7.90-1
- Update to 1.7.90
* Fri Feb 19 2016 Wim Taymans <wtaymans@redhat.com> - 1.7.2-1
- Update to 1.7.2
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Mon Jan 4 2016 Wim Taymans <wtaymans@redhat.com> - 1.7.1-1
- Update to 1.7.1
- update rpm inspect patch
- add gst-stats
- add core traces
* Tue Dec 15 2015 Wim Taymans <wtaymans@redhat.com> - 1.6.2-1
- Update to 1.6.2
* Mon Nov 2 2015 Wim Taymans <wtaymans@redhat.com> - 1.6.1-1
- Update to 1.6.1
* Sat Sep 26 2015 Kalev Lember <klember@redhat.com> - 1.6.0-2
- Remove lib64 rpaths from newly added binaries
* Sat Sep 26 2015 Kalev Lember <klember@redhat.com> - 1.6.0-1
- Update to 1.6.0
- Use license macro for COPYING
* Mon Sep 21 2015 Wim Taymans <wtaymans@redhat.com> - 1.5.91-1
- Update to 1.5.91
* Wed Aug 19 2015 Wim Taymans <wtaymans@redhat.com> - 1.5.90-1
- Update to 1.5.90
* Thu Jun 25 2015 Wim Taymans <wtaymans@redhat.com> - 1.5.2-1
- Update to 1.5.2
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Tue May 5 2015 Wim Taymans <wtaymans@redhat.com> - 1.5.1-1
- Update to 1.5.1
- add new bash-completion scripts
- gstconfig.h got moved
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.4.5-2
- Rebuilt for Fedora 23 Change
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
* Wed Jan 28 2015 Bastien Nocera <bnocera@redhat.com> 1.4.5-1
- Update to 1.4.5
* Fri Nov 14 2014 Kalev Lember <kalevlember@gmail.com> - 1.4.4-1
- Update to 1.4.4
* Mon Sep 22 2014 Wim Taymans <wtaymans@redhat.com> - 1.4.2-1
- Update to 1.4.2
* Fri Aug 29 2014 Wim Taymans <wtaymans@redhat.com> - 1.4.1-1
- Update to 1.4.1
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Tue Jul 22 2014 Kalev Lember <kalevlember@gmail.com> - 1.4.0-2
- Rebuilt for gobject-introspection 1.41.4
* Tue Jul 22 2014 Wim Taymans <wtaymans@redhat.com> - 1.4.0-1
- Update to 1.4.0
* Fri Jul 11 2014 Wim Taymans <wtaymans@redhat.com> - 1.3.91-1
- Update to 1.3.91
* Mon Jun 30 2014 Richard Hughes <rhughes@redhat.com> - 1.3.90-1
- Update to 1.3.90
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sun Apr 20 2014 Brian Pepple <bpepple@fedoraproject.org> - 1.2.4-1
- Update to 1.2.4.
* Mon Feb 10 2014 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-1
- Update to 1.2.3.
* Fri Dec 27 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-1
- Update to 1.2.2.
* Mon Nov 11 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-1
- Update to 1.2.1.
* Tue Sep 24 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-1
- Update to 1.2.0.
* Thu Sep 19 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.1.90-1
- Update to 1.1.90.
* Wed Aug 28 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.1.4-1
- Update to 1.1.4.
* Mon Jul 29 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.1.3-1
- Update to 1.1.3.
* Fri Jul 12 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.1.2-1
- Update to 1.1.2.
* Fri Apr 26 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.0.7-1
- Update to 1.0.7.
* Wed Mar 27 2013 Adam Jackson <ajax@redhat.com>
- Tweak BRs for RHEL
* Fri Mar 22 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.0.6-1
- Update to 1.0.6.
- Remove BR on PyXML.
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Tue Jan 8 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-1
- Update to 1.0.5.
* Wed Dec 19 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-1
- Update to 1.0.4
* Wed Nov 21 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.3-1
- Update to 1.0.3
* Thu Oct 25 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.2-1
- Update to 1.0.2.
* Sun Oct 7 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.1-1
- Update to 1.0.1
* Mon Oct 1 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.0.0-2
- Enable verbose build
* Mon Sep 24 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.0-1
- Update to 1.0.0.
* Wed Sep 19 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.99-1
- Update to 0.11.99
* Fri Sep 14 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.94-1
- Update to 0.11.94.
* Sat Sep 8 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.93-2
- Add patch to gst-inspect to generate RPM provides
- Add RPM find-provides script
* Tue Aug 14 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.93-1
- Update to 0.11.93.
- Bump minimum version of glib2 needed.
* Fri Aug 3 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.92-2
- Use %%global instead of %%define.
- Remove rpath.
* Tue Jul 17 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.92-1
- Initial Fedora spec file.