Update to 1.18.0
Enable opencv
This commit is contained in:
parent
8c1b965e33
commit
98015e056c
1
.gitignore
vendored
1
.gitignore
vendored
@ -70,3 +70,4 @@
|
||||
/gst-plugins-bad-free-1.17.1.tar.xz
|
||||
/gst-plugins-bad-free-1.17.2.tar.xz
|
||||
/gst-plugins-bad-free-1.17.90.tar.xz
|
||||
/gst-plugins-bad-free-1.18.0.tar.xz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 2a24c2d09eb2c1245caed059610f3b1b20479fbc Mon Sep 17 00:00:00 2001
|
||||
From: Wim Taymans <wtaymans@redhat.com>
|
||||
Date: Fri, 21 Aug 2020 16:28:42 +0200
|
||||
Subject: [PATCH] vulkan: fix the enumtypes install path
|
||||
|
||||
---
|
||||
gst-libs/gst/vulkan/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gst-libs/gst/vulkan/meson.build b/gst-libs/gst/vulkan/meson.build
|
||||
index 52a636898..f3688381b 100644
|
||||
--- a/gst-libs/gst/vulkan/meson.build
|
||||
+++ b/gst-libs/gst/vulkan/meson.build
|
||||
@@ -295,7 +295,7 @@ vulkan_enumtypes_h = custom_target('gstvulkanenum_h',
|
||||
output : 'vulkan-enumtypes.h',
|
||||
input : vulkan_headers,
|
||||
install : true,
|
||||
- install_dir : join_paths(get_option('includedir'), 'include/gstreamer-1.0/gst/vulkan/'),
|
||||
+ install_dir : join_paths(get_option('includedir'), 'gstreamer-1.0/gst/vulkan/'),
|
||||
command : [mkenums, glib_mkenums, '@OUTPUT@', '@INPUT@'])
|
||||
|
||||
vulkan_enumtypes_c = custom_target('gstvulkanenum_c',
|
||||
--
|
||||
2.26.2
|
||||
|
@ -13,7 +13,7 @@
|
||||
#global shortcommit %(c=%{gitcommit}; echo ${c:0:5})
|
||||
|
||||
Name: gstreamer1-plugins-bad-free
|
||||
Version: 1.17.90
|
||||
Version: 1.18.0
|
||||
Release: 1%{?gitcommit:.git%{shortcommit}}%{?dist}
|
||||
Summary: GStreamer streaming media framework "bad" plugins
|
||||
|
||||
@ -31,8 +31,6 @@ URL: http://gstreamer.freedesktop.org/
|
||||
Source0: gst-plugins-bad-free-%{version}.tar.xz
|
||||
Source1: gst-p-bad-cleanup.sh
|
||||
|
||||
Patch0: 0001-vulkan-fix-the-enumtypes-install-path.patch
|
||||
|
||||
BuildRequires: meson >= 0.48.0
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gstreamer1-devel >= %{version}
|
||||
@ -118,7 +116,7 @@ BuildRequires: libofa-devel
|
||||
BuildRequires: libvdpau-devel
|
||||
BuildRequires: libva-devel
|
||||
BuildRequires: openal-soft-devel
|
||||
#BuildRequires: opencv-devel
|
||||
BuildRequires: opencv-devel
|
||||
BuildRequires: openjpeg2-devel
|
||||
BuildRequires: pkgconfig(spandsp) >= 0.0.6
|
||||
## Plugins not ported
|
||||
@ -220,7 +218,6 @@ aren't tested well enough, or the code is not of good enough quality.
|
||||
|
||||
%prep
|
||||
%setup -q -n gst-plugins-bad-%{version}
|
||||
%patch0 -p1 -b .0001
|
||||
|
||||
%build
|
||||
%meson \
|
||||
@ -235,14 +232,14 @@ aren't tested well enough, or the code is not of good enough quality.
|
||||
%{!?with_extras:-D ttml=disabled -D kate=disabled } \
|
||||
%{!?with_extras:-D modplug=disabled -D ofa=disabled } \
|
||||
%{!?with_extras:-D vdpau=disabled -D openal=disabled } \
|
||||
%{!?with_extras:-D opencv=disabled -D openjpeg=disabled } \
|
||||
%{!?with_extras:-D openjpeg=disabled } \
|
||||
%{!?with_extras:-D wildmidi=disabled -D zbar=disabled } \
|
||||
%{!?with_extras:-D gme=disabled -D lv2=disabled } \
|
||||
-D doc=disabled -D magicleap=disabled -D msdk=disabled \
|
||||
-D dts=disabled -D faac=disabled -D faad=disabled \
|
||||
-D libmms=disabled -D mpeg2enc=disabled -D mplex=disabled \
|
||||
-D neon=disabled -D rtmp=disabled -D rtmp2=disabled \
|
||||
-D flite=disabled -D sbc=disabled -D opencv=disabled \
|
||||
-D flite=disabled -D sbc=disabled \
|
||||
%{!?with_extras:-D spandsp=disabled -D va=disabled } \
|
||||
-D voamrwbenc=disabled -D x265=disabled \
|
||||
-D dvbsuboverlay=disabled -D dvdspu=disabled -D siren=disabled \
|
||||
@ -348,6 +345,7 @@ rm $RPM_BUILD_ROOT%{_bindir}/playout
|
||||
%{_libdir}/libgstinsertbin-%{majorminor}.so.*
|
||||
%{_libdir}/libgstisoff-%{majorminor}.so.*
|
||||
%{_libdir}/libgstmpegts-%{majorminor}.so.*
|
||||
%{_libdir}/libgstopencv-%{majorminor}.so.*
|
||||
%{_libdir}/libgstplayer-%{majorminor}.so.*
|
||||
%{_libdir}/libgstphotography-%{majorminor}.so.*
|
||||
%{_libdir}/libgstsctp-%{majorminor}.so.*
|
||||
@ -504,7 +502,7 @@ rm $RPM_BUILD_ROOT%{_bindir}/playout
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgstofa.so
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgstopenal.so
|
||||
#{_libdir}/gstreamer-%{majorminor}/libgstopencv.so
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgstopencv.so
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgstopenexr.so
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgstopenjpeg.so
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgstspandsp.so
|
||||
@ -548,6 +546,7 @@ rm $RPM_BUILD_ROOT%{_bindir}/playout
|
||||
%{_libdir}/libgstinsertbin-%{majorminor}.so
|
||||
%{_libdir}/libgstisoff-%{majorminor}.so
|
||||
%{_libdir}/libgstmpegts-%{majorminor}.so
|
||||
%{_libdir}/libgstopencv-%{majorminor}.so
|
||||
%{_libdir}/libgstplayer-%{majorminor}.so
|
||||
%{_libdir}/libgstphotography-%{majorminor}.so
|
||||
%{_libdir}/libgstsctp-%{majorminor}.so
|
||||
@ -566,6 +565,7 @@ rm $RPM_BUILD_ROOT%{_bindir}/playout
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/interfaces/photography*
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/isoff/
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/mpegts
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/opencv
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/player
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/sctp
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/transcoder
|
||||
@ -589,6 +589,10 @@ rm $RPM_BUILD_ROOT%{_bindir}/playout
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Sep 8 2020 Wim Taymans <wtaymans@redhat.com> - 1.18.0-1
|
||||
- Update to 1.18.0
|
||||
- Enable opencv
|
||||
|
||||
* Fri Aug 21 2020 Wim Taymans <wtaymans@redhat.com> - 1.17.90-1
|
||||
- Update to 1.17.90
|
||||
- Remove obsolete -bad-transcoder .pc file
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gst-plugins-bad-free-1.17.90.tar.xz) = cdf48ede90a5878bb249b3ebc4d043922bcf48c9ead09a62706c592bf8e502da1cadc8b7a8fb2751502ad508199968fa12e9404bf58121c9fcd985cacd207a67
|
||||
SHA512 (gst-plugins-bad-free-1.18.0.tar.xz) = 97246c92fccd795fcf231476d974808b1f7ec340f2632fe4456ded47c3898ff4eaa01ddb8b95ad859f3ca63e7095c518572bc1792d6c1a84368f69cbabc4df00
|
||||
|
Loading…
Reference in New Issue
Block a user