update to 1.0.20 (resolves rhbz#2103499)

This commit is contained in:
Dominik 'Rathann' Mierzejewski 2022-07-19 10:32:45 +02:00
parent b63d7643ab
commit e1a196f31e
4 changed files with 30 additions and 31 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@ gsm-1.0.13.tar.gz
/gsm-1.0.17.tar.gz /gsm-1.0.17.tar.gz
/gsm-1.0.18.tar.gz /gsm-1.0.18.tar.gz
/gsm-1.0.19.tar.gz /gsm-1.0.19.tar.gz
/gsm-1.0.20.tar.gz

View File

@ -1,6 +1,6 @@
diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile diff -up gsm-1.0-pl20/Makefile.mk gsm-1.0-pl20/Makefile
--- gsm-1.0-pl17/Makefile.mk 2017-06-28 02:24:24.000000000 +0200 --- gsm-1.0-pl20/Makefile.mk 2022-07-03 19:49:29.000000000 +0200
+++ gsm-1.0-pl17/Makefile 2017-06-29 13:18:44.138719902 +0200 +++ gsm-1.0-pl20/Makefile 2022-07-19 10:20:35.123611479 +0200
@@ -44,13 +44,17 @@ WAV49 = -DWAV49 @@ -44,13 +44,17 @@ WAV49 = -DWAV49
# CCFLAGS = -c -O # CCFLAGS = -c -O
@ -20,7 +20,7 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
# If your compiler needs additional flags/libraries, regardless of # If your compiler needs additional flags/libraries, regardless of
# the source compiled, configure them here. # the source compiled, configure them here.
@@ -81,7 +85,7 @@ INSTALL_ROOT = @@ -84,7 +88,7 @@ VERSION = 1.0-pl20
GSM_INSTALL_ROOT = $(INSTALL_ROOT) GSM_INSTALL_ROOT = $(INSTALL_ROOT)
GSM_INSTALL_LIB = $(GSM_INSTALL_ROOT)/lib GSM_INSTALL_LIB = $(GSM_INSTALL_ROOT)/lib
GSM_INSTALL_INC = $(GSM_INSTALL_ROOT)/inc GSM_INSTALL_INC = $(GSM_INSTALL_ROOT)/inc
@ -29,7 +29,7 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
# Where do you want to install the toast binaries and their manpage? # Where do you want to install the toast binaries and their manpage?
@@ -91,16 +95,16 @@ GSM_INSTALL_MAN = $(GSM_INSTALL_ROOT)/ma @@ -94,12 +98,12 @@ GSM_INSTALL_MAN = $(GSM_INSTALL_ROOT)/ma
TOAST_INSTALL_ROOT = $(INSTALL_ROOT) TOAST_INSTALL_ROOT = $(INSTALL_ROOT)
TOAST_INSTALL_BIN = $(TOAST_INSTALL_ROOT)/bin TOAST_INSTALL_BIN = $(TOAST_INSTALL_ROOT)/bin
@ -44,12 +44,7 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
BASENAME = basename BASENAME = basename
AR = ar AR = ar
ARFLAGS = cr ARFLAGS = cr
-RMFLAGS = @@ -143,6 +147,7 @@ LFLAGS = $(LDFLAGS) $(LDINC)
+RMFLAGS = -f
FIND = find
COMPRESS = gzip
COMPRESSFLAGS =
@@ -140,6 +144,7 @@ LFLAGS = $(LDFLAGS) $(LDINC)
# Targets # Targets
LIBGSM = $(LIB)/libgsm.a LIBGSM = $(LIB)/libgsm.a
@ -57,7 +52,7 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
TOAST = $(BIN)/toast TOAST = $(BIN)/toast
UNTOAST = $(BIN)/untoast UNTOAST = $(BIN)/untoast
@@ -257,7 +262,9 @@ STUFF = ChangeLog \ @@ -260,7 +265,9 @@ STUFF = ChangeLog \
# Install targets # Install targets
GSM_INSTALL_TARGETS = \ GSM_INSTALL_TARGETS = \
@ -68,7 +63,7 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
$(GSM_INSTALL_INC)/gsm.h \ $(GSM_INSTALL_INC)/gsm.h \
$(GSM_INSTALL_MAN)/gsm.3 \ $(GSM_INSTALL_MAN)/gsm.3 \
$(GSM_INSTALL_MAN)/gsm_explode.3 \ $(GSM_INSTALL_MAN)/gsm_explode.3 \
@@ -279,7 +286,7 @@ TOAST_INSTALL_TARGETS = \ @@ -282,7 +289,7 @@ TOAST_INSTALL_TARGETS = \
# Target rules # Target rules
@ -77,7 +72,7 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
@-echo $(ROOT): Done. @-echo $(ROOT): Done.
tst: $(TST)/lin2cod $(TST)/cod2lin $(TOAST) $(TST)/test-result tst: $(TST)/lin2cod $(TST)/cod2lin $(TOAST) $(TST)/test-result
@@ -299,24 +306,32 @@ install: toastinstall gsminstall @@ -302,24 +309,32 @@ install: toastinstall gsminstall
# The basic API: libgsm # The basic API: libgsm
@ -115,70 +110,70 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
# The local bin and lib directories # The local bin and lib directories
@@ -352,8 +367,7 @@ toastuninstall: @@ -355,8 +370,7 @@ toastuninstall:
$(TOAST_INSTALL_BIN)/toast: $(TOAST) $(TOAST_INSTALL_BIN)/toast: $(TOAST)
-rm $@ -rm $(RMFLAGS) $@
- cp $(TOAST) $@ - cp $(TOAST) $@
- chmod 755 $@ - chmod 755 $@
+ install -pm755 $(TOAST) $@ + install -pm755 $(TOAST) $@
$(TOAST_INSTALL_BIN)/untoast: $(TOAST_INSTALL_BIN)/toast $(TOAST_INSTALL_BIN)/untoast: $(TOAST_INSTALL_BIN)/toast
-rm $@ -rm $(RMFLAGS) $@
@@ -365,39 +379,43 @@ $(TOAST_INSTALL_BIN)/tcat: $(TOAST_INSTA @@ -368,39 +382,43 @@ $(TOAST_INSTALL_BIN)/tcat: $(TOAST_INSTA
$(TOAST_INSTALL_MAN)/toast.1: $(MAN)/toast.1 $(TOAST_INSTALL_MAN)/toast.1: $(MAN)/toast.1
-rm $@ -rm $(RMFLAGS) $@
- cp $? $@ - cp $? $@
- chmod 444 $@ - chmod 444 $@
+ install -pm644 $? $@ + install -pm644 $? $@
$(GSM_INSTALL_MAN)/gsm.3: $(MAN)/gsm.3 $(GSM_INSTALL_MAN)/gsm.3: $(MAN)/gsm.3
-rm $@ -rm $(RMFLAGS) $@
- cp $? $@ - cp $? $@
- chmod 444 $@ - chmod 444 $@
+ install -pm644 $? $@ + install -pm644 $? $@
$(GSM_INSTALL_MAN)/gsm_option.3: $(MAN)/gsm_option.3 $(GSM_INSTALL_MAN)/gsm_option.3: $(MAN)/gsm_option.3
-rm $@ -rm $(RMFLAGS) $@
- cp $? $@ - cp $? $@
- chmod 444 $@ - chmod 444 $@
+ install -pm644 $? $@ + install -pm644 $? $@
$(GSM_INSTALL_MAN)/gsm_explode.3: $(MAN)/gsm_explode.3 $(GSM_INSTALL_MAN)/gsm_explode.3: $(MAN)/gsm_explode.3
-rm $@ -rm $(RMFLAGS) $@
- cp $? $@ - cp $? $@
- chmod 444 $@ - chmod 444 $@
+ install -pm644 $? $@ + install -pm644 $? $@
$(GSM_INSTALL_MAN)/gsm_print.3: $(MAN)/gsm_print.3 $(GSM_INSTALL_MAN)/gsm_print.3: $(MAN)/gsm_print.3
-rm $@ -rm $(RMFLAGS) $@
- cp $? $@ - cp $? $@
- chmod 444 $@ - chmod 444 $@
+ install -pm644 $? $@ + install -pm644 $? $@
$(GSM_INSTALL_INC)/gsm.h: $(INC)/gsm.h $(GSM_INSTALL_INC)/gsm.h: $(INC)/gsm.h
-rm $@ -rm $(RMFLAGS) $@
- cp $? $@ - cp $? $@
- chmod 444 $@ - chmod 444 $@
+ install -pm644 $? $@ + install -pm644 $? $@
$(GSM_INSTALL_LIB)/libgsm.a: $(LIBGSM) $(GSM_INSTALL_LIB)/libgsm.a: $(LIBGSM)
-rm $@ -rm $(RMFLAGS) $@
- cp $? $@ - cp $? $@
- chmod 444 $@ - chmod 444 $@
+ install -pm644 $? $@ + install -pm644 $? $@
+$(GSM_INSTALL_LIB)/libgsm.so.$(SO_VER): $(LIBGSMSO).$(SO_VER) +$(GSM_INSTALL_LIB)/libgsm.so.$(SO_VER): $(LIBGSMSO).$(SO_VER)
+ -rm $@ + -rm $(RMFLAGS) $@
+ install -pm755 $? $@ + install -pm755 $? $@
+ +
+$(GSM_INSTALL_LIB)/libgsm.so.$(SO_MAJOR): $(LIBGSMSO).$(SO_MAJOR) +$(GSM_INSTALL_LIB)/libgsm.so.$(SO_MAJOR): $(LIBGSMSO).$(SO_MAJOR)
+ -rm $@ + -rm $(RMFLAGS) $@
+ ln -s libgsm.so.$(SO_VER) $@ + ln -s libgsm.so.$(SO_VER) $@
+ +
+$(GSM_INSTALL_LIB)/libgsm.so: $(LIBGSMSO) +$(GSM_INSTALL_LIB)/libgsm.so: $(LIBGSMSO)
+ -rm $@ + -rm $(RMFLAGS) $@
+ ln -s libgsm.so.$(SO_VER) $@ + ln -s libgsm.so.$(SO_VER) $@
# Distribution # Distribution

View File

@ -1,11 +1,11 @@
# on update also change soname in the gsm-makefile.patch # on update also change soname in the gsm-makefile.patch
%global ver_major 1 %global ver_major 1
%global ver_minor 0 %global ver_minor 0
%global ver_patch 19 %global ver_patch 20
Name: gsm Name: gsm
Version: %{ver_major}.%{ver_minor}.%{ver_patch} Version: %{ver_major}.%{ver_minor}.%{ver_patch}
Release: 7%{?dist} Release: 1%{?dist}
Summary: Shared libraries for GSM speech compressor Summary: Shared libraries for GSM speech compressor
License: MIT License: MIT
@ -113,6 +113,9 @@ export LDFLAGS="%{?__global_ldflags}"
%{_mandir}/man3/gsm_print.3* %{_mandir}/man3/gsm_print.3*
%changelog %changelog
* Tue Jul 19 2022 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.20-1
- update to 1.0.20 (resolves rhbz#2103499)
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.19-7 * Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.19-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (gsm-1.0.19.tar.gz) = f69b4bf2d918b118b5de90b8ab88fd026008ac7432f07b872b81fe52cdc781f605dca8eedcdaebc8beb974cef388496c618f92a41961c62057009964159f8392 SHA512 (gsm-1.0.20.tar.gz) = 8a57395cd22ff1e0340619aefc279693cbed7c4616b6e6ddc33fffca35361ddfe26b6c5a64ddcb5a9bb455797ca79aa1b7b8a31671dab1a003c544da78fc2ec5