New version
Resolves: rhbz#1818181
This commit is contained in:
parent
7ab087af19
commit
d2a954a727
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ gsm-1.0.13.tar.gz
|
|||||||
/gsm-1.0.16.tar.gz
|
/gsm-1.0.16.tar.gz
|
||||||
/gsm-1.0.17.tar.gz
|
/gsm-1.0.17.tar.gz
|
||||||
/gsm-1.0.18.tar.gz
|
/gsm-1.0.18.tar.gz
|
||||||
|
/gsm-1.0.19.tar.gz
|
||||||
|
@ -15,8 +15,8 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
|
|||||||
|
|
||||||
+SO_MAJOR = 1
|
+SO_MAJOR = 1
|
||||||
+SO_MINOR = 0
|
+SO_MINOR = 0
|
||||||
+SO_MICRO = 18
|
+SO_PATCH = 18
|
||||||
+SO_VER = $(SO_MAJOR).$(SO_MINOR).$(SO_MICRO)
|
+SO_VER = $(SO_MAJOR).$(SO_MINOR).$(SO_PATCH)
|
||||||
|
|
||||||
# If your compiler needs additional flags/libraries, regardless of
|
# If your compiler needs additional flags/libraries, regardless of
|
||||||
# the source compiled, configure them here.
|
# the source compiled, configure them here.
|
||||||
@ -47,7 +47,7 @@ diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
|
|||||||
-RMFLAGS =
|
-RMFLAGS =
|
||||||
+RMFLAGS = -f
|
+RMFLAGS = -f
|
||||||
FIND = find
|
FIND = find
|
||||||
COMPRESS = compress
|
COMPRESS = gzip
|
||||||
COMPRESSFLAGS =
|
COMPRESSFLAGS =
|
||||||
@@ -140,6 +144,7 @@ LFLAGS = $(LDFLAGS) $(LDINC)
|
@@ -140,6 +144,7 @@ LFLAGS = $(LDFLAGS) $(LDINC)
|
||||||
# Targets
|
# Targets
|
||||||
|
20
gsm.spec
20
gsm.spec
@ -1,9 +1,10 @@
|
|||||||
%global ver_maj 1.0
|
%global ver_major 1
|
||||||
%global ver_min 18
|
%global ver_minor 0
|
||||||
|
%global ver_patch 19
|
||||||
|
|
||||||
Name: gsm
|
Name: gsm
|
||||||
Version: %{ver_maj}.%{ver_min}
|
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Shared libraries for GSM speech compressor
|
Summary: Shared libraries for GSM speech compressor
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -13,7 +14,7 @@ Patch0: %{name}-makefile.patch
|
|||||||
Patch1: %{name}-warnings.patch
|
Patch1: %{name}-warnings.patch
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
|
|
||||||
%global srcver %{ver_maj}-pl%{ver_min}
|
%global srcver %{ver_major}.%{ver_minor}-pl%{ver_patch}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Contains runtime shared libraries for libgsm, an implementation of
|
Contains runtime shared libraries for libgsm, an implementation of
|
||||||
@ -60,7 +61,7 @@ full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
export LDFLAGS="%{?__global_ldflags}"
|
export LDFLAGS="%{?__global_ldflags}"
|
||||||
make %{?_smp_mflags} all
|
make %{?_smp_mflags} all SO_MAJOR=%{ver_major} SO_MINOR=%{ver_minor} SO_PATCH=%{ver_patch}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
export LDFLAGS="%{?__global_ldflags}"
|
export LDFLAGS="%{?__global_ldflags}"
|
||||||
@ -69,7 +70,8 @@ mkdir -p %{buildroot}{%{_bindir},%{_includedir}/gsm,%{_libdir},%{_mandir}/{man1,
|
|||||||
make install \
|
make install \
|
||||||
INSTALL_ROOT=%{buildroot}%{_prefix} \
|
INSTALL_ROOT=%{buildroot}%{_prefix} \
|
||||||
GSM_INSTALL_INC=%{buildroot}%{_includedir}/gsm \
|
GSM_INSTALL_INC=%{buildroot}%{_includedir}/gsm \
|
||||||
GSM_INSTALL_LIB=%{buildroot}%{_libdir}
|
GSM_INSTALL_LIB=%{buildroot}%{_libdir} \
|
||||||
|
SO_MAJOR=%{ver_major} SO_MINOR=%{ver_minor} SO_PATCH=%{ver_patch}
|
||||||
|
|
||||||
# some apps look for this in /usr/include
|
# some apps look for this in /usr/include
|
||||||
ln -s gsm/gsm.h %{buildroot}%{_includedir}
|
ln -s gsm/gsm.h %{buildroot}%{_includedir}
|
||||||
@ -109,6 +111,10 @@ make addtst
|
|||||||
%{_mandir}/man3/gsm_print.3*
|
%{_mandir}/man3/gsm_print.3*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 1 2020 Jaroslav Škarvada <jskarvad@redhat.com> - 1.0.19-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1818181
|
||||||
|
|
||||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.18-6
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.18-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gsm-1.0.18.tar.gz) = c5b597f68d4a270e1d588f480dcde66fda8302564c687d753f2bd4fc41d246109243e567568da61eddce170f5232d869984743ddf1eea7696d673014a1a453b7
|
SHA512 (gsm-1.0.19.tar.gz) = f69b4bf2d918b118b5de90b8ab88fd026008ac7432f07b872b81fe52cdc781f605dca8eedcdaebc8beb974cef388496c618f92a41961c62057009964159f8392
|
||||||
|
Loading…
Reference in New Issue
Block a user