Merge branch 'f25' into f26
This commit is contained in:
commit
52bfee4e0d
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
gsm-1.0.13.tar.gz
|
||||
/gsm-1.0.16.tar.gz
|
||||
/gsm-1.0.17.tar.gz
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- gsm-1.0-pl12/inc/private.h.64bit 2006-04-26 21:17:01.000000000 +0200
|
||||
+++ gsm-1.0-pl12/inc/private.h 2007-05-11 00:25:23.000000000 +0200
|
||||
@@ -10,10 +10,10 @@
|
||||
#define PRIVATE_H
|
||||
|
||||
typedef short word; /* 16 bit signed int */
|
||||
-typedef long longword; /* 32 bit signed int */
|
||||
+typedef int longword; /* 32 bit signed int */
|
||||
|
||||
typedef unsigned short uword; /* unsigned word */
|
||||
-typedef unsigned long ulongword; /* unsigned longword */
|
||||
+typedef unsigned int ulongword; /* unsigned longword */
|
||||
|
||||
struct gsm_state {
|
||||
|
@ -1,12 +1,12 @@
|
||||
diff -up gsm-1.0-pl16/Makefile.mk gsm-1.0-pl16/Makefile
|
||||
--- gsm-1.0-pl16/Makefile.mk 2006-04-26 21:14:26.000000000 +0200
|
||||
+++ gsm-1.0-pl16/Makefile 2016-11-24 13:49:47.810060070 +0100
|
||||
diff -up gsm-1.0-pl17/Makefile.mk gsm-1.0-pl17/Makefile
|
||||
--- gsm-1.0-pl17/Makefile.mk 2017-06-28 02:24:24.000000000 +0200
|
||||
+++ gsm-1.0-pl17/Makefile 2017-06-29 13:18:44.138719902 +0200
|
||||
@@ -44,13 +44,17 @@ WAV49 = -DWAV49
|
||||
# CCFLAGS = -c -O
|
||||
|
||||
CC = gcc -ansi -pedantic
|
||||
-CCFLAGS = -c -O2 -DNeedFunctionPrototypes=1
|
||||
+CCFLAGS = -c $(RPM_OPT_FLAGS) -D_REENTRANT -DNeedFunctionPrototypes=1
|
||||
-CCFLAGS = -c -O2 -DNeedFunctionPrototypes=1 -Wall -Wno-comment
|
||||
+CCFLAGS = -c $(RPM_OPT_FLAGS) -DNeedFunctionPrototypes=1 -Wall -Wno-comment -D_XOPEN_SOURCE=700 -D_REENTRANT -fPIC
|
||||
|
||||
LD = $(CC)
|
||||
|
||||
@ -15,7 +15,7 @@ diff -up gsm-1.0-pl16/Makefile.mk gsm-1.0-pl16/Makefile
|
||||
|
||||
+SO_MAJOR = 1
|
||||
+SO_MINOR = 0
|
||||
+SO_MICRO = 16
|
||||
+SO_MICRO = 17
|
||||
+SO_VER = $(SO_MAJOR).$(SO_MINOR).$(SO_MICRO)
|
||||
|
||||
# If your compiler needs additional flags/libraries, regardless of
|
||||
|
@ -1,31 +1,12 @@
|
||||
diff -up gsm-1.0-pl16/add-test/add_test.c.warn gsm-1.0-pl16/add-test/add_test.c
|
||||
--- gsm-1.0-pl16/add-test/add_test.c.warn 2006-04-26 21:14:25.000000000 +0200
|
||||
+++ gsm-1.0-pl16/add-test/add_test.c 2016-11-24 10:35:09.642537236 +0100
|
||||
@@ -9,6 +9,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include "gsm.h"
|
||||
|
||||
@@ -29,7 +30,7 @@ word M_gsm_abs P((word op1));
|
||||
longword M_gsm_L_mult P((word op1, word op2));
|
||||
longword M_gsm_L_add P((longword op1, longword op2));
|
||||
|
||||
-help()
|
||||
+void help(void)
|
||||
{
|
||||
puts( " add a b sub a b mult a b div a b" );
|
||||
puts( "L_add A B L_sub A B L_mult A B mult_r a b" );
|
||||
diff -up gsm-1.0-pl16/src/toast.c.warn gsm-1.0-pl16/src/toast.c
|
||||
--- gsm-1.0-pl16/src/toast.c.warn 2006-04-26 21:14:26.000000000 +0200
|
||||
+++ gsm-1.0-pl16/src/toast.c 2016-11-24 10:35:15.266571608 +0100
|
||||
@@ -6,6 +6,8 @@
|
||||
diff -up gsm-1.0-pl17/src/toast.c.warn gsm-1.0-pl17/src/toast.c
|
||||
--- gsm-1.0-pl17/src/toast.c.warn 2017-06-28 02:09:38.000000000 +0200
|
||||
+++ gsm-1.0-pl17/src/toast.c 2017-06-29 11:44:43.979453734 +0200
|
||||
@@ -6,6 +6,9 @@
|
||||
|
||||
/* $Header: /tmp_amd/presto/export/kbs/jutta/src/gsm/RCS/toast.c,v 1.8 1996/07/02 10:41:04 jutta Exp $ */
|
||||
|
||||
+#include <stdio.h>
|
||||
+#include <unistd.h>
|
||||
+#include <getopt.h>
|
||||
#include "toast.h"
|
||||
|
||||
|
21
gsm.spec
21
gsm.spec
@ -1,6 +1,9 @@
|
||||
%global ver_maj 1.0
|
||||
%global ver_min 17
|
||||
|
||||
Name: gsm
|
||||
Version: 1.0.16
|
||||
Release: 2%{?dist}
|
||||
Version: %{ver_maj}.%{ver_min}
|
||||
Release: 1%{?dist}
|
||||
Summary: Shared libraries for GSM speech compressor
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -9,10 +12,8 @@ URL: http://www.quut.com/gsm/
|
||||
Source: http://www.quut.com/gsm/%{name}-%{version}.tar.gz
|
||||
Patch0: %{name}-makefile.patch
|
||||
Patch1: %{name}-warnings.patch
|
||||
Patch2: %{name}-64bit.patch
|
||||
|
||||
%global srcver 1.0-pl16
|
||||
%global soname 1.0.16
|
||||
%global srcver %{ver_maj}-pl%{ver_min}
|
||||
|
||||
%description
|
||||
Contains runtime shared libraries for libgsm, an implementation of
|
||||
@ -58,10 +59,8 @@ full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
|
||||
%setup -n gsm-%{srcver} -q
|
||||
%patch0 -p1 -b .mk
|
||||
%patch1 -p1 -b .warn
|
||||
%patch2 -p1 -b .64bit
|
||||
|
||||
%build
|
||||
export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
|
||||
make %{?_smp_mflags} all
|
||||
|
||||
%install
|
||||
@ -77,7 +76,7 @@ ln -s gsm/gsm.h %{buildroot}%{_includedir}
|
||||
|
||||
%check
|
||||
# This is to ensure that the patch creates the proper library version.
|
||||
[ -f %{buildroot}%{_libdir}/libgsm.so.%{soname} ]
|
||||
[ -f %{buildroot}%{_libdir}/libgsm.so.%{version} ]
|
||||
make addtst
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
@ -106,6 +105,12 @@ make addtst
|
||||
%{_mandir}/man3/gsm_print.3*
|
||||
|
||||
%changelog
|
||||
* Thu Jun 29 2017 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.17-1
|
||||
- update to 1.0.17 (#1465878)
|
||||
- ease future updates by better macro use
|
||||
- drop obsolete patch hunks
|
||||
- fix missing prototype for fchown warning
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.16-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user