import gsl-2.6-6.el9
This commit is contained in:
commit
3460a8e92b
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/gsl-2.6.tar.gz
|
1
.gsl.metadata
Normal file
1
.gsl.metadata
Normal file
@ -0,0 +1 @@
|
||||
9273164b6bdf60d0577518a1c1310eff6659e3dd SOURCES/gsl-2.6.tar.gz
|
23
SOURCES/gsl-1.10-lib64.patch
Normal file
23
SOURCES/gsl-1.10-lib64.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -up gsl-1.15/gsl-config.in.pom gsl-1.15/gsl-config.in
|
||||
--- gsl-1.15/gsl-config.in.pom 2010-12-26 18:57:08.000000000 +0100
|
||||
+++ gsl-1.15/gsl-config.in 2011-05-09 08:33:05.000000000 +0200
|
||||
@@ -58,16 +58,16 @@ while test $# -gt 0; do
|
||||
;;
|
||||
|
||||
--cflags)
|
||||
- echo @GSL_CFLAGS@
|
||||
+ echo -I$includedir
|
||||
;;
|
||||
|
||||
--libs)
|
||||
: ${GSL_CBLAS_LIB=-lgslcblas}
|
||||
- echo @GSL_LIBS@ $GSL_CBLAS_LIB @GSL_LIBM@
|
||||
+ echo -lgsl $GSL_CBLAS_LIB -lm
|
||||
;;
|
||||
|
||||
--libs-without-cblas)
|
||||
- echo @GSL_LIBS@ @GSL_LIBM@
|
||||
+ echo -lgsl -lm
|
||||
;;
|
||||
*)
|
||||
usage
|
15
SOURCES/gsl-test.patch
Normal file
15
SOURCES/gsl-test.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -up gsl-2.1/rstat/test.c.than gsl-2.1/rstat/test.c
|
||||
diff -up gsl-2.1/test/results.c.than gsl-2.1/test/results.c
|
||||
--- gsl-2.1/test/results.c.than 2016-03-10 18:08:17.013928401 -0500
|
||||
+++ gsl-2.1/test/results.c 2016-03-10 18:42:45.717980023 -0500
|
||||
@@ -131,6 +131,10 @@ gsl_test_rel (double result, double expe
|
||||
{
|
||||
status = -1;
|
||||
}
|
||||
+ else if (fabs(result-expected) < relative_error)
|
||||
+ {
|
||||
+ status = 0;
|
||||
+ }
|
||||
else if (expected != 0 )
|
||||
{
|
||||
status = (fabs(result-expected)/fabs(expected) > relative_error) ;
|
38
SOURCES/gsl-tol.patch
Normal file
38
SOURCES/gsl-tol.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -up gsl-2.1/multifit/test_nonlinear.c.tol gsl-2.1/multifit/test_nonlinear.c
|
||||
--- gsl-2.1/multifit/test_nonlinear.c.tol 2015-11-03 09:21:55.000000000 -0700
|
||||
+++ gsl-2.1/multifit/test_nonlinear.c 2015-12-02 17:02:31.710586128 -0700
|
||||
@@ -175,8 +175,8 @@ static test_fdf_problem *test_fdf_nist[]
|
||||
static void
|
||||
test_nonlinear(void)
|
||||
{
|
||||
- const double xtol = pow(GSL_DBL_EPSILON, 0.9);
|
||||
- const double gtol = pow(GSL_DBL_EPSILON, 0.9);
|
||||
+ const double xtol = pow(GSL_DBL_EPSILON, 0.9) * 10.0;
|
||||
+ const double gtol = pow(GSL_DBL_EPSILON, 0.9) * 10.0;
|
||||
const double ftol = 0.0;
|
||||
size_t i, j;
|
||||
|
||||
diff -up gsl-2.1/multifit/test_powell1.c.tol gsl-2.1/multifit/test_powell1.c
|
||||
--- gsl-2.1/multifit/test_powell1.c.tol 2015-11-03 09:21:55.000000000 -0700
|
||||
+++ gsl-2.1/multifit/test_powell1.c 2015-12-02 17:05:05.295788606 -0700
|
||||
@@ -4,7 +4,7 @@
|
||||
#define powell1_NTRIES 4
|
||||
|
||||
static double powell1_x0[powell1_P] = { 3.0, -1.0, 0.0, 1.0 };
|
||||
-static double powell1_epsrel = 1.0e-5;
|
||||
+static double powell1_epsrel = 2.0e-5;
|
||||
|
||||
static void
|
||||
powell1_checksol(const double x[], const double sumsq,
|
||||
diff -up gsl-2.1/multifit/test_powell3.c.tol gsl-2.1/multifit/test_powell3.c
|
||||
--- gsl-2.1/multifit/test_powell3.c.tol 2015-11-03 09:21:55.000000000 -0700
|
||||
+++ gsl-2.1/multifit/test_powell3.c 2015-12-02 17:05:52.299546834 -0700
|
||||
@@ -4,7 +4,7 @@
|
||||
#define powell3_NTRIES 1
|
||||
|
||||
static double powell3_x0[powell3_P] = { 0.0, 1.0 };
|
||||
-static double powell3_epsrel = 1.0e-12;
|
||||
+static double powell3_epsrel = 1.0e-8;
|
||||
|
||||
static void
|
||||
powell3_checksol(const double x[], const double sumsq,
|
286
SPECS/gsl.spec
Normal file
286
SPECS/gsl.spec
Normal file
@ -0,0 +1,286 @@
|
||||
Summary: The GNU Scientific Library for numerical analysis
|
||||
Name: gsl
|
||||
Version: 2.6
|
||||
Release: 6%{?dist}
|
||||
URL: http://www.gnu.org/software/gsl/
|
||||
License: GPLv3+
|
||||
Source: http://ftp.gnu.org/gnu/gsl/%{name}-%{version}.tar.gz
|
||||
Patch0: gsl-1.10-lib64.patch
|
||||
# http://lists.gnu.org/archive/html/bug-gsl/2015-12/msg00012.html
|
||||
Patch1: gsl-tol.patch
|
||||
Patch2: gsl-test.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: make
|
||||
|
||||
%description
|
||||
The GNU Scientific Library (GSL) is a collection of routines for
|
||||
numerical analysis, written in C.
|
||||
|
||||
%package devel
|
||||
Summary: Libraries and the header files for GSL development
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
Requires: automake
|
||||
|
||||
%description devel
|
||||
The gsl-devel package contains the header files necessary for
|
||||
developing programs using the GSL (GNU Scientific Library).
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .lib64
|
||||
%patch1 -p1 -b .tol
|
||||
%patch2 -p1 -b .test
|
||||
|
||||
iconv -f windows-1252 -t utf-8 THANKS > THANKS.aux
|
||||
touch -r THANKS THANKS.aux
|
||||
mv THANKS.aux THANKS
|
||||
|
||||
%build
|
||||
# disable FMA
|
||||
%ifarch aarch64 ppc64 ppc64le s390 s390x
|
||||
export CFLAGS="%{optflags} -ffp-contract=off"
|
||||
%endif
|
||||
%configure
|
||||
%make_build
|
||||
|
||||
%check
|
||||
make check || ( cat */test-suite.log && exit 1 )
|
||||
|
||||
%install
|
||||
%make_install
|
||||
# remove unpackaged files from the buildroot
|
||||
rm -rf %{buildroot}%{_infodir}/dir
|
||||
rm -f %{buildroot}%{_libdir}/*.la
|
||||
# remove static libraries
|
||||
rm -r %{buildroot}%{_libdir}/*.a
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%license COPYING
|
||||
%doc AUTHORS ChangeLog NEWS README THANKS TODO
|
||||
%{_bindir}/gsl-histogram
|
||||
%{_bindir}/gsl-randist
|
||||
%{_libdir}/libgsl.so.25*
|
||||
%{_libdir}/libgslcblas.so.0*
|
||||
%{_mandir}/man1/gsl-histogram.1*
|
||||
%{_mandir}/man1/gsl-randist.1*
|
||||
|
||||
%files devel
|
||||
%{_bindir}/gsl-config
|
||||
%{_libdir}/libgsl.so
|
||||
%{_libdir}/libgslcblas.so
|
||||
%{_libdir}/pkgconfig/gsl.pc
|
||||
%{_mandir}/man1/gsl-config.1*
|
||||
%{_mandir}/man3/gsl.3*
|
||||
%{_infodir}/gsl-ref.info*
|
||||
%{_datadir}/aclocal/gsl.m4
|
||||
%{_includedir}/gsl/
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.6-6
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.6-5
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Aug 20 2019 Susi Lehtola <jussilehtola@fedoraproject.org> - 2.6-1
|
||||
- Update to 2.6.
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue Jun 11 2019 Susi Lehtola <jussilehtola@fedoraproject.org> - 2.5-1
|
||||
- Update to 2.5.
|
||||
- Updated license tag (the license that applies to the binaries) to GPLv3+.
|
||||
- Bring spec file up to date by relying on recommended macros in build phase.
|
||||
- Arched requires for base package in gsl-devel.
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.4-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Sat Jun 30 2018 Christian Dersch <lupinix@mailbox.org> - 2.4-6
|
||||
- Rebuilt, next try
|
||||
|
||||
* Wed Feb 28 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 2.4-5
|
||||
- Added gcc buildrequires.
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Jul 12 2017 Arthur Mello <amello@redhat.com> - 2.4-1
|
||||
- Update to 2.4
|
||||
|
||||
* Tue Feb 14 2017 Frantisek Kluknavsky <fkluknav@redhat.com> - 2.3-1
|
||||
- rebase to 2.3
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Mar 10 2016 Than Ngo <than@redhat.com> - 2.1-4
|
||||
- fix build failure on powerpc
|
||||
|
||||
* Fri Feb 26 2016 Dan Horák <dan[at]danny.cz> - 2.1-3
|
||||
- Disable FMA also on ppc64(le) and s390(x)
|
||||
|
||||
* Tue Feb 23 2016 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 2.1-2
|
||||
- Disable FMA on AArch64 to lower precision so tests do not fail.
|
||||
|
||||
* Sun Feb 21 2016 Orion Poplawski <orion@cora.nwra.com> - 2.1-1
|
||||
- Update to 2.1
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.16-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Mon Dec 08 2014 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.16-16
|
||||
- Drop linkage patch: libgsl should not link to libgslcblas,
|
||||
so that more efficient libraries can be used (BZ #1007058).
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Apr 28 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.16-13
|
||||
- Add upstream patch which fixes FTBFS on aarch64
|
||||
|
||||
* Sat Feb 15 2014 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.16-12
|
||||
- Drop ATLAS linkage patch: by design, the CBLAS library must be
|
||||
defined at link time to allow use of more optimized implementations.
|
||||
(BZ #1007058).
|
||||
|
||||
* Tue Oct 1 2013 Orion Poplawski <orion@cora.nwra.com> - 1.16-11
|
||||
- Update to 1.16
|
||||
- Rebase atlas patch
|
||||
- Drop upstreamed ode patch
|
||||
|
||||
* Sat Sep 21 2013 Frantisek Kluknavsky <fkluknav@redhat.com> - 1.15-10
|
||||
- linked against atlas 3.10
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jan 30 2013 Frantisek Kluknavsky <fkluknav@redhat.com> - 1.15-8
|
||||
- self test moved to %%check section
|
||||
|
||||
* Tue Jan 29 2013 Frantisek Kluknavsky <fkluknav@redhat.com> - 1.15-7
|
||||
- run self-tests after build
|
||||
- updated ode-initval2 to upstream revision 4788
|
||||
|
||||
* Mon Nov 19 2012 Frantisek Kluknavsky <fkluknav@redhat.com> - 1.15-6
|
||||
- minor cleanup of gsl.spec
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Sep 27 2011 Peter Schiffer <pschiffe@redhat.com> - 1.15-3
|
||||
- resolves: #741138
|
||||
removed unnecessary Requires: atlas
|
||||
|
||||
* Mon May 9 2011 Ivana Hutarova Varekova <varekova@redhat.com> - 1.15-2
|
||||
- resolves: #695148
|
||||
link gsl against atlas package for blas operations
|
||||
|
||||
* Mon May 9 2011 Ivana Hutarova Varekova <varekova@redhat.com> - 1.15-1
|
||||
- update to 1.15
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.14-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed May 5 2010 Ivana Hutarova Varekova <varekova@redhat.com> - 1.14-1
|
||||
- update to 1.14
|
||||
- Resolves: #560219
|
||||
Library not linked correctly
|
||||
|
||||
* Wed Mar 3 2010 Ivana Hutarova Varekova <varekova@redhat.com> - 1.13-2
|
||||
- remove the static subpackage
|
||||
|
||||
* Tue Sep 15 2009 Ivana Varekova <varekova@redhat.com> - 1.13-1
|
||||
- update to 1.13
|
||||
|
||||
* Mon Aug 17 2009 Ivana Varekova <varekova@redhat.com> - 1.12-6
|
||||
- fix preun and post scripts (#517568)
|
||||
|
||||
* Mon Aug 10 2009 Ivana Varekova <varekova@redhat.com> - 1.12-5
|
||||
- fix installation with --excludedocs option (#515971)
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Sat Mar 07 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 1.12-3
|
||||
- Remove rpaths (fix BZ#487823).
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Mon Jan 19 2009 Ivana Varekova <varekova@redhat.com> - 1.12-1
|
||||
- update to 1.12
|
||||
|
||||
* Tue Sep 16 2008 Ivana Varekova <varekova@redhat.com> - 1.11-4
|
||||
- Resolves: #462369 - remove %%{_datadir}/aclocal
|
||||
- add automake dependency
|
||||
|
||||
* Mon Jul 28 2008 Ivana Varekova <varekova@redhat.com> - 1.11-3
|
||||
- add -fgnu89-inline flag to solve gcc4.3 problem
|
||||
remove gcc43 patch
|
||||
|
||||
* Wed Jun 18 2008 Ivana Varekova <varekova@redhat.com> - 1.11-2
|
||||
- Resolves: #451006
|
||||
programs build with gcc 4.3 based on gsl require -fgnu89-inline
|
||||
|
||||
* Mon Jun 16 2008 Ivana Varekova <varekova@redhat.com> - 1.11-1
|
||||
- update to 1.11
|
||||
|
||||
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.10-10
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Thu Nov 1 2007 Ivana Varekova <varekova@redhat.com> - 1.10-9
|
||||
- source file change
|
||||
- spec cleanup
|
||||
|
||||
* Thu Nov 1 2007 Ivana Varekova <varekova@redhat.com> - 1.10-8
|
||||
- fix man-pages directories
|
||||
|
||||
* Tue Oct 30 2007 Ivana Varekova <varekova@redhat.com> - 1.10-7
|
||||
- add man pages
|
||||
|
||||
* Fri Oct 26 2007 Ivana Varekova <varekova@redhat.com> - 1.10-6
|
||||
- minor spec changes
|
||||
|
||||
* Thu Oct 25 2007 Ivana Varekova <varekova@redhat.com> - 1.10-5
|
||||
- minor spec changes
|
||||
|
||||
* Wed Oct 24 2007 Ivana Varekova <varekova@redhat.com> - 1.10-4
|
||||
- add pkgconfig dependency
|
||||
- separate static libraries to -static subpackage
|
||||
- fix gsl-config script - thanks Patrice Dumas
|
||||
|
Loading…
Reference in New Issue
Block a user