1f092caba7
Add comments and revert logic changes in 01_fallback_counting Remove quotes when reading ID value from /etc/os-release Related: rhbz#1650706 blscfg: expand grub_users before passing to grub_normal_add_menu_entry() Resolves: rhbz#1650706 Drop buggy downstream patch "efinet: retransmit if our device is busy" Resolves: rhbz#1649048 Make the menu entry users option argument to be optional Related: rhbz#1652434 10_linux_bls: add missing menu entries options Resolves: rhbz#1652434 Drop "Be more aggro about actually using the *configured* network device." Resolves: rhbz#1654388 Fix menu entry selection based on title Resolves: rhbz#1654936 Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
40 lines
1.1 KiB
Diff
40 lines
1.1 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||
From: Will Thompson <wjt@endlessm.com>
|
||
Date: Fri, 13 Jul 2018 05:51:54 +0100
|
||
Subject: [PATCH] Add loadenv to blscfg and loadenv source file list
|
||
MIME-Version: 1.0
|
||
Content-Type: text/plain; charset=UTF-8
|
||
Content-Transfer-Encoding: 8bit
|
||
|
||
Without this, `make distcheck` fails because loadenv.h is not included
|
||
in the source tarball.
|
||
|
||
This broke in ‘Add blscfg command support to parse BootLoaderSpec config
|
||
fragments’.
|
||
|
||
Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||
---
|
||
grub-core/Makefile.core.def | 2 ++
|
||
1 file changed, 2 insertions(+)
|
||
|
||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||
index 2851437e098..aa44d66aca4 100644
|
||
--- a/grub-core/Makefile.core.def
|
||
+++ b/grub-core/Makefile.core.def
|
||
@@ -781,6 +781,7 @@ module = {
|
||
module = {
|
||
name = blscfg;
|
||
common = commands/blscfg.c;
|
||
+ common = commands/loadenv.h;
|
||
enable = efi;
|
||
enable = i386_pc;
|
||
enable = emu;
|
||
@@ -947,6 +948,7 @@ module = {
|
||
module = {
|
||
name = loadenv;
|
||
common = commands/loadenv.c;
|
||
+ common = commands/loadenv.h;
|
||
common = lib/envblk.c;
|
||
};
|
||
|