f74b50e380
Signed-off-by: Peter Jones <pjones@redhat.com>
72 lines
2.6 KiB
Diff
72 lines
2.6 KiB
Diff
From 8109764f605afbc888760e323d19110ccef84e7b Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Gr=C3=A9goire=20Sutre?= <gregoire.sutre@gmail.com>
|
|
Date: Sun, 28 Oct 2012 11:55:22 +0100
|
|
Subject: [PATCH 054/482] Fix ordering and tab indentation of NetBSD boot menu
|
|
entries.
|
|
|
|
---
|
|
ChangeLog | 5 +++++
|
|
util/grub.d/10_netbsd.in | 12 ++++++------
|
|
2 files changed, 11 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/ChangeLog b/ChangeLog
|
|
index c7b07bb..caea96d 100644
|
|
--- a/ChangeLog
|
|
+++ b/ChangeLog
|
|
@@ -1,3 +1,8 @@
|
|
+2012-10-28 Grégoire Sutre <gregoire.sutre@gmail.com>
|
|
+
|
|
+ * util/grub.d/10_netbsd.in: Fix tab indentation and make sure
|
|
+ that /netbsd appears first (when it exists).
|
|
+
|
|
2012-10-12 Christoph Junghans <ottxor@gentoo.org>
|
|
|
|
* grub-core/Makefile.am (moddep.lst): Use $(AWK) rather than awk.
|
|
diff --git a/util/grub.d/10_netbsd.in b/util/grub.d/10_netbsd.in
|
|
index b76332b..dead5c1 100644
|
|
--- a/util/grub.d/10_netbsd.in
|
|
+++ b/util/grub.d/10_netbsd.in
|
|
@@ -74,13 +74,13 @@ netbsd_load_fs_module ()
|
|
fi
|
|
|
|
kmodule_rel=$(make_system_path_relative_to_its_root "$kmodule") || return
|
|
- prepare_grub_to_access_device $(${grub_probe} -t device "${kmodule}") | sed -e 's,^, ,'
|
|
+ prepare_grub_to_access_device $(${grub_probe} -t device "${kmodule}") | sed -e 's,^, ,' | sed "s/^/$submenu_indentation/"
|
|
case "${loader}" in
|
|
knetbsd)
|
|
- printf "$grub_tabknetbsd_module_elf %s\n" "${kmodule_rel}"
|
|
+ printf "${grub_tab}knetbsd_module_elf %s\n" "${kmodule_rel}" | sed "s/^/$submenu_indentation/"
|
|
;;
|
|
multiboot)
|
|
- printf "$grub_tabmodule %s\n" "${kmodule_rel}"
|
|
+ printf "${grub_tab}module %s\n" "${kmodule_rel}" | sed "s/^/$submenu_indentation/"
|
|
;;
|
|
esac
|
|
}
|
|
@@ -121,11 +121,11 @@ netbsd_entry ()
|
|
printf "%s\n" "${prepare_boot_cache}" | sed "s/^/$submenu_indentation/"
|
|
case "${loader}" in
|
|
knetbsd)
|
|
- printf "$grub_tabknetbsd %s -r %s %s\n" \
|
|
+ printf "${grub_tab}knetbsd %s -r %s %s\n" \
|
|
"${kernel}" "${kroot_device}" "${GRUB_CMDLINE_NETBSD} ${args}" | sed "s/^/$submenu_indentation/"
|
|
;;
|
|
multiboot)
|
|
- printf "$grub_tabmultiboot %s %s root=%s %s\n" \
|
|
+ printf "${grub_tab}multiboot %s %s root=%s %s\n" \
|
|
"${kernel}" "${kernel}" "${kroot_device}" "${GRUB_CMDLINE_NETBSD} ${args}" | sed "s/^/$submenu_indentation/"
|
|
;;
|
|
esac
|
|
@@ -147,7 +147,7 @@ pattern="^ELF[^,]*executable.*statically linked"
|
|
submenu_indentation=""
|
|
|
|
is_first_entry=true
|
|
-for k in $(ls -t /netbsd*) ; do
|
|
+for k in /netbsd $(ls -t /netbsd?* 2>/dev/null) ; do
|
|
if ! grub_file_is_not_garbage "$k" ; then
|
|
continue
|
|
fi
|
|
--
|
|
1.8.2.1
|
|
|