8c6b1ac71e
Also include some minor fixes for gcc 5.1.1 Signed-off-by: Peter Jones <pjones@redhat.com>
105 lines
3.8 KiB
Diff
105 lines
3.8 KiB
Diff
From eaf3b8f6a44f827047eb5a5197fec3daae453005 Mon Sep 17 00:00:00 2001
|
|
From: Paulo Flabiano Smorigo <pfsmorigo@linux.vnet.ibm.com>
|
|
Date: Wed, 13 Aug 2014 18:59:58 +0000
|
|
Subject: [PATCH 484/506] Add powerpc little-endian (ppc64le) flags
|
|
|
|
libgcc dependency was removed *just* for this target because
|
|
the distros that use ppc64el doesn't have 32-bit support on it.
|
|
|
|
* configure.ac: Add targets for powerpc64el and skip libgcc.
|
|
* Makefile.am: Likewise.
|
|
---
|
|
configure.ac | 26 ++++++++++++++++++++++++++
|
|
grub-core/Makefile.am | 3 +++
|
|
2 files changed, 29 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 6275310..9306223 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -139,6 +139,7 @@ if test "x$with_platform" = x; then
|
|
x86_64-*) platform=pc ;;
|
|
powerpc-*) platform=ieee1275 ;;
|
|
powerpc64-*) platform=ieee1275 ;;
|
|
+ powerpc64le-*) platform=ieee1275 ;;
|
|
sparc64-*) platform=ieee1275 ;;
|
|
mipsel-*) platform=loongson ;;
|
|
mips-*) platform=arc ;;
|
|
@@ -161,6 +162,7 @@ case "$target_cpu"-"$platform" in
|
|
x86_64-none) ;;
|
|
x86_64-*) target_cpu=i386 ;;
|
|
powerpc64-ieee1275) target_cpu=powerpc ;;
|
|
+ powerpc64le-ieee1275) target_cpu=powerpc ;;
|
|
esac
|
|
|
|
# Check if the platform is supported, make final adjustments.
|
|
@@ -624,6 +626,13 @@ if test "x$target_cpu" = xi386 && test "x$platform" != xemu; then
|
|
TARGET_CFLAGS="$TARGET_CFLAGS -march=i386"
|
|
fi
|
|
|
|
+if test x$target_cpu = xpowerpc && test x$ac_cv_c_bigendian = xno; then
|
|
+ LD_FORCE_LE=1
|
|
+ TARGET_CFLAGS="$TARGET_CFLAGS -mbig-endian -DNO_LIBGCC=1"
|
|
+ TARGET_CCASFLAGS="$TARGET_CCASFLAGS -mbig-endian"
|
|
+ TARGET_LDFLAGS="$TARGET_LDFLAGS -static -mbig-endian"
|
|
+fi
|
|
+
|
|
if test "x$target_m32" = x1; then
|
|
# Force 32-bit mode.
|
|
TARGET_CFLAGS="$TARGET_CFLAGS -m32"
|
|
@@ -1154,6 +1163,14 @@ else
|
|
CFLAGS="$TARGET_CFLAGS -nostdlib -Wno-error"
|
|
fi
|
|
CPPFLAGS="$TARGET_CPPFLAGS"
|
|
+if test x$target_cpu = xi386 || test x$target_cpu = xx86_64 || test "x$grub_cv_cc_target_clang" = xyes \
|
|
+ || ( test x$target_cpu = xpowerpc && test x$ac_cv_c_bigendian = xno ); then
|
|
+TARGET_LIBGCC=
|
|
+else
|
|
+TARGET_LIBGCC=-lgcc
|
|
+fi
|
|
+
|
|
+LIBS="$TARGET_LIBGCC"
|
|
|
|
grub_ASM_USCORE
|
|
if test "x$TARGET_APPLE_LINKER" = x0 && test x"$platform" != xemu; then
|
|
@@ -1691,6 +1708,14 @@ if test x"$enable_werror" != xno ; then
|
|
HOST_CFLAGS="$HOST_CFLAGS -Werror"
|
|
fi
|
|
|
|
+# if not clang or power LE, use static libgcc
|
|
+if test "x$grub_cv_cc_target_clang" = xno \
|
|
+ || ! ( test x$target_cpu = xpowerpc && test x$ac_cv_c_bigendian = xno ); then
|
|
+ TARGET_LDFLAGS_STATIC_LIBGCC="-static-libgcc"
|
|
+else
|
|
+ TARGET_LDFLAGS_STATIC_LIBGCC=
|
|
+fi
|
|
+
|
|
TARGET_CPP="$TARGET_CC -E"
|
|
TARGET_CCAS=$TARGET_CC
|
|
|
|
@@ -1752,6 +1777,7 @@ AM_CONDITIONAL([COND_mips_arc], [test "(" x$target_cpu = xmips -o x$target_cpu =
|
|
AM_CONDITIONAL([COND_sparc64_ieee1275], [test x$target_cpu = xsparc64 -a x$platform = xieee1275])
|
|
AM_CONDITIONAL([COND_sparc64_emu], [test x$target_cpu = xsparc64 -a x$platform = xemu])
|
|
AM_CONDITIONAL([COND_powerpc_ieee1275], [test x$target_cpu = xpowerpc -a x$platform = xieee1275])
|
|
+AM_CONDITIONAL([COND_powerpc_le], [test x$target_cpu = xpowerpc -a x$ac_cv_c_bigendian = xno])
|
|
AM_CONDITIONAL([COND_mips], [test x$target_cpu = xmips -o x$target_cpu = xmipsel])
|
|
AM_CONDITIONAL([COND_mipsel], [test x$target_cpu = xmipsel])
|
|
AM_CONDITIONAL([COND_mipseb], [test x$target_cpu = xmips])
|
|
diff --git a/grub-core/Makefile.am b/grub-core/Makefile.am
|
|
index af0c7f4..8c37782 100644
|
|
--- a/grub-core/Makefile.am
|
|
+++ b/grub-core/Makefile.am
|
|
@@ -88,6 +88,9 @@ KERNEL_HEADER_FILES += $(top_srcdir)/include/grub/term.h
|
|
KERNEL_HEADER_FILES += $(top_srcdir)/include/grub/time.h
|
|
KERNEL_HEADER_FILES += $(top_srcdir)/include/grub/mm_private.h
|
|
KERNEL_HEADER_FILES += $(top_srcdir)/include/grub/net.h
|
|
+if !COND_powerpc_le
|
|
+KERNEL_HEADER_FILES += $(top_srcdir)/include/grub/libgcc.h
|
|
+endif
|
|
KERNEL_HEADER_FILES += $(top_srcdir)/include/grub/memory.h
|
|
|
|
if COND_i386_pc
|
|
--
|
|
2.4.3
|
|
|