grub2/0328-Allow-clang-compilation-for-thumb-with-mthumb-interw.patch
Peter Jones 8c6b1ac71e Reconcile with upstream once again.
Also include some minor fixes for gcc 5.1.1

Signed-off-by: Peter Jones <pjones@redhat.com>
2015-07-22 09:46:32 -04:00

42 lines
1.2 KiB
Diff

From 2066c35b3ff6e35edf2a4e903f9aa79a23b6aefe Mon Sep 17 00:00:00 2001
From: Vladimir Serbinenko <phcoder@gmail.com>
Date: Sun, 22 Feb 2015 17:45:30 +0100
Subject: [PATCH 328/506] Allow clang compilation for thumb with
-mthumb-interwork.
clang already uses -mthumb-interwork behaviour even thout it doesn't
support the option.
---
configure.ac | 13 +------------
1 file changed, 1 insertion(+), 12 deletions(-)
diff --git a/configure.ac b/configure.ac
index 35f430a..8f9ab81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1029,20 +1029,9 @@ if test "x$target_cpu" = xarm; then
])
if test "x$grub_cv_cc_mthumb_interwork" = xyes; then
TARGET_CFLAGS="$TARGET_CFLAGS -mthumb-interwork"
+ # Clang defaults to thumb interworking
elif test "x$grub_cv_cc_target_clang" = xno ; then
AC_MSG_ERROR([your compiler doesn't support -mthumb-interwork])
- else
- CFLAGS="$TARGET_CFLAGS"
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
-#if defined (__thumb__) && !defined (__thumb2__)
-#error thumb without interworking
-#endif
-]])],
- [no_interwork_ok=yes],
- [no_interwork_ok=no])
- if test x$no_interwork_ok = xno ; then
- AC_MSG_ERROR([attempt to compile to thumb with no thumb interwork])
- fi
fi
fi
--
2.4.3