8c6b1ac71e
Also include some minor fixes for gcc 5.1.1 Signed-off-by: Peter Jones <pjones@redhat.com>
30 lines
1.0 KiB
Diff
30 lines
1.0 KiB
Diff
From ea39b87a8b258a0f19752f5e5607e14deec54c44 Mon Sep 17 00:00:00 2001
|
|
From: Vladimir Serbinenko <phcoder@gmail.com>
|
|
Date: Sun, 22 Feb 2015 14:42:19 +0100
|
|
Subject: [PATCH 324/506] configure.ac: Add ia64-specific way to disable
|
|
floats.
|
|
|
|
---
|
|
configure.ac | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 4d59fbe..94f96c4 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -690,6 +690,11 @@ if test x"$platform" != xemu ; then
|
|
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],
|
|
[grub_cv_target_cc_soft_float="-march=armv8-a+nofp+nosimd"], [])
|
|
fi
|
|
+ if test "x$target_cpu" = xia64; then
|
|
+ CFLAGS="$TARGET_CFLAGS -mno-inline-float-divide -mno-inline-sqrt -Werror"
|
|
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],
|
|
+ [grub_cv_target_cc_soft_float="-mno-inline-float-divide -mno-inline-sqrt"], [])
|
|
+ fi
|
|
for cand in "-Xclang -msoft-float -Xclang -no-implicit-float" \
|
|
"-Xclang -msoft-float" "-msoft-float"; do
|
|
if test x"$grub_cv_target_cc_soft_float" != xno ; then
|
|
--
|
|
2.4.3
|
|
|