7e98da058f
This change reorganizes and cleanups our patches to reduce the patch number from 314 patches to 187. That's achieved by dropping patches that are later reverted and squashing fixes for earlier patches that introduced features. There are no code changes and the diff with upstream is the same before and after the cleanup. Having fewer patches makes easier to manage the patchset and also will ease to rebase them on top of the latest grub-2.04 release. Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Peter Jones <pjones@redhat.com>
|
|
Date: Thu, 2 Aug 2018 10:56:38 -0400
|
|
Subject: [PATCH] Disable non-wordsize allocations on arm
|
|
|
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
|
---
|
|
configure.ac | 20 ++++++++++++++++++++
|
|
1 file changed, 20 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 819212095ff..9323c125469 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1234,6 +1234,26 @@ if test "x$target_cpu" = xarm; then
|
|
done
|
|
])
|
|
|
|
+ AC_CACHE_CHECK([for options to disable movt and movw relocations],
|
|
+ grub_cv_target_cc_mword_relocations,
|
|
+ [grub_cv_target_cc_mword_relocations=no
|
|
+ for cand in "-mword-relocations" ; do
|
|
+ if test x"$grub_cv_target_cc_mword_relocations" != xno ; then
|
|
+ break
|
|
+ fi
|
|
+ CFLAGS="$TARGET_CFLAGS $cand -Werror"
|
|
+ CPPFLAGS="$TARGET_CPPFLAGS"
|
|
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],
|
|
+ [grub_cv_target_cc_mword_relocations="$cand"],
|
|
+ [])
|
|
+ done
|
|
+ ])
|
|
+ if test x"$grub_cv_target_cc_mword_relocations" = xno ; then
|
|
+ AC_MSG_ERROR(["your compiler doesn't support disabling movw/movt relocations"])
|
|
+ else
|
|
+ TARGET_CFLAGS="$TARGET_CFLAGS $grub_cv_target_cc_mword_relocations"
|
|
+ fi
|
|
+
|
|
if test x"$grub_cv_target_cc_mno_movt" != xno ; then
|
|
# A trick so that clang doesn't see it on link stage
|
|
TARGET_CPPFLAGS="$TARGET_CPPFLAGS $grub_cv_target_cc_mno_movt"
|