Minor fixup, woops.

Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
Peter Jones 2018-07-11 17:57:52 -04:00
parent 64626d2a22
commit e8fe2763b0
2 changed files with 21 additions and 10 deletions

View File

@ -1,28 +1,39 @@
From b09601dabd607da4bbd3e7c36331ee49acc019a8 Mon Sep 17 00:00:00 2001
From daf2e12adfb61d8c1f7a61322bc2a09bda2335ee Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Wed, 11 Jul 2018 13:49:17 -0400
Subject: [PATCH] Make the linuxefi module just be the x86 efi version of linux
Signed-off-by: Peter Jones <pjones@redhat.com>
---
grub-core/Makefile.core.def | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)
grub-core/Makefile.core.def | 14 +++++---------
1 file changed, 5 insertions(+), 9 deletions(-)
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
index 81509b86a0d..8da0a01dfce 100644
index 81509b86a0d..524330ee829 100644
--- a/grub-core/Makefile.core.def
+++ b/grub-core/Makefile.core.def
@@ -1724,6 +1724,9 @@ module = {
@@ -1710,6 +1710,8 @@ module = {
module = {
name = linux;
x86 = loader/i386/linux.c;
+ x86_efi = loader/i386/efi/linux.c;
+ i386_efi = loader/i386/efi/linux.c;
xen = loader/i386/xen.c;
i386_pc = lib/i386/pc/vesa_modes_table.c;
mips = loader/mips/linux.c;
@@ -1722,8 +1724,11 @@ module = {
arm64 = loader/efi/linux.c;
emu = loader/emu/linux.c;
fdt = lib/fdt.c;
+
common = loader/linux.c;
common = lib/cmdline.c;
+
+ efi = loader/i386/efi/linux.c;
+ efi = loader/efi/linux.c;
};
module = {
@@ -1784,15 +1787,6 @@ module = {
@@ -1784,15 +1789,6 @@ module = {
enable = x86_64_efi;
};

View File

@ -1,4 +1,4 @@
From e309a10fd317ada214cf23a897bb21518137b188 Mon Sep 17 00:00:00 2001
From 2abf6e14bae2d6ac6d694f482a0e657744919ef1 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Wed, 11 Jul 2018 13:50:00 -0400
Subject: [PATCH] Make efi_netfs not duplicate symbols from efinet
@ -9,10 +9,10 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
1 file changed, 6 deletions(-)
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
index 8da0a01dfce..6146f77297f 100644
index 524330ee829..063060575b3 100644
--- a/grub-core/Makefile.core.def
+++ b/grub-core/Makefile.core.def
@@ -2193,12 +2193,6 @@ module = {
@@ -2195,12 +2195,6 @@ module = {
module = {
name = efi_netfs;
common = net/efi/efi_netfs.c;