First 9.1 build; no changes from 9.0
- Fix initialization on efidisk patch - Re-run signing with updated redhat-release Resolves: #2062874 Signed-off-by: Robbie Harwood <rharwood@redhat.com>
This commit is contained in:
parent
01f68549dc
commit
e3753ed4c2
@ -1,7 +1,8 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Renaud=20M=C3=A9trich?= <rmetrich@redhat.com>
|
||||
Date: Tue, 8 Feb 2022 08:39:10 +0100
|
||||
Subject: [PATCH] search: fixed bug stopping iteration when --no-floppy is used
|
||||
Subject: [PATCH] commands/search: Fix bug stopping iteration when --no-floppy
|
||||
is used
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
@ -10,7 +11,10 @@ When using --no-floppy and a floppy was encountered, iterate_device()
|
||||
was returning 1, causing the iteration to stop instead of continuing.
|
||||
|
||||
Signed-off-by: Renaud Métrich <rmetrich@redhat.com>
|
||||
(cherry picked from commit e784b4b3367341b0468dd2a83b265d49383f48ae)
|
||||
Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
|
||||
(cherry picked from commit 68ba54c2298604146be83cae144dafd1cfd1fe2d)
|
||||
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||
(cherry picked from commit 7ada55e3fcd16e00773d3918955b2b945b7f063a)
|
||||
---
|
||||
grub-core/commands/search.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
@ -17,7 +17,9 @@ effective EFI device behind.
|
||||
This commit also refactors handling of --no-floppy option.
|
||||
|
||||
Signed-off-by: Renaud Métrich <rmetrich@redhat.com>
|
||||
(cherry picked from commit aedb45f32106dd2a64f906b0db6a76ee09f1b930)
|
||||
[rharwood: apply rmetrich's flags initialization fix]
|
||||
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||
(cherry picked from commit fdd8396f4fa750bbbabd4298f2593942f2b84710)
|
||||
---
|
||||
grub-core/commands/search.c | 27 +++++++++++++++++++++++----
|
||||
grub-core/commands/search_wrap.c | 18 ++++++++++++------
|
||||
@ -85,7 +87,7 @@ index 51656e361cc..57d26ced8a8 100644
|
||||
.nhints = nhints,
|
||||
.count = 0,
|
||||
diff --git a/grub-core/commands/search_wrap.c b/grub-core/commands/search_wrap.c
|
||||
index 47fc8eb9966..464e6ebb1c8 100644
|
||||
index 47fc8eb9966..0b62acf8535 100644
|
||||
--- a/grub-core/commands/search_wrap.c
|
||||
+++ b/grub-core/commands/search_wrap.c
|
||||
@@ -40,6 +40,7 @@ static const struct grub_arg_option options[] =
|
||||
@ -108,7 +110,7 @@ index 47fc8eb9966..464e6ebb1c8 100644
|
||||
const char *id = 0;
|
||||
int i = 0, j = 0, nhints = 0;
|
||||
char **hints = NULL;
|
||||
+ enum search_flags flags;
|
||||
+ enum search_flags flags = 0;
|
||||
|
||||
if (state[SEARCH_HINT].set)
|
||||
for (i = 0; state[SEARCH_HINT].args[i]; i++)
|
||||
|
@ -50,7 +50,8 @@ The code is easily extensible to handle other arguments in the future if
|
||||
needed.
|
||||
|
||||
Signed-off-by: Renaud Métrich <rmetrich@redhat.com>
|
||||
(cherry picked from commit 73e183ce1e42bd97ae91a9254f8d4acd4d0b1cbc)
|
||||
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||
(cherry picked from commit cc972c27314c841f80ab0fe8318fae06f078c680)
|
||||
---
|
||||
grub-core/Makefile.core.def | 6 ++
|
||||
grub-core/commands/efi/connectefi.c | 205 ++++++++++++++++++++++++++++++++++++
|
||||
|
18
do-rebase
18
do-rebase
@ -161,15 +161,15 @@ git rm -q 0*.patch
|
||||
#git add release-to-master.patch
|
||||
|
||||
centpkg sources
|
||||
curl -L https://github.com/rhboot/gnulib/archive/fixes.tar.gz > gnulib-fixes.tar.gz.new
|
||||
if cmp -s gnulib-fixes.tar.gz gnulib-fixes.tar.gz.new; then
|
||||
rm gnulib-fixes.tar.gz.new
|
||||
else
|
||||
mv gnulib-fixes.tar.gz.new gnulib-fixes.tar.gz
|
||||
sed -i -e '/gnulib-/d' sources
|
||||
centpkg upload gnulib-fixes.tar.gz
|
||||
git add sources
|
||||
fi
|
||||
# curl -L https://github.com/rhboot/gnulib/archive/fixes.tar.gz > gnulib-fixes.tar.gz.new
|
||||
# if cmp -s gnulib-fixes.tar.gz gnulib-fixes.tar.gz.new; then
|
||||
# rm gnulib-fixes.tar.gz.new
|
||||
# else
|
||||
# mv gnulib-fixes.tar.gz.new gnulib-fixes.tar.gz
|
||||
# sed -i -e '/gnulib-/d' sources
|
||||
# centpkg upload gnulib-fixes.tar.gz
|
||||
# git add sources
|
||||
# fi
|
||||
|
||||
> grub.patches
|
||||
patches=$(formatpatch refs/remotes/rhboot/master..refs/remotes/rhboot/${releasever})
|
||||
|
@ -222,6 +222,6 @@ Patch0221: 0221-fs-xfs-Fix-unreadable-filesystem-with-v4-superblock.patch
|
||||
Patch0222: 0222-Print-module-name-on-license-check-failure.patch
|
||||
Patch0223: 0223-powerpc-ieee1275-load-grub-at-4MB-not-2MB.patch
|
||||
Patch0224: 0224-grub-mkconfig-restore-umask-for-grub.cfg.patch
|
||||
Patch0225: 0225-search-fixed-bug-stopping-iteration-when-no-floppy-i.patch
|
||||
Patch0225: 0225-commands-search-Fix-bug-stopping-iteration-when-no-f.patch
|
||||
Patch0226: 0226-search-new-efidisk-only-option-on-EFI-systems.patch
|
||||
Patch0227: 0227-efi-new-connectefi-command.patch
|
||||
|
12
grub2.spec
12
grub2.spec
@ -14,7 +14,7 @@
|
||||
Name: grub2
|
||||
Epoch: 1
|
||||
Version: 2.06
|
||||
Release: 25%{?dist}
|
||||
Release: 28%{?dist}
|
||||
Summary: Bootloader with support for Linux, Multiboot and more
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/grub/
|
||||
@ -530,6 +530,16 @@ mv ${EFI_HOME}/grub.cfg.stb ${EFI_HOME}/grub.cfg
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed May 04 2022 Robbie Harwood <rharwood@redhat.com> - 2.06-28
|
||||
- First 9.1 build; no changes from 9.0
|
||||
- Resolves: #2062874
|
||||
|
||||
* Wed Mar 09 2022 Robbie Harwood <rharwood@redhat.com> - 2.06-27
|
||||
- Fix initialization on efidisk patch
|
||||
|
||||
* Tue Mar 08 2022 Robbie Harwood <rharwood@redhat.com> - 2.06-26
|
||||
- Re-run signing with updated redhat-release
|
||||
|
||||
* Mon Feb 28 2022 Robbie Harwood <rharwood@redhat.com> - 2.06-25
|
||||
- Enable connectefi module
|
||||
- Resolves: #2049219
|
||||
|
Loading…
Reference in New Issue
Block a user