fix a copy-paste error in patch 0154.
Resolves: rhbz#964828 Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
parent
9d85b1d3af
commit
dea2713c92
@ -15,13 +15,14 @@ diff --git a/util/grub.d/30_os-prober.in b/util/grub.d/30_os-prober.in
|
|||||||
index 9f955ab..908a09d 100644
|
index 9f955ab..908a09d 100644
|
||||||
--- a/util/grub.d/30_os-prober.in
|
--- a/util/grub.d/30_os-prober.in
|
||||||
+++ b/util/grub.d/30_os-prober.in
|
+++ b/util/grub.d/30_os-prober.in
|
||||||
@@ -135,6 +135,28 @@ for OS in ${OSPROBED} ; do
|
@@ -135,6 +135,29 @@ for OS in ${OSPROBED} ; do
|
||||||
LONGNAME="${LABEL}"
|
LONGNAME="${LABEL}"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
+ sixteenbit=""
|
+ sixteenbit=""
|
||||||
+ linuxefi="linux"
|
+ linuxefi="linux"
|
||||||
+ initrdefi="initrd"
|
+ initrdefi="initrd"
|
||||||
|
+ machine=`uname -m`
|
||||||
+ case "$machine" in
|
+ case "$machine" in
|
||||||
+ i?86|x86_64)
|
+ i?86|x86_64)
|
||||||
+ sixteenbit="16"
|
+ sixteenbit="16"
|
||||||
@ -44,7 +45,7 @@ index 9f955ab..908a09d 100644
|
|||||||
gettext_printf "Found %s on %s\n" "${LONGNAME}" "${DEVICE}" >&2
|
gettext_printf "Found %s on %s\n" "${LONGNAME}" "${DEVICE}" >&2
|
||||||
|
|
||||||
case ${BOOT} in
|
case ${BOOT} in
|
||||||
@@ -235,11 +257,11 @@ EOF
|
@@ -235,11 +258,11 @@ EOF
|
||||||
save_default_entry | grub_add_tab
|
save_default_entry | grub_add_tab
|
||||||
printf '%s\n' "${prepare_boot_cache}"
|
printf '%s\n' "${prepare_boot_cache}"
|
||||||
cat << EOF
|
cat << EOF
|
||||||
@ -58,7 +59,7 @@ index 9f955ab..908a09d 100644
|
|||||||
EOF
|
EOF
|
||||||
fi
|
fi
|
||||||
cat << EOF
|
cat << EOF
|
||||||
@@ -255,11 +277,11 @@ EOF
|
@@ -255,11 +278,11 @@ EOF
|
||||||
save_default_entry | sed -e "s/^/$grub_tab$grub_tab/"
|
save_default_entry | sed -e "s/^/$grub_tab$grub_tab/"
|
||||||
printf '%s\n' "${prepare_boot_cache}" | grub_add_tab
|
printf '%s\n' "${prepare_boot_cache}" | grub_add_tab
|
||||||
cat << EOF
|
cat << EOF
|
||||||
|
13
grub2.spec
13
grub2.spec
@ -47,7 +47,7 @@
|
|||||||
Name: grub2
|
Name: grub2
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.02
|
Version: 2.02
|
||||||
Release: 0.10%{?dist}
|
Release: 0.11%{?dist}
|
||||||
Summary: Bootloader with support for Linux, Multiboot and more
|
Summary: Bootloader with support for Linux, Multiboot and more
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -328,11 +328,14 @@ cd grub-%{tarversion}
|
|||||||
cp %{SOURCE4} unifont.pcf.gz
|
cp %{SOURCE4} unifont.pcf.gz
|
||||||
cp %{SOURCE6} .gitignore
|
cp %{SOURCE6} .gitignore
|
||||||
git init
|
git init
|
||||||
git config user.email "grub2-owner@fedoraproject.org"
|
git config user.email "%{name}-owner@fedoraproject.org"
|
||||||
git config user.name "Fedora Ninjas"
|
git config user.name "Fedora Ninjas"
|
||||||
|
git config gc.auto 0
|
||||||
git add .
|
git add .
|
||||||
git commit -a -q -m "%{tarversion} baseline."
|
git commit -a -q -m "%{tarversion} baseline."
|
||||||
git am %{patches}
|
git am %{patches} </dev/null
|
||||||
|
git config --unset user.email
|
||||||
|
git config --unset user.name
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -647,6 +650,10 @@ fi
|
|||||||
%{_datarootdir}/grub/themes/
|
%{_datarootdir}/grub/themes/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 07 2014 Peter Jones <pjones@redhat.com> - 2.02-0.11
|
||||||
|
- fix a copy-paste error in patch 0154.
|
||||||
|
Resolves: rhbz#964828
|
||||||
|
|
||||||
* Mon Oct 27 2014 Peter Jones <pjones@redhat.com> - 2.02-0.10
|
* Mon Oct 27 2014 Peter Jones <pjones@redhat.com> - 2.02-0.10
|
||||||
- Try to emit linux16/initrd16 and linuxefi/initrdefi when appropriate
|
- Try to emit linux16/initrd16 and linuxefi/initrdefi when appropriate
|
||||||
in 30_os-prober.
|
in 30_os-prober.
|
||||||
|
Loading…
Reference in New Issue
Block a user