Fix missing format specifier in appended signature commit
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
This commit is contained in:
parent
90dacf59d0
commit
ac0e146ae3
@ -20,6 +20,8 @@ other mechanisms, such as a password or lockdown, must be used to ensure
|
||||
that a user cannot drop to the grub shell and disable verification.
|
||||
|
||||
Signed-off-by: Daniel Axtens <dja@axtens.net>
|
||||
[pjones: fix missing format specifier]
|
||||
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||
---
|
||||
grub-core/Makefile.core.def | 12 +
|
||||
grub-core/commands/appendedsig/appendedsig.c | 645 +++++++++++++++++++++++++++
|
||||
@ -52,7 +54,7 @@ index b4aaccf7b57..77321d218c8 100644
|
||||
common = commands/hdparm.c;
|
||||
diff --git a/grub-core/commands/appendedsig/appendedsig.c b/grub-core/commands/appendedsig/appendedsig.c
|
||||
new file mode 100644
|
||||
index 00000000000..dc294cd339e
|
||||
index 00000000000..bf8b18b6205
|
||||
--- /dev/null
|
||||
+++ b/grub-core/commands/appendedsig/appendedsig.c
|
||||
@@ -0,0 +1,645 @@
|
||||
@ -387,7 +389,7 @@ index 00000000000..dc294cd339e
|
||||
+ data = grub_malloc (file_size);
|
||||
+ if (!data)
|
||||
+ return grub_error (GRUB_ERR_OUT_OF_MEMORY,
|
||||
+ N_("Could not allocate data buffer size "
|
||||
+ N_("Could not allocate data buffer size %"
|
||||
+ PRIuGRUB_UINT64_T " for verification"), file_size);
|
||||
+
|
||||
+ while (total_read_size < file_size)
|
||||
|
@ -17,7 +17,7 @@
|
||||
Name: grub2
|
||||
Epoch: 1
|
||||
Version: 2.06
|
||||
Release: 23%{?dist}
|
||||
Release: 24%{?dist}
|
||||
Summary: Bootloader with support for Linux, Multiboot and more
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/grub/
|
||||
@ -526,6 +526,9 @@ mv ${EFI_HOME}/grub.cfg.stb ${EFI_HOME}/grub.cfg
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Mar 21 2022 Robbie Harwood <rharwood@redhat.com> - 2.06-24
|
||||
- Fix missing format specifier in appended signature commit
|
||||
|
||||
* Fri Mar 18 2022 Robbie Harwood <rharwood@redhat.com> - 2.06-23
|
||||
- Don't verify kernels twice
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user