Manually patch this to make it look like the changes from F17. Ugh.
This commit is contained in:
parent
7374fca6aa
commit
820140e8ac
@ -1,9 +1,10 @@
|
|||||||
From ad101ca2bd8913b989cc759bf36632c94381fc4e Mon Sep 17 00:00:00 2001
|
From e263907f50e496e602edd9bd846ccb6e0565a085 Mon Sep 17 00:00:00 2001
|
||||||
From: Mark Hamzy <hamzy@us.ibm.com>
|
From: Mark Hamzy <hamzy@us.ibm.com>
|
||||||
Date: Thu, 1 Mar 2012 21:18:20 -0600
|
Date: Wed, 28 Mar 2012 14:46:41 -0500
|
||||||
Subject: [PATCH] Migrate PPC from Yaboot to Grub2
|
Subject: [PATCH] Migrate PPC from Yaboot to Grub2
|
||||||
|
|
||||||
Add configuration support for serial terminal consoles. This will set the maximum screen size so that text is not overwritten.
|
Add configuration support for serial terminal consoles. This will set the
|
||||||
|
maximum screen size so that text is not overwritten.
|
||||||
|
|
||||||
---
|
---
|
||||||
Makefile.util.def | 7 +++
|
Makefile.util.def | 7 +++
|
||||||
@ -12,10 +13,10 @@ Add configuration support for serial terminal consoles. This will set the maxim
|
|||||||
create mode 100644 util/grub.d/20_ppc_terminfo.in
|
create mode 100644 util/grub.d/20_ppc_terminfo.in
|
||||||
|
|
||||||
diff --git a/Makefile.util.def b/Makefile.util.def
|
diff --git a/Makefile.util.def b/Makefile.util.def
|
||||||
index 058572f..1993f9b 100644
|
index c41b76e..b349758 100644
|
||||||
--- a/Makefile.util.def
|
--- a/Makefile.util.def
|
||||||
+++ b/Makefile.util.def
|
+++ b/Makefile.util.def
|
||||||
@@ -360,6 +360,13 @@ script = {
|
@@ -423,6 +423,13 @@ script = {
|
||||||
};
|
};
|
||||||
|
|
||||||
script = {
|
script = {
|
||||||
@ -31,7 +32,7 @@ index 058572f..1993f9b 100644
|
|||||||
installdir = grubconf;
|
installdir = grubconf;
|
||||||
diff --git a/util/grub.d/20_ppc_terminfo.in b/util/grub.d/20_ppc_terminfo.in
|
diff --git a/util/grub.d/20_ppc_terminfo.in b/util/grub.d/20_ppc_terminfo.in
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..545ad62
|
index 0000000..10d6658
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/util/grub.d/20_ppc_terminfo.in
|
+++ b/util/grub.d/20_ppc_terminfo.in
|
||||||
@@ -0,0 +1,114 @@
|
@@ -0,0 +1,114 @@
|
||||||
@ -58,7 +59,7 @@ index 0000000..545ad62
|
|||||||
+exec_prefix=@exec_prefix@
|
+exec_prefix=@exec_prefix@
|
||||||
+bindir=@bindir@
|
+bindir=@bindir@
|
||||||
+libdir=@libdir@
|
+libdir=@libdir@
|
||||||
+. ${libdir}/grub/grub-mkconfig_lib
|
+. "@datadir@/@PACKAGE@/grub-mkconfig_lib"
|
||||||
+
|
+
|
||||||
+export TEXTDOMAIN=@PACKAGE@
|
+export TEXTDOMAIN=@PACKAGE@
|
||||||
+export TEXTDOMAINDIR=@localedir@
|
+export TEXTDOMAINDIR=@localedir@
|
||||||
@ -150,5 +151,5 @@ index 0000000..545ad62
|
|||||||
+ terminfo -g ${X}x${Y} ${TERMINAL}
|
+ terminfo -g ${X}x${Y} ${TERMINAL}
|
||||||
+EOF
|
+EOF
|
||||||
--
|
--
|
||||||
1.7.7.6
|
1.7.7.2
|
||||||
|
|
||||||
|
15
grub2.spec
15
grub2.spec
@ -21,8 +21,8 @@
|
|||||||
|
|
||||||
Name: grub2
|
Name: grub2
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.99
|
Version: 2.0
|
||||||
Release: 19%{?dist}.2
|
Release: 0.21%{?dist}
|
||||||
Summary: Bootloader with support for Linux, Multiboot and more
|
Summary: Bootloader with support for Linux, Multiboot and more
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -59,9 +59,8 @@ Requires: gettext os-prober which
|
|||||||
Requires(pre): dracut
|
Requires(pre): dracut
|
||||||
Requires(post): dracut
|
Requires(post): dracut
|
||||||
|
|
||||||
# TODO: ppc
|
|
||||||
# ExclusiveArch: %{ix86} x86_64 %{sparc}
|
# ExclusiveArch: %{ix86} x86_64 %{sparc}
|
||||||
ExcludeArch: s390 s390x ppc64
|
ExcludeArch: s390 s390x
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The GRand Unified Bootloader (GRUB) is a highly configurable and customizable
|
The GRand Unified Bootloader (GRUB) is a highly configurable and customizable
|
||||||
@ -385,6 +384,14 @@ fi
|
|||||||
%attr(0755,root,root)/%{_datarootdir}/grub/
|
%attr(0755,root,root)/%{_datarootdir}/grub/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 29 2012 Peter Jones <pjones@redhat.com> - 2.0-0.21
|
||||||
|
- Remove ppc excludearch lines (dwa)
|
||||||
|
- Update ppc terminfo patch (hamzy)
|
||||||
|
|
||||||
|
* Wed Mar 28 2012 Peter Jones <pjones@redhat.com> - 2.0-0.20
|
||||||
|
- Fix ppc64 vs ppc exclude according to what dwa tells me they need
|
||||||
|
- Fix version number to better match policy.
|
||||||
|
|
||||||
* Tue Mar 27 2012 Dan Horák <dan[at]danny.cz> - 1.99-19.2
|
* Tue Mar 27 2012 Dan Horák <dan[at]danny.cz> - 1.99-19.2
|
||||||
- Add support for serial terminal consoles on PPC by Mark Hamzy
|
- Add support for serial terminal consoles on PPC by Mark Hamzy
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user