Compiler flags: ignore incompatible types for now as it prevents
CI builds Signed-off-by: Nicolas Frayer <nfrayer@redhat.com>
This commit is contained in:
parent
d2d9f6012b
commit
6cc927e76b
28
0349-Ignore-warnings-for-incompatible-types.patch
Normal file
28
0349-Ignore-warnings-for-incompatible-types.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Frayer <nfrayer@redhat.com>
|
||||
Date: Wed, 17 Jan 2024 21:15:14 +0100
|
||||
Subject: [PATCH] Ignore warnings for incompatible types
|
||||
|
||||
Add -Wno-incompatible-pointer-types to ignore warnings for incompatible
|
||||
types
|
||||
|
||||
Signed-off-by: Nicolas Frayer <nfrayer@redhat.com>
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 79f45ef1e14c..b66e07c67851 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2009,8 +2009,8 @@ if test x"$enable_wextra" != xno ; then
|
||||
HOST_CFLAGS="$HOST_CFLAGS -Wextra"
|
||||
fi
|
||||
|
||||
-TARGET_CFLAGS="$TARGET_CFLAGS -Werror=trampolines -fno-trampolines"
|
||||
-HOST_CFLAGS="$HOST_CFLAGS -Werror=trampolines -fno-trampolines"
|
||||
+TARGET_CFLAGS="$TARGET_CFLAGS -Werror=trampolines -fno-trampolines -Wno-incompatible-pointer-types"
|
||||
+HOST_CFLAGS="$HOST_CFLAGS -Werror=trampolines -fno-trampolines -Wno-incompatible-pointer-types"
|
||||
|
||||
TARGET_CPP="$TARGET_CC -E"
|
||||
TARGET_CCAS=$TARGET_CC
|
@ -346,3 +346,4 @@ Patch0345: 0345-fs-xfs-Add-large-extent-counters-incompat-feature-su.patch
|
||||
Patch0346: 0346-chainloader-remove-device-path-debug-message.patch
|
||||
Patch0347: 0347-normal-Remove-grub_env_set-prefix-in-grub_try_normal.patch
|
||||
Patch0348: 0348-add-flag-to-only-search-root-dev.patch
|
||||
Patch0349: 0349-Ignore-warnings-for-incompatible-types.patch
|
||||
|
@ -17,7 +17,7 @@
|
||||
Name: grub2
|
||||
Epoch: 1
|
||||
Version: 2.06
|
||||
Release: 116%{?dist}
|
||||
Release: 117%{?dist}
|
||||
Summary: Bootloader with support for Linux, Multiboot and more
|
||||
License: GPL-3.0-or-later
|
||||
URL: http://www.gnu.org/software/grub/
|
||||
@ -554,6 +554,10 @@ mv ${EFI_HOME}/grub.cfg.stb ${EFI_HOME}/grub.cfg
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 17 2024 Nicolas Frayer <nfrayer@redhat.com> - 2.06-117
|
||||
- Compiler flags: ignore incompatible types for now as it prevents
|
||||
CI builds
|
||||
|
||||
* Wed Jan 17 2024 Nicolas Frayer <nfrayer@redhat.com> - 2.06-116
|
||||
- grub-core/commands: add flag to only search root dev
|
||||
- Resolves: #2223437
|
||||
|
Loading…
Reference in New Issue
Block a user